aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-trivial-features-clisp/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-17 15:48:42 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-17 15:48:42 +0000
commitace97b2c934087a565bc9e9d77e4b9802d6a5a0a (patch)
tree62b349d628e31cdebbdfffe6f72a77765d8621cd /devel/cl-trivial-features-clisp/Makefile
parenteac60cc50d98946653622ff3e686761416564b4a (diff)
Notes
Diffstat (limited to 'devel/cl-trivial-features-clisp/Makefile')
-rw-r--r--devel/cl-trivial-features-clisp/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/cl-trivial-features-clisp/Makefile b/devel/cl-trivial-features-clisp/Makefile
new file mode 100644
index 000000000000..ac8a7dae1a55
--- /dev/null
+++ b/devel/cl-trivial-features-clisp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: cl-trivial-features-clisp
+# Date created: 16 January 2010
+# Whom: Jimmy Olgeni <olgeni@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= trivial-features
+PORTVERSION= 2010.01.16
+CATEGORIES= devel lisp
+PKGNAMEPREFIX= cl-
+DISTFILES= # none
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Ensures consistent *FEATURES* in Common Lisp
+
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-features/trivial-features.asd:${PORTSDIR}/devel/cl-trivial-features
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-features/trivial-features.asd:${PORTSDIR}/devel/cl-trivial-features
+
+USE_ASDF_FASL= yes
+FASL_TARGET= clisp
+FASL_BUILD= yes
+
+do-install:
+ @${MKDIR} ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
+ @${INSTALL_DATA} ${WRKSRC}/*.fasl ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
+
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
+.include <bsd.port.mk>