aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-uffi-sbcl/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
commit1ac224e5633aab81a4aa7a40d84308751aa6bbe1 (patch)
tree364e168d1c32783717ae24623ca009a9e3afac74 /devel/cl-uffi-sbcl/Makefile
parent0771132bce39427ace1fc0c1a360e09e40965a9d (diff)
Notes
Diffstat (limited to 'devel/cl-uffi-sbcl/Makefile')
-rw-r--r--devel/cl-uffi-sbcl/Makefile28
1 files changed, 10 insertions, 18 deletions
diff --git a/devel/cl-uffi-sbcl/Makefile b/devel/cl-uffi-sbcl/Makefile
index a087af427ed0..88746c9ae262 100644
--- a/devel/cl-uffi-sbcl/Makefile
+++ b/devel/cl-uffi-sbcl/Makefile
@@ -6,32 +6,24 @@
PORTNAME= uffi
PORTVERSION= 1.6.2
+PORTREVISION= 1
CATEGORIES= devel lisp
-MASTER_SITES= # use installed sources from CL_LIBDIR
PKGNAMEPREFIX= cl-
-PKGNAMESUFFIX= -sbcl
-DISTFILES= # use installed sources from CL_LIBDIR
-EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Universal Foreign Function Interface for Common Lisp (SBCL binaries)
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/uffi/uffi.asd:${PORTSDIR}/devel/cl-uffi \
- sbcl:${PORTSDIR}/lang/sbcl
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
- sbcl:${PORTSDIR}/lang/sbcl
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/uffi/uffi.asd:${PORTSDIR}/devel/cl-uffi
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/port/port.asd:${PORTSDIR}/devel/cl-port
-CL_LIBDIR?= ${LOCALBASE}/lib/common-lisp
-
-do-build:
- @FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
- sbcl --noinform --userinit /dev/null --disable-debugger \
- --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
- --eval "(asdf:oos 'asdf:compile-op :uffi)" \
- --eval "(quit)"
+USE_ASDF_FASL= yes
+FASL_TARGET= sbcl
+FASL_BUILD= yes
do-install:
- @${MKDIR} ${CL_LIBDIR}/uffi/src/sbclfasl
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${CL_LIBDIR}/uffi/src/sbclfasl/
+ @${MKDIR} ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
+ @${INSTALL_DATA} ${WRKSRC}/*.fasl ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>