aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-uffi
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
commit1ac224e5633aab81a4aa7a40d84308751aa6bbe1 (patch)
tree364e168d1c32783717ae24623ca009a9e3afac74 /devel/cl-uffi
parent0771132bce39427ace1fc0c1a360e09e40965a9d (diff)
Remove redundant code and variables from the cl-* ports.
Introduce bsd.cl-asdf.mk to automate the compilation and installation of Common Lisp libraries using the ASDF framework. Currently it supports building FASL files on SBCL and CLISP, to support the ports that already exist in the ports tree. This should help bringing in more cl-* ports from the ASDF repository without excessive code duplication.
Notes
Notes: svn path=/head/; revision=247937
Diffstat (limited to 'devel/cl-uffi')
-rw-r--r--devel/cl-uffi/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/devel/cl-uffi/Makefile b/devel/cl-uffi/Makefile
index f30d8b88a0a3..700602772eb6 100644
--- a/devel/cl-uffi/Makefile
+++ b/devel/cl-uffi/Makefile
@@ -6,26 +6,24 @@
PORTNAME= uffi
PORTVERSION= 1.6.2
+PORTREVISION= 2
CATEGORIES= devel lisp
-MASTER_SITES= http://files.b9.com/uffi/
PKGNAMEPREFIX= cl-
+MASTER_SITES= http://files.b9.com/uffi/
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Universal Foreign Function Interface for Common Lisp
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-
-DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
NO_BUILD= yes
-CL_LIBDIR?= ${LOCALBASE}/lib/common-lisp
+
+USE_ASDF= yes
do-install:
- @${MKDIR} ${CL_LIBDIR}/uffi
- @${MKDIR} ${CL_LIBDIR}/uffi/src
- @${INSTALL_DATA} ${WRKSRC}/uffi.asd ${CL_LIBDIR}/uffi/
- @${INSTALL_DATA} ${WRKSRC}/src/*.lisp ${CL_LIBDIR}/uffi/src/
- @${LN} -sf ${CL_LIBDIR}/uffi/uffi.asd ${CL_LIBDIR}/system-registry/uffi.asd
+ @${MKDIR} ${ASDF_PATHNAME}
+ @${MKDIR} ${ASDF_PATHNAME}/src
+ @${INSTALL_DATA} ${WRKSRC}/uffi.asd ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/src/*.lisp ${ASDF_PATHNAME}/src
+ @${LN} -sf ${ASDF_PATHNAME}/*.asd ${ASDF_REGISTRY}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${TAR} -C ${DOCSDIR} -xf ${WRKSRC}/doc/html.tar.gz
@@ -42,4 +40,5 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>