aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-uffi
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-13 11:35:08 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-13 11:35:08 +0000
commitb747f4b76917036b679631e2ad26143e400fa25e (patch)
tree8ac6c541fc05169b6b162148616e734cc4bcef97 /devel/cl-uffi
parenta947283b91bb706636565449fbebf27e930769b0 (diff)
downloadports-b747f4b76917036b679631e2ad26143e400fa25e.tar.gz
ports-b747f4b76917036b679631e2ad26143e400fa25e.zip
Notes
Diffstat (limited to 'devel/cl-uffi')
-rw-r--r--devel/cl-uffi/Makefile24
-rw-r--r--devel/cl-uffi/pkg-plist117
2 files changed, 95 insertions, 46 deletions
diff --git a/devel/cl-uffi/Makefile b/devel/cl-uffi/Makefile
index d260d662bac6..1e299c552fc5 100644
--- a/devel/cl-uffi/Makefile
+++ b/devel/cl-uffi/Makefile
@@ -21,13 +21,6 @@ DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
NO_BUILD= yes
CL_LIBDIR?= ${LOCALBASE}/lib/common-lisp
-LPORTDOCS= AUTHORS ChangeLog INSTALL LICENSE Makefile.common NEWS README TODO \
- doc/uffi.pdf doc/html.tar.gz
-LPORTEXAMPLES= Makefile Makefile.msvc acl-compat-tester.lisp arrays.lisp atoifl.lisp \
- c-test-fns.c c-test-fns.lisp compress.lisp file-socket.lisp getenv.lisp \
- gethostname.lisp getshells.lisp gettime.lisp run-examples.lisp \
- strtol.lisp test-examples.lisp union.lisp
-
do-install:
@${MKDIR} ${CL_LIBDIR}/uffi
@${MKDIR} ${CL_LIBDIR}/uffi/src
@@ -36,13 +29,18 @@ do-install:
@${LN} -sf ${CL_LIBDIR}/uffi/uffi.asd ${CL_LIBDIR}/system-registry/uffi.asd
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for i in ${LPORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
-.endfor
- @${MKDIR} ${DOCSDIR}/examples
-.for i in ${LPORTEXAMPLES}
- @${INSTALL_DATA} ${WRKSRC}/examples/${i} ${DOCSDIR}/examples/
+ @${TAR} -C ${DOCSDIR} -xf ${WRKSRC}/doc/html.tar.gz
+ @${CHOWN} ${DOCOWN}:${DOCGRP} ${DOCSDIR}/html/*
+ @${CHMOD} ${DOCMODE} ${DOCSDIR}/html/*
+ @${INSTALL_DATA} ${WRKSRC}/doc/uffi.pdf ${DOCSDIR}
+.for FILE in AUTHORS ChangeLog INSTALL LICENSE NEWS README TODO
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/cl-uffi/pkg-plist b/devel/cl-uffi/pkg-plist
index 755e3632fce8..29f63c6ee913 100644
--- a/devel/cl-uffi/pkg-plist
+++ b/devel/cl-uffi/pkg-plist
@@ -1,42 +1,93 @@
-lib/common-lisp/system-registry/uffi.asd
-lib/common-lisp/uffi/uffi.asd
-lib/common-lisp/uffi/src/aggregates.lisp
-lib/common-lisp/uffi/src/functions.lisp
-lib/common-lisp/uffi/src/libraries.lisp
-lib/common-lisp/uffi/src/objects.lisp
-lib/common-lisp/uffi/src/os.lisp
-lib/common-lisp/uffi/src/package.lisp
-lib/common-lisp/uffi/src/primitives.lisp
-lib/common-lisp/uffi/src/readmacros-mcl.lisp
-lib/common-lisp/uffi/src/strings.lisp
+%%LIB32DIR%%/common-lisp/system-registry/uffi.asd
+%%LIB32DIR%%/common-lisp/uffi/src/aggregates.lisp
+%%LIB32DIR%%/common-lisp/uffi/src/functions.lisp
+%%LIB32DIR%%/common-lisp/uffi/src/libraries.lisp
+%%LIB32DIR%%/common-lisp/uffi/src/objects.lisp
+%%LIB32DIR%%/common-lisp/uffi/src/os.lisp
+%%LIB32DIR%%/common-lisp/uffi/src/package.lisp
+%%LIB32DIR%%/common-lisp/uffi/src/primitives.lisp
+%%LIB32DIR%%/common-lisp/uffi/src/readmacros-mcl.lisp
+%%LIB32DIR%%/common-lisp/uffi/src/strings.lisp
+%%LIB32DIR%%/common-lisp/uffi/uffi.asd
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/Makefile.common
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/examples/Makefile
-%%PORTDOCS%%%%DOCSDIR%%/examples/Makefile.msvc
-%%PORTDOCS%%%%DOCSDIR%%/examples/acl-compat-tester.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/arrays.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/atoifl.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/c-test-fns.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/c-test-fns.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/compress.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/file-socket.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/getenv.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/gethostname.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/getshells.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/gettime.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/run-examples.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/strtol.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/test-examples.lisp
-%%PORTDOCS%%%%DOCSDIR%%/examples/union.lisp
+%%PORTDOCS%%%%DOCSDIR%%/html/aggregates.html
+%%PORTDOCS%%%%DOCSDIR%%/html/allocate-foreign-object.html
+%%PORTDOCS%%%%DOCSDIR%%/html/allocate-foreign-string.html
+%%PORTDOCS%%%%DOCSDIR%%/html/background.html
+%%PORTDOCS%%%%DOCSDIR%%/html/convert-from-cstring.html
+%%PORTDOCS%%%%DOCSDIR%%/html/convert-from-foreign-string.html
+%%PORTDOCS%%%%DOCSDIR%%/html/convert-to-cstring.html
+%%PORTDOCS%%%%DOCSDIR%%/html/convert-to-foreign-string.html
+%%PORTDOCS%%%%DOCSDIR%%/html/def-array-pointer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/def-constant.html
+%%PORTDOCS%%%%DOCSDIR%%/html/def-enum.html
+%%PORTDOCS%%%%DOCSDIR%%/html/def-foreign-type.html
+%%PORTDOCS%%%%DOCSDIR%%/html/def-foreign-var.html
+%%PORTDOCS%%%%DOCSDIR%%/html/def-function.html
+%%PORTDOCS%%%%DOCSDIR%%/html/def-struct.html
+%%PORTDOCS%%%%DOCSDIR%%/html/def-type.html
+%%PORTDOCS%%%%DOCSDIR%%/html/def-union.html
+%%PORTDOCS%%%%DOCSDIR%%/html/deref-array.html
+%%PORTDOCS%%%%DOCSDIR%%/html/deref-pointer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/design.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ensure-char-character.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ensure-char-integer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/find-foreign-library.html
+%%PORTDOCS%%%%DOCSDIR%%/html/free-cstring.html
+%%PORTDOCS%%%%DOCSDIR%%/html/free-foreign-object.html
+%%PORTDOCS%%%%DOCSDIR%%/html/func_libr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/get-slot-pointer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/get-slot-value.html
+%%PORTDOCS%%%%DOCSDIR%%/html/glossary.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/installation.html
+%%PORTDOCS%%%%DOCSDIR%%/html/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/load-foreign-library.html
+%%PORTDOCS%%%%DOCSDIR%%/html/loading.html
+%%PORTDOCS%%%%DOCSDIR%%/html/make-null-pointer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/notes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/null-char-p.html
+%%PORTDOCS%%%%DOCSDIR%%/html/null-cstring-pointer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/null-pointer-p.html
+%%PORTDOCS%%%%DOCSDIR%%/html/object-represen.html
+%%PORTDOCS%%%%DOCSDIR%%/html/objects.html
+%%PORTDOCS%%%%DOCSDIR%%/html/optimizing.html
+%%PORTDOCS%%%%DOCSDIR%%/html/pointer-address.html
+%%PORTDOCS%%%%DOCSDIR%%/html/preface.html
+%%PORTDOCS%%%%DOCSDIR%%/html/primitives.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ref_declarations.html
+%%PORTDOCS%%%%DOCSDIR%%/html/size-of-foreign-type.html
+%%PORTDOCS%%%%DOCSDIR%%/html/strings.html
+%%PORTDOCS%%%%DOCSDIR%%/html/supported-impl.html
+%%PORTDOCS%%%%DOCSDIR%%/html/with-cast-pointer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/with-cstring.html
+%%PORTDOCS%%%%DOCSDIR%%/html/with-foreign-object.html
%%PORTDOCS%%%%DOCSDIR%%/uffi.pdf
-%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm lib/common-lisp/uffi/src
-@dirrm lib/common-lisp/uffi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.msvc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/acl-compat-tester.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arrays.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/atoifl.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c-test-fns.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c-test-fns.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file-socket.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getenv.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gethostname.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getshells.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gettime.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run-examples.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/strtol.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-examples.lisp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/union.lisp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%LIB32DIR%%/common-lisp/uffi/src
+@dirrm %%LIB32DIR%%/common-lisp/uffi