aboutsummaryrefslogtreecommitdiff
path: root/devel/clanlib
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2013-09-01 15:19:48 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2013-09-01 15:19:48 +0000
commit4347d9e45fdb790dcf372cbce6ecc948b4671c39 (patch)
tree3ceb89fdae3de54c0b84178c14a4b02cfab25f9c /devel/clanlib
parentdd7c2bf519f90d0df052d40896f2408853f934e0 (diff)
downloadports-4347d9e45fdb790dcf372cbce6ecc948b4671c39.tar.gz
ports-4347d9e45fdb790dcf372cbce6ecc948b4671c39.zip
Notes
Diffstat (limited to 'devel/clanlib')
-rw-r--r--devel/clanlib/Makefile16
-rw-r--r--devel/clanlib/distinfo4
-rw-r--r--devel/clanlib/files/patch-Sources__Core__System__Unix__init_linux.cpp11
-rw-r--r--devel/clanlib/files/patch-Sources__Core__System__system.cpp34
4 files changed, 12 insertions, 53 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index d94b0a973266..2b647912b8e4 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= clanlib
-PORTVERSION= 2.3.6
-PORTREVISION= 1
+PORTVERSION= 2.3.7
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.clanlib.org/download/releases-2.0/
@@ -21,12 +20,12 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
mikmod:${PORTSDIR}/audio/libmikmod \
vorbis:${PORTSDIR}/audio/libvorbis \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- pcre:${PORTSDIR}/devel/pcre
+ pcre:${PORTSDIR}/devel/pcre \
+ execinfo:${PORTSDIR}/devel/libexecinfo
-USE_GMAKE= yes
USE_GCC= yes
USE_XORG= x11
-USES= pathfix pkgconfig
+USES= gmake pathfix pkgconfig
USE_LDCONFIG= yes
USE_GL= yes
USE_SQLITE= yes
@@ -56,5 +55,10 @@ PLIST_SUB+= VER=${PORTVERSION:R} \
post-patch:
@${REINPLACE_CMD} -e 's|LIBS="-lsqlite3 -ldl"|LIBS="-lsqlite3"|g' \
${WRKSRC}/configure
-
+ @${REINPLACE_CMD} -e '114 s|/proc/self/exe|/proc/curproc/file|g' \
+ ${WRKSRC}/Sources/Core/System/Unix/init_linux.cpp
+ @${REINPLACE_CMD} -e 's|APPLE|FreeBSD|g' \
+ ${WRKSRC}/Sources/Core/System/system.cpp
+ @${REINPLACE_CMD} -e '47 s|#ifndef __FreeBSD__|#if !defined(__FreeBSD__)|g' \
+ ${WRKSRC}/Sources/Core/System/system.cpp
.include <bsd.port.mk>
diff --git a/devel/clanlib/distinfo b/devel/clanlib/distinfo
index 5547b0ee591d..93084dd70a83 100644
--- a/devel/clanlib/distinfo
+++ b/devel/clanlib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ClanLib-2.3.6.tgz) = b8dc9b41028bf16c0a6082aa15cdee5d8b1ecd5256797576970f09a63e3fafde
-SIZE (ClanLib-2.3.6.tgz) = 25605576
+SHA256 (ClanLib-2.3.7.tgz) = d46127c08103f48d15936ceb9f95b3dfb1ff8ccba667cef1b3f8e639cb2601c2
+SIZE (ClanLib-2.3.7.tgz) = 26132425
diff --git a/devel/clanlib/files/patch-Sources__Core__System__Unix__init_linux.cpp b/devel/clanlib/files/patch-Sources__Core__System__Unix__init_linux.cpp
deleted file mode 100644
index 06cadba92602..000000000000
--- a/devel/clanlib/files/patch-Sources__Core__System__Unix__init_linux.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Sources/Core/System/Unix/init_linux.cpp.orig 2012-03-05 06:24:31.000000000 -0500
-+++ ./Sources/Core/System/Unix/init_linux.cpp 2012-09-25 07:42:19.000000000 -0400
-@@ -111,7 +111,7 @@
-
- #else
- #ifndef PROC_EXE_PATH
--#define PROC_EXE_PATH "/proc/self/exe"
-+#define PROC_EXE_PATH "/proc/curproc/file"
- #endif
- int size;
- struct stat sb;
diff --git a/devel/clanlib/files/patch-Sources__Core__System__system.cpp b/devel/clanlib/files/patch-Sources__Core__System__system.cpp
deleted file mode 100644
index 218a7c5e75fa..000000000000
--- a/devel/clanlib/files/patch-Sources__Core__System__system.cpp
+++ /dev/null
@@ -1,34 +0,0 @@
---- ./Sources/Core/System/system.cpp.orig 2012-09-25 07:46:49.000000000 -0400
-+++ ./Sources/Core/System/system.cpp 2012-09-25 07:57:19.000000000 -0400
-@@ -1,3 +1,4 @@
-+
- /*
- ** ClanLib SDK
- ** Copyright (c) 1997-2011 The ClanLib Team
-@@ -44,7 +45,7 @@
- #include <sys/sysctl.h>
- #endif
-
--#ifndef __APPLE__
-+#if !(defined(__APPLE__) || defined(__FreeBSD__))
- #include <execinfo.h>
- #endif
- #include <cxxabi.h>
-@@ -128,7 +129,7 @@
- *out_hash = 0;
- return capturedFrames;
-
--#elif !defined(__APPLE__)
-+#elif !(defined(__APPLE__) || defined(__FreeBSD__))
- // Ensure the output is cleared
- memset(out_frames, 0, (sizeof(void *)) * max_frames);
-
-@@ -188,7 +189,7 @@
- SymCleanup(GetCurrentProcess());
- return backtrace_text;
-
--#elif !defined(__APPLE__)
-+#elif !(defined(__APPLE__) || defined(__FreeBSD__))
-
- char **strings;
- strings = backtrace_symbols(frames, num_frames);