aboutsummaryrefslogtreecommitdiff
path: root/devel/clanlib
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-07-26 18:51:40 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-07-26 18:51:40 +0000
commit7788fa551c750796e572ffa1952a95bb7a618583 (patch)
treeca893a37398d4d7a347a8cb2cba15d23d98ff1fc /devel/clanlib
parent7b1651856d7bb6621753c7273db70346dec5efd1 (diff)
downloadports-7788fa551c750796e572ffa1952a95bb7a618583.tar.gz
ports-7788fa551c750796e572ffa1952a95bb7a618583.zip
Notes
Diffstat (limited to 'devel/clanlib')
-rw-r--r--devel/clanlib/Makefile2
-rw-r--r--devel/clanlib/files/patch-Sources_Core_System_detect__cpu__ext.cpp12
2 files changed, 5 insertions, 9 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index 720f782b7158..cb73b23fd2c2 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= clanlib
PORTVERSION= 2.3.7
-PORTREVISION= 12
+PORTREVISION= 13
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.clanlib.org/download/releases-2.0/
diff --git a/devel/clanlib/files/patch-Sources_Core_System_detect__cpu__ext.cpp b/devel/clanlib/files/patch-Sources_Core_System_detect__cpu__ext.cpp
index b21b0fd7e9b7..c77477f9711f 100644
--- a/devel/clanlib/files/patch-Sources_Core_System_detect__cpu__ext.cpp
+++ b/devel/clanlib/files/patch-Sources_Core_System_detect__cpu__ext.cpp
@@ -1,15 +1,11 @@
--- Sources/Core/System/detect_cpu_ext.cpp.orig 2011-11-15 12:15:42 UTC
+++ Sources/Core/System/detect_cpu_ext.cpp
-@@ -30,6 +30,7 @@
+@@ -30,7 +30,7 @@
#include "Core/precomp.h"
#include "API/Core/System/system.h"
-+#ifndef CL_DISABLE_SSE2
- #ifdef CL_ARM_PLATFORM
+-#ifdef CL_ARM_PLATFORM
++#if defined(CL_ARM_PLATFORM) || defined(CL_DISABLE_SSE2)
bool CL_System::detect_cpu_extension(CL_CPU_ExtensionPPC ext)
{
-@@ -183,3 +184,4 @@ bool CL_System::detect_cpu_extension(CL_CPU_ExtensionX
- }
-
- #endif
-+#endif // not CL_DISABLE_SSE2
+ throw ("Congratulations, you've just been selected to code this feature!");