aboutsummaryrefslogtreecommitdiff
path: root/devel/cloudabi-libc++
diff options
context:
space:
mode:
authorEd Schouten <ed@FreeBSD.org>2015-07-08 13:09:07 +0000
committerEd Schouten <ed@FreeBSD.org>2015-07-08 13:09:07 +0000
commit55ad3098ed74b249b1abc7931781ec4be55aaf75 (patch)
tree7a1d8c4ef12b1799568b7a9af741c343d92dcb44 /devel/cloudabi-libc++
parent3df4f13fa148625b0b48f12f046f60cf79321881 (diff)
Notes
Diffstat (limited to 'devel/cloudabi-libc++')
-rw-r--r--devel/cloudabi-libc++/Makefile2
-rw-r--r--devel/cloudabi-libc++/distinfo8
-rw-r--r--devel/cloudabi-libc++/files/patch-include_locale18
-rw-r--r--devel/cloudabi-libc++/files/patch-src_locale.cpp128
4 files changed, 5 insertions, 151 deletions
diff --git a/devel/cloudabi-libc++/Makefile b/devel/cloudabi-libc++/Makefile
index 2ea589670532..99b9c3eac8c9 100644
--- a/devel/cloudabi-libc++/Makefile
+++ b/devel/cloudabi-libc++/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libc++
-PORTVERSION= 0.240527
+PORTVERSION= 0.241676
CATEGORIES= devel
MASTER_SITES= https://nuxi.nl/distfiles/libc++/:libcxx \
https://nuxi.nl/distfiles/libc++abi/:libcxxabi
diff --git a/devel/cloudabi-libc++/distinfo b/devel/cloudabi-libc++/distinfo
index b64e3835cba3..d16963766c2d 100644
--- a/devel/cloudabi-libc++/distinfo
+++ b/devel/cloudabi-libc++/distinfo
@@ -1,4 +1,4 @@
-SHA256 (libc++-0.240527.tar.xz) = 6775bb5ef2cacc71cd40d70ce54d77237333cb9ea83f1d06e0fd10fe58561f44
-SIZE (libc++-0.240527.tar.xz) = 967240
-SHA256 (libc++abi-0.240527.tar.xz) = 16b206bb5ad40fbd40f69f79c31924aa9efe7e01255f69962361f873f13b4c29
-SIZE (libc++abi-0.240527.tar.xz) = 507212
+SHA256 (libc++-0.241676.tar.xz) = f95aa5a100128377e52313456d3016125182186df11109e434ad7f9b8ed25f1d
+SIZE (libc++-0.241676.tar.xz) = 959656
+SHA256 (libc++abi-0.241676.tar.xz) = 204a6772d70e1ad910117ca30335718ac9f344df555145abbe34b0bbf14ed50e
+SIZE (libc++abi-0.241676.tar.xz) = 506816
diff --git a/devel/cloudabi-libc++/files/patch-include_locale b/devel/cloudabi-libc++/files/patch-include_locale
deleted file mode 100644
index 39b2e097e289..000000000000
--- a/devel/cloudabi-libc++/files/patch-include_locale
+++ /dev/null
@@ -1,18 +0,0 @@
---- include/locale.orig 2015-06-17 04:49:22 UTC
-+++ include/locale
-@@ -1297,13 +1297,13 @@ __num_put<_CharT>::__widen_and_group_flo
- *__oe++ = __ct.widen(*__nf++);
- *__oe++ = __ct.widen(*__nf++);
- for (__ns = __nf; __ns < __ne; ++__ns)
-- if (!isxdigit_l(*__ns, _LIBCPP_GET_C_LOCALE))
-+ if (!isxdigit(*__ns))
- break;
- }
- else
- {
- for (__ns = __nf; __ns < __ne; ++__ns)
-- if (!isdigit_l(*__ns, _LIBCPP_GET_C_LOCALE))
-+ if (!isdigit(*__ns))
- break;
- }
- if (__grouping.empty())
diff --git a/devel/cloudabi-libc++/files/patch-src_locale.cpp b/devel/cloudabi-libc++/files/patch-src_locale.cpp
deleted file mode 100644
index 9a29c36a5542..000000000000
--- a/devel/cloudabi-libc++/files/patch-src_locale.cpp
+++ /dev/null
@@ -1,128 +0,0 @@
---- src/locale.cpp.orig 2015-06-24 08:46:54 UTC
-+++ src/locale.cpp
-@@ -575,8 +575,6 @@ locale::global(const locale& loc)
- locale& g = __global();
- locale r = g;
- g = loc;
-- if (g.name() != "*")
-- setlocale(LC_ALL, g.name().c_str());
- return r;
- }
-
-@@ -813,7 +811,7 @@ ctype<wchar_t>::do_toupper(char_type c)
- #elif defined(__GLIBC__) || defined(__EMSCRIPTEN__) || defined(__NetBSD__)
- return isascii(c) ? ctype<char>::__classic_upper_table()[c] : c;
- #else
-- return (isascii(c) && iswlower_l(c, __cloc())) ? c-L'a'+L'A' : c;
-+ return (isascii(c) && iswlower(c)) ? c-L'a'+L'A' : c;
- #endif
- }
-
-@@ -827,7 +825,7 @@ ctype<wchar_t>::do_toupper(char_type* lo
- *low = isascii(*low) ? ctype<char>::__classic_upper_table()[*low]
- : *low;
- #else
-- *low = (isascii(*low) && islower_l(*low, __cloc())) ? (*low-L'a'+L'A') : *low;
-+ *low = (isascii(*low) && islower(*low)) ? (*low-L'a'+L'A') : *low;
- #endif
- return low;
- }
-@@ -840,7 +838,7 @@ ctype<wchar_t>::do_tolower(char_type c)
- #elif defined(__GLIBC__) || defined(__EMSCRIPTEN__) || defined(__NetBSD__)
- return isascii(c) ? ctype<char>::__classic_lower_table()[c] : c;
- #else
-- return (isascii(c) && isupper_l(c, __cloc())) ? c-L'A'+'a' : c;
-+ return (isascii(c) && isupper(c)) ? c-L'A'+'a' : c;
- #endif
- }
-
-@@ -854,7 +852,7 @@ ctype<wchar_t>::do_tolower(char_type* lo
- *low = isascii(*low) ? ctype<char>::__classic_lower_table()[*low]
- : *low;
- #else
-- *low = (isascii(*low) && isupper_l(*low, __cloc())) ? *low-L'A'+L'a' : *low;
-+ *low = (isascii(*low) && isupper(*low)) ? *low-L'A'+L'a' : *low;
- #endif
- return low;
- }
-@@ -923,7 +921,7 @@ ctype<char>::do_toupper(char_type c) con
- return isascii(c) ?
- static_cast<char>(__classic_upper_table()[static_cast<unsigned char>(c)]) : c;
- #else
-- return (isascii(c) && islower_l(c, __cloc())) ? c-'a'+'A' : c;
-+ return (isascii(c) && islower(c)) ? c-'a'+'A' : c;
- #endif
- }
-
-@@ -940,7 +938,7 @@ ctype<char>::do_toupper(char_type* low,
- *low = isascii(*low) ?
- static_cast<char>(__classic_upper_table()[static_cast<size_t>(*low)]) : *low;
- #else
-- *low = (isascii(*low) && islower_l(*low, __cloc())) ? *low-'a'+'A' : *low;
-+ *low = (isascii(*low) && islower(*low)) ? *low-'a'+'A' : *low;
- #endif
- return low;
- }
-@@ -957,7 +955,7 @@ ctype<char>::do_tolower(char_type c) con
- return isascii(c) ?
- static_cast<char>(__classic_lower_table()[static_cast<size_t>(c)]) : c;
- #else
-- return (isascii(c) && isupper_l(c, __cloc())) ? c-'A'+'a' : c;
-+ return (isascii(c) && isupper(c)) ? c-'A'+'a' : c;
- #endif
- }
-
-@@ -972,7 +970,7 @@ ctype<char>::do_tolower(char_type* low,
- #elif defined(__GLIBC__) || defined(__EMSCRIPTEN__)
- *low = isascii(*low) ? static_cast<char>(__classic_lower_table()[static_cast<size_t>(*low)]) : *low;
- #else
-- *low = (isascii(*low) && isupper_l(*low, __cloc())) ? *low-'A'+'a' : *low;
-+ *low = (isascii(*low) && isupper(*low)) ? *low-'A'+'a' : *low;
- #endif
- return low;
- }
-@@ -1201,28 +1199,28 @@ ctype_byname<char>::~ctype_byname()
- char
- ctype_byname<char>::do_toupper(char_type c) const
- {
-- return static_cast<char>(toupper_l(static_cast<unsigned char>(c), __l));
-+ return static_cast<char>(toupper(static_cast<unsigned char>(c)));
- }
-
- const char*
- ctype_byname<char>::do_toupper(char_type* low, const char_type* high) const
- {
- for (; low != high; ++low)
-- *low = static_cast<char>(toupper_l(static_cast<unsigned char>(*low), __l));
-+ *low = static_cast<char>(toupper(static_cast<unsigned char>(*low)));
- return low;
- }
-
- char
- ctype_byname<char>::do_tolower(char_type c) const
- {
-- return static_cast<char>(tolower_l(static_cast<unsigned char>(c), __l));
-+ return static_cast<char>(tolower(static_cast<unsigned char>(c)));
- }
-
- const char*
- ctype_byname<char>::do_tolower(char_type* low, const char_type* high) const
- {
- for (; low != high; ++low)
-- *low = static_cast<char>(tolower_l(static_cast<unsigned char>(*low), __l));
-+ *low = static_cast<char>(tolower(static_cast<unsigned char>(*low)));
- return low;
- }
-
-@@ -1707,11 +1705,6 @@ codecvt<wchar_t, char, mbstate_t>::do_un
- int
- codecvt<wchar_t, char, mbstate_t>::do_encoding() const _NOEXCEPT
- {
--#ifdef _LIBCPP_LOCALE__L_EXTENSIONS
-- if (mbtowc_l(nullptr, nullptr, MB_LEN_MAX, __l) == 0)
--#else
-- if (__mbtowc_l(nullptr, nullptr, MB_LEN_MAX, __l) == 0)
--#endif
- {
- // stateless encoding
- #ifdef _LIBCPP_LOCALE__L_EXTENSIONS