aboutsummaryrefslogtreecommitdiff
path: root/devel/cmake-gui/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-09-07 12:09:53 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-09-07 12:09:53 +0000
commitcfc6c4293039552f202f876335e4b66c3747e29a (patch)
treeffb571025437522673ec34290c9b44247880bed5 /devel/cmake-gui/Makefile
parent679e84470dc12a145262007bd7529a3bdd65f0c7 (diff)
Notes
Diffstat (limited to 'devel/cmake-gui/Makefile')
-rw-r--r--devel/cmake-gui/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/devel/cmake-gui/Makefile b/devel/cmake-gui/Makefile
index 7b21c7de4d11..301247ba6888 100644
--- a/devel/cmake-gui/Makefile
+++ b/devel/cmake-gui/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= cmake
-PORTVERSION= 3.2.3
-PORTREVISION= 1
+PORTVERSION= 3.3.1
CATEGORIES= devel
-MASTER_SITES= http://www.cmake.org/files/v3.2/
+MASTER_SITES= http://www.cmake.org/files/v3.3/
PKGNAMESUFFIX= -gui
MAINTAINER= kde@FreeBSD.org
@@ -17,7 +16,7 @@ LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
libexpat.so:${PORTSDIR}/textproc/expat2
USE_QT5= core gui widgets buildtools_build qmake_build
-USES= cmake:run desktop-file-utils shared-mime-info
+USES= cmake:run desktop-file-utils libarchive shared-mime-info
CMAKE_ARGS= -DBUILD_QtDialog:bool=on \
-DBUILD_CursesDialog:BOOL=OFF \
-DSPHINX_MAN:BOOL=ON \
@@ -30,14 +29,6 @@ INSTALL_WRKSRC= ${WRKSRC}/Source/QtDialog
DISTINFO_FILE= ${.CURDIR}/../cmake/distinfo
-.include <bsd.port.pre.mk>
-
-# CMake >= 3.1.0 needs libarchive3 because it calls
-# archive_entry_copy_sourcepath_w and archive_write_set_format_7zip.
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000009
-LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
-.endif
-
post-patch:
@(${FIND} ${WRKSRC}/Modules -name "*.cmake" -print0; \
${FIND} ${WRKSRC}/Tests -name "CMakeLists.txt" -print0 ) | \
@@ -51,4 +42,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/Utilities/Sphinx/man/cmake-gui.1 \
${STAGEDIR}${PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>