aboutsummaryrefslogtreecommitdiff
path: root/devel/cmake
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2011-09-11 02:04:09 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2011-09-11 02:04:09 +0000
commit44cfcd60fb9fe35365e3e44c13b34cd099ff0e53 (patch)
tree4038df2e47e1df8311d44cd6451a80251b8b6e27 /devel/cmake
parent33624c0958c0d0c5470cfb9699a778ee0c5d5400 (diff)
downloadports-44cfcd60fb9fe35365e3e44c13b34cd099ff0e53.tar.gz
ports-44cfcd60fb9fe35365e3e44c13b34cd099ff0e53.zip
Notes
Diffstat (limited to 'devel/cmake')
-rw-r--r--devel/cmake/Makefile2
-rw-r--r--devel/cmake/files/patch-Modules_Compiler_GNU.cmake14
2 files changed, 1 insertions, 15 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index 49967a7e8a33..1118b8d3792d 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cmake
PORTVERSION= 2.8.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.${PORTNAME}.org/files/v${PORTVERSION:C/\.[[:digit:]]+$//}/
diff --git a/devel/cmake/files/patch-Modules_Compiler_GNU.cmake b/devel/cmake/files/patch-Modules_Compiler_GNU.cmake
deleted file mode 100644
index 06a5aadf5f67..000000000000
--- a/devel/cmake/files/patch-Modules_Compiler_GNU.cmake
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./Modules/Compiler/GNU.cmake.orig 2011-02-15 20:47:27.000000000 +0300
-+++ ./Modules/Compiler/GNU.cmake 2011-04-09 13:43:24.030760248 +0400
-@@ -26,9 +26,9 @@
-
- # Initial configuration flags.
- set(CMAKE_${lang}_FLAGS_INIT "")
-- set(CMAKE_${lang}_FLAGS_DEBUG_INIT "-g")
-+ set(CMAKE_${lang}_FLAGS_DEBUG_INIT "")
- set(CMAKE_${lang}_FLAGS_MINSIZEREL_INIT "-Os -DNDEBUG")
-- set(CMAKE_${lang}_FLAGS_RELEASE_INIT "-O3 -DNDEBUG")
-+ set(CMAKE_${lang}_FLAGS_RELEASE_INIT "")
- set(CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT "-O2 -g")
- set(CMAKE_${lang}_CREATE_PREPROCESSED_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <FLAGS> -E <SOURCE> > <PREPROCESSED_SOURCE>")
- set(CMAKE_${lang}_CREATE_ASSEMBLY_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <FLAGS> -S <SOURCE> -o <ASSEMBLY_SOURCE>")