aboutsummaryrefslogtreecommitdiff
path: root/devel/cmake
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-08-29 07:15:12 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-08-29 07:15:12 +0000
commit0343c9319ea1311e8810f84669e023b1d7236dc8 (patch)
treefbdb69cadad5329ece6742143c506a6556bb0664 /devel/cmake
parent66ee82d3be75f67a1e19fde59cec40f1be4698a7 (diff)
downloadports-0343c9319ea1311e8810f84669e023b1d7236dc8.tar.gz
ports-0343c9319ea1311e8810f84669e023b1d7236dc8.zip
Notes
Diffstat (limited to 'devel/cmake')
-rw-r--r--devel/cmake/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index 881cb56c4a75..6719f278c404 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -37,8 +37,14 @@ MAN1= ccmake.1 \
ctest.1
post-patch:
- @${GREP} -rl '/usr/X11R6' ${WRKSRC}/Modules ${WRKSRC}/Tests | \
- ${XARGS} ${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g'
+ @(${FIND} ${WRKSRC}/Modules -name "*.cmake" -print0; \
+ ${FIND} ${WRKSRC}/Tests -name "CMakeLists.txt" -print0 ) | \
+ ${XARGS} -0 -n 100 ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g; \
+ s,/usr/X11R6,${LOCALBASE},g'
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${WRKSRC}/Source/cmLocalGenerator.cxx \
+ ${WRKSRC}/Source/CPack/cmCPackGenerator.cxx \
+ ${WRKSRC}/bootstrap
@${REINPLACE_CMD} -e 's,/opt/kde4,${LOCALBASE}/kde4,g' \
${WRKSRC}/Modules/FindKDE4.cmake