aboutsummaryrefslogtreecommitdiff
path: root/devel/cmunge
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-27 14:09:19 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-27 14:09:19 +0000
commit2c42ab7d995159f8cfdfc70acf42f96a86f17e1f (patch)
tree18c57db13e1ecf1388bede993e360f1cd091874b /devel/cmunge
parent055c6a1be0eb22136ed535485fbf6b8135dd2396 (diff)
downloadports-2c42ab7d995159f8cfdfc70acf42f96a86f17e1f.tar.gz
ports-2c42ab7d995159f8cfdfc70acf42f96a86f17e1f.zip
Notes
Diffstat (limited to 'devel/cmunge')
-rw-r--r--devel/cmunge/Makefile32
-rw-r--r--devel/cmunge/distinfo2
-rw-r--r--devel/cmunge/pkg-descr18
3 files changed, 52 insertions, 0 deletions
diff --git a/devel/cmunge/Makefile b/devel/cmunge/Makefile
new file mode 100644
index 000000000000..29d5c2ba5c68
--- /dev/null
+++ b/devel/cmunge/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: cmunge
+# Date created: October 26th 2005
+# Whom: Frerich Raabe <frerich.raabe@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cmunge
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.vcpc.univie.ac.at/vcpc/jhm/code/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= frerich.raabe@gmx.de
+COMMENT= A tool for encrypting and compacting C source code
+
+WRKSRC= ${WRKDIR}/cmunger
+MAKE_ARGS= CC="${CC} ${CFLAGS}"
+
+PLIST_FILES= bin/cmunge bin/ctran bin/proc-incl
+PORTDOCS= *
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/ctran ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/proc-incl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/cmunge ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cmunge/distinfo b/devel/cmunge/distinfo
new file mode 100644
index 000000000000..39b0a255a4fb
--- /dev/null
+++ b/devel/cmunge/distinfo
@@ -0,0 +1,2 @@
+MD5 (cmunge.tar.gz) = 1ba149c619cacdfbbaf7ec59281b8cc2
+SIZE (cmunge.tar.gz) = 27591
diff --git a/devel/cmunge/pkg-descr b/devel/cmunge/pkg-descr
new file mode 100644
index 000000000000..bfaaf5f215b6
--- /dev/null
+++ b/devel/cmunge/pkg-descr
@@ -0,0 +1,18 @@
+CMUNGE is a simple tool for encrypting and compacting C source code, while
+leaving it syntactically and semantically unchanged. It does this by:
+
+* Recursively in-lining `user-defined' #include files.
+* Renaming C identifiers, except those in the C Standard Library, with names
+ like l1 (i.e. letter-l one), l2, l3, etc.
+* Removing comments and blank lines, converting multiple consecutive whitespace
+ characters (including `\n') into single blanks, removing all unnecessary
+ whitespace between tokens.
+* Outputting the transformed code in lines of least N characters long, where N
+ is a user-specified minimum line length.
+
+It accepts ANSI and K & R C as its input language.
+
+WWW: http://www.vcpc.univie.ac.at/~jhm/cmunge/
+
+- Frerich Raabe
+frerich.raabe@gmx.de