aboutsummaryrefslogtreecommitdiff
path: root/devel/cobf
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-06-11 09:39:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-06-11 09:39:38 +0000
commit3e82ea7898f7cd4378a73a4cd649b2b8fde51645 (patch)
tree0345e2f892104603d3e9442516b1061b32cc4582 /devel/cobf
parentf8fec84c7ed7cd55767696073b73e94278416cd3 (diff)
downloadports-3e82ea7898f7cd4378a73a4cd649b2b8fde51645.tar.gz
ports-3e82ea7898f7cd4378a73a4cd649b2b8fde51645.zip
Notes
Diffstat (limited to 'devel/cobf')
-rw-r--r--devel/cobf/Makefile34
-rw-r--r--devel/cobf/distinfo3
-rw-r--r--devel/cobf/files/patch-makefile26
-rw-r--r--devel/cobf/pkg-descr5
4 files changed, 68 insertions, 0 deletions
diff --git a/devel/cobf/Makefile b/devel/cobf/Makefile
new file mode 100644
index 000000000000..d382aaebefd6
--- /dev/null
+++ b/devel/cobf/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cobf
+# Date created: 14 May 2006
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cobf
+PORTVERSION= 1.06
+CATEGORIES= devel
+MASTER_SITES= http://home.arcor.de/bernhard.baier/${PORTNAME}/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ed@fxq.nl
+COMMENT= C and C++ code obfuscator
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}
+PORTDOCS= COPYING README cobf.pdf
+PLIST_FILES= bin/cobf
+
+do-build:
+ @${MAKE} -C ${WRKSRC}/src/cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/cpp/cobf ${PREFIX}/bin/cobf
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/copyright.txt ${DOCSDIR}/COPYING
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/doc/cobf.pdf ${DOCSDIR}/cobf.pdf
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cobf/distinfo b/devel/cobf/distinfo
new file mode 100644
index 000000000000..b133a9df4e53
--- /dev/null
+++ b/devel/cobf/distinfo
@@ -0,0 +1,3 @@
+MD5 (cobf_1.06.zip) = 81443c440586952c7b2f5d49dbd7e56f
+SHA256 (cobf_1.06.zip) = df3902d52c7e0cea0e5ebd7b463d7f991df023ae2be49fc225f4d3ada2e17789
+SIZE (cobf_1.06.zip) = 199444
diff --git a/devel/cobf/files/patch-makefile b/devel/cobf/files/patch-makefile
new file mode 100644
index 000000000000..21803f77f768
--- /dev/null
+++ b/devel/cobf/files/patch-makefile
@@ -0,0 +1,26 @@
+--- src/cpp/makefile Fri Jan 6 18:55:56 2006
++++ src/cpp/makefile Sun May 14 14:23:10 2006
+@@ -3,9 +3,8 @@
+ # Makefile for gcc 3.4.4
+ #
+ #
+-CFLAGS = -Wall -O6 -fomit-frame-pointer -m486 -Dunix -I ../include
++CXXFLAGS += -Dunix -I../include
+ CCFLAGS = -Wall -O6 -fomit-frame-pointer -m486 -Dunix -I ../include
+-LDFLAGS = -lstdc++
+
+ AS =as
+ LD =gcc $(LDFLAGS)
+@@ -32,11 +31,8 @@
+ .cc.o:
+ $(CCC) -c -o $*.o $<
+
+-.cpp.o:
+- $(CCC) -c -o $*.o $<
+-
+ cobf: $(COBF_OBJECTS)
+- $(LD) -o $@ $(COBF_OBJECTS) $(LDFLAGS)
++ $(CXX) -o $@ $(COBF_OBJECTS) $(LDFLAGS)
+
+ clean:
+ -rm *.o
diff --git a/devel/cobf/pkg-descr b/devel/cobf/pkg-descr
new file mode 100644
index 000000000000..c396f03e41f8
--- /dev/null
+++ b/devel/cobf/pkg-descr
@@ -0,0 +1,5 @@
+COBF (aka C-Obfuscator) is a program which manipulates C or C++ sourcefiles
+in a way that they aren't readable by human beings; but they remain
+compilable.
+
+WWW: http://home.arcor.de/bernhard.baier/cobf/