aboutsummaryrefslogtreecommitdiff
path: root/devel/codeblocks
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-05-08 17:41:52 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-05-08 17:41:52 +0000
commit5d3da8cf47c214d428157433e86ac6c5788088c5 (patch)
tree528901ac7e0d8aaee15e53ac990fc6073e5890d6 /devel/codeblocks
parent0c26af0332fdad3a1ab9f2413d4aa87a327cf01d (diff)
downloadports-5d3da8cf47c214d428157433e86ac6c5788088c5.tar.gz
ports-5d3da8cf47c214d428157433e86ac6c5788088c5.zip
Notes
Diffstat (limited to 'devel/codeblocks')
-rw-r--r--devel/codeblocks/Makefile19
-rw-r--r--devel/codeblocks/distinfo4
-rw-r--r--devel/codeblocks/files/patch-Makefile.am11
-rw-r--r--devel/codeblocks/files/patch-Makefile.in11
-rw-r--r--devel/codeblocks/files/patch-src__include__cbthreadpool.h73
-rw-r--r--devel/codeblocks/files/patch-src_plugins_contrib_SpellChecker_hunspell_Makefile.am11
-rw-r--r--devel/codeblocks/files/patch-src_plugins_contrib_SpellChecker_hunspell_Makefile.in.org11
-rw-r--r--devel/codeblocks/files/patch-src_plugins_contrib_wxContribItems_Makefile.am9
-rw-r--r--devel/codeblocks/files/patch-src_plugins_contrib_wxContribItems_Makefile.in11
-rw-r--r--devel/codeblocks/files/patch-src_plugins_contrib_wxSmithAui_Makefile.am11
-rw-r--r--devel/codeblocks/files/patch-src_plugins_contrib_wxSmithAui_Makefile.in11
-rw-r--r--devel/codeblocks/files/patch-src_plugins_contrib_wxSmith_Makefile.am11
-rw-r--r--devel/codeblocks/files/patch-src_plugins_contrib_wxSmith_Makefile.in11
-rw-r--r--devel/codeblocks/files/patch-src_sdk_wxscintilla_src_ScintillaWX.cpp11
-rw-r--r--devel/codeblocks/pkg-plist68
15 files changed, 181 insertions, 102 deletions
diff --git a/devel/codeblocks/Makefile b/devel/codeblocks/Makefile
index 3640ad56ef55..34a4a315bfa2 100644
--- a/devel/codeblocks/Makefile
+++ b/devel/codeblocks/Makefile
@@ -1,14 +1,13 @@
-# Created by: Matthias Sund <m.sund@arcor.de>
+# Created by: Loïc BARTOLETTI <lbartoletti@tuxfamily.org>
# $FreeBSD$
PORTNAME= codeblocks
-PORTVERSION= 13.12
-PORTREVISION= 5
+PORTVERSION= 16.01
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/Sources/${PORTVERSION}
-DISTNAME= ${PORTNAME}_${PORTVERSION}-1
+DISTNAME= ${PORTNAME}_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= lbartoletti@tuxfamily.org
COMMENT= Open source, cross-platform, free C/C++ IDE
LICENSE= GPLv3 LGPL3
@@ -16,23 +15,23 @@ LICENSE_COMB= multi
BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
- libhunspell-1.3.so:textproc/hunspell \
- librsync.so:net/librsync
+ libhunspell-1.3.so:textproc/hunspell
-USES= compiler desktop-file-utils fam:gamin libtool pathfix \
+USES= autoreconf compiler desktop-file-utils fam:gamin libtool pathfix \
pkgconfig shared-mime-info
USE_WX= 2.8
-WX_UNICODE= yes
+WANT_UNICODE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG} --with-contrib-plugins=all \
--disable-pch
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lboost_system
+PKG_CONFIG_LIBDIR= ${LOCALBASE}/libdata/pkgconfig
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.release
.include <bsd.port.pre.mk>
diff --git a/devel/codeblocks/distinfo b/devel/codeblocks/distinfo
index 5a86e23f66be..1115da64ebec 100644
--- a/devel/codeblocks/distinfo
+++ b/devel/codeblocks/distinfo
@@ -1,2 +1,2 @@
-SHA256 (codeblocks_13.12-1.tar.gz) = 772450046e8c8ba2ea0086acf433a46b83e6254fae64df9c8ca132a22f949610
-SIZE (codeblocks_13.12-1.tar.gz) = 17221056
+SHA256 (codeblocks_16.01.tar.gz) = 30fb9d206df4ab3c2e2fec2451a0a7c9723bfed9a673cc9be71e881c529d5a03
+SIZE (codeblocks_16.01.tar.gz) = 20250097
diff --git a/devel/codeblocks/files/patch-Makefile.am b/devel/codeblocks/files/patch-Makefile.am
new file mode 100644
index 000000000000..aef89ad3871e
--- /dev/null
+++ b/devel/codeblocks/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orig 2016-01-23 16:43:26 UTC
++++ Makefile.am
+@@ -10,7 +10,7 @@ endif
+
+ am__tar = @am__tar@ $(ADDITIONAL_MAKE_DIST_OPTIONS)
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ pkgconfig_DATA = codeblocks.pc
+
+ EXTRA_DIST = bootstrap \
diff --git a/devel/codeblocks/files/patch-Makefile.in b/devel/codeblocks/files/patch-Makefile.in
new file mode 100644
index 000000000000..202b29b672d5
--- /dev/null
+++ b/devel/codeblocks/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2016-05-06 22:17:30 UTC
++++ Makefile.in
+@@ -455,7 +455,7 @@ SUBDIRS = src
+ ACLOCAL_AMFLAGS = -I m4
+ @KEEP_DLLS_FALSE@ADDITIONAL_MAKE_DIST_OPTIONS = --exclude=".svn" --exclude="*.dll"
+ @KEEP_DLLS_TRUE@ADDITIONAL_MAKE_DIST_OPTIONS = --exclude=".svn"
+-pkgconfigdir = $(prefix)/libdata/pkgconfig
++pkgconfigdir = ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ pkgconfig_DATA = codeblocks.pc
+ EXTRA_DIST = bootstrap \
+ codeblocks.spec \
diff --git a/devel/codeblocks/files/patch-src__include__cbthreadpool.h b/devel/codeblocks/files/patch-src__include__cbthreadpool.h
deleted file mode 100644
index c1e1b8010b5d..000000000000
--- a/devel/codeblocks/files/patch-src__include__cbthreadpool.h
+++ /dev/null
@@ -1,73 +0,0 @@
---- src/include/cbthreadpool.h.orig 2013-11-17 20:34:15.000000000 +0100
-+++ src/include/cbthreadpool.h 2015-09-16 21:19:53.385265000 +0200
-@@ -15,6 +15,12 @@
- #include "settings.h"
- #include "prep.h"
-
-+#if defined(__has_feature) && __has_feature(cxx_noexcept)
-+#define NOEXCEPT noexcept
-+#else
-+#define NOEXCEPT throw()
-+#endif
-+
- /// A Thread Pool implementation
- class DLLIMPORT cbThreadPool
- {
-@@ -94,11 +100,11 @@ class DLLIMPORT cbThreadPool
-
- public:
- explicit CountedPtr(T *p = 0);
-- CountedPtr(const CountedPtr<T> &p) throw();
-- ~CountedPtr() throw();
-- CountedPtr<T> &operator = (const CountedPtr<T> &p) throw();
-- T &operator * () const throw();
-- T *operator -> () const throw();
-+ CountedPtr(const CountedPtr<T> &p) NOEXCEPT;
-+ ~CountedPtr() NOEXCEPT;
-+ CountedPtr<T> &operator = (const CountedPtr<T> &p) NOEXCEPT;
-+ T &operator * () const NOEXCEPT;
-+ T *operator -> () const NOEXCEPT;
-
- private:
- void dispose();
-@@ -281,7 +287,7 @@ inline cbThreadPool::CountedPtr<T>::Coun
- }
-
- template <typename T>
--inline cbThreadPool::CountedPtr<T>::CountedPtr(const CountedPtr<T> &p) throw()
-+inline cbThreadPool::CountedPtr<T>::CountedPtr(const CountedPtr<T> &p) NOEXCEPT
- : ptr(p.ptr),
- count(p.count)
- {
-@@ -289,13 +295,13 @@ inline cbThreadPool::CountedPtr<T>::Coun
- }
-
- template <typename T>
--inline cbThreadPool::CountedPtr<T>::~CountedPtr() throw()
-+inline cbThreadPool::CountedPtr<T>::~CountedPtr() NOEXCEPT
- {
- dispose();
- }
-
- template <typename T>
--inline cbThreadPool::CountedPtr<T> &cbThreadPool::CountedPtr<T>::operator = (const CountedPtr<T> &p) throw()
-+inline cbThreadPool::CountedPtr<T> &cbThreadPool::CountedPtr<T>::operator = (const CountedPtr<T> &p) NOEXCEPT
- {
- if (this != &p)
- {
-@@ -309,13 +315,13 @@ inline cbThreadPool::CountedPtr<T> &cbTh
- }
-
- template <typename T>
--inline T &cbThreadPool::CountedPtr<T>::operator * () const throw()
-+inline T &cbThreadPool::CountedPtr<T>::operator * () const NOEXCEPT
- {
- return *ptr;
- }
-
- template <typename T>
--inline T *cbThreadPool::CountedPtr<T>::operator -> () const throw()
-+inline T *cbThreadPool::CountedPtr<T>::operator -> () const NOEXCEPT
- {
- return ptr;
- }
diff --git a/devel/codeblocks/files/patch-src_plugins_contrib_SpellChecker_hunspell_Makefile.am b/devel/codeblocks/files/patch-src_plugins_contrib_SpellChecker_hunspell_Makefile.am
new file mode 100644
index 000000000000..4f749838bbfb
--- /dev/null
+++ b/devel/codeblocks/files/patch-src_plugins_contrib_SpellChecker_hunspell_Makefile.am
@@ -0,0 +1,11 @@
+--- src/plugins/contrib/SpellChecker/hunspell/Makefile.am.orig 2016-05-06 22:18:30 UTC
++++ src/plugins/contrib/SpellChecker/hunspell/Makefile.am
+@@ -2,7 +2,7 @@ ACLOCAL_AMFLAGS = -I m4
+
+ SUBDIRS= intl po src man m4 tests
+
+-pkgconfdir = $(libdir)/pkgconfig
++pkgconfdir = ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ pkgconf_DATA = hunspell.pc
+
+ EXTRA_DIST = BUGS README.myspell AUTHORS.myspell license.myspell license.hunspell \
diff --git a/devel/codeblocks/files/patch-src_plugins_contrib_SpellChecker_hunspell_Makefile.in.org b/devel/codeblocks/files/patch-src_plugins_contrib_SpellChecker_hunspell_Makefile.in.org
new file mode 100644
index 000000000000..db1f956d5af2
--- /dev/null
+++ b/devel/codeblocks/files/patch-src_plugins_contrib_SpellChecker_hunspell_Makefile.in.org
@@ -0,0 +1,11 @@
+--- src/plugins/contrib/SpellChecker/hunspell/Makefile.in.org.orig 2016-05-06 22:19:18 UTC
++++ src/plugins/contrib/SpellChecker/hunspell/Makefile.in.org
+@@ -429,7 +429,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ ACLOCAL_AMFLAGS = -I m4
+ SUBDIRS = intl po src man m4 tests
+-pkgconfdir = $(libdir)/pkgconfig
++pkgconfdir = ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ pkgconf_DATA = hunspell.pc
+ EXTRA_DIST = BUGS README.myspell AUTHORS.myspell license.myspell license.hunspell \
+ ChangeLog.O COPYING.MPL COPYING.LGPL hunspell.pc.in
diff --git a/devel/codeblocks/files/patch-src_plugins_contrib_wxContribItems_Makefile.am b/devel/codeblocks/files/patch-src_plugins_contrib_wxContribItems_Makefile.am
new file mode 100644
index 000000000000..7820d2085ab1
--- /dev/null
+++ b/devel/codeblocks/files/patch-src_plugins_contrib_wxContribItems_Makefile.am
@@ -0,0 +1,9 @@
+--- src/plugins/contrib/wxContribItems/Makefile.am.orig 2016-05-06 22:22:42 UTC
++++ src/plugins/contrib/wxContribItems/Makefile.am
+@@ -9,5 +9,5 @@ SUBDIRS = wxchart wxFlatNotebook wxthing
+
+ EXTRA_DIST = $(srcdir)/*.cbp $(TREELIST_DIST)
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ pkgconfig_DATA = wxsmith-contrib.pc cb_wxcontrib.pc cb_wxchartctrl.pc cb_wxcustombutton.pc cb_wxflatnotebook.pc cb_wximagepanel.pc cb_wxspeedbutton.pc cb_wxKWIC.pc $(TREELIST_PC) cb_wxled.pc cb_wxmathplot.pc
diff --git a/devel/codeblocks/files/patch-src_plugins_contrib_wxContribItems_Makefile.in b/devel/codeblocks/files/patch-src_plugins_contrib_wxContribItems_Makefile.in
new file mode 100644
index 000000000000..1e90a482a7d9
--- /dev/null
+++ b/devel/codeblocks/files/patch-src_plugins_contrib_wxContribItems_Makefile.in
@@ -0,0 +1,11 @@
+--- src/plugins/contrib/wxContribItems/Makefile.in.orig 2016-05-06 22:22:44 UTC
++++ src/plugins/contrib/wxContribItems/Makefile.in
+@@ -444,7 +444,7 @@ top_srcdir = @top_srcdir@
+ @HAVE_WX29_TRUE@TREELIST_DIST = $(srcdir)/wxTreeList/src/treelistctrl.cpp $(srcdir)/wxTreeList/include/wx/treelistctrl.h
+ SUBDIRS = wxchart wxFlatNotebook wxthings wxImagePanel wxSpeedButton KWIC $(TREELIST_DIR) wxled wxmathplot .
+ EXTRA_DIST = $(srcdir)/*.cbp $(TREELIST_DIST)
+-pkgconfigdir = $(prefix)/libdata/pkgconfig
++pkgconfigdir = ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ pkgconfig_DATA = wxsmith-contrib.pc cb_wxcontrib.pc cb_wxchartctrl.pc cb_wxcustombutton.pc cb_wxflatnotebook.pc cb_wximagepanel.pc cb_wxspeedbutton.pc cb_wxKWIC.pc $(TREELIST_PC) cb_wxled.pc cb_wxmathplot.pc
+ all: all-recursive
+
diff --git a/devel/codeblocks/files/patch-src_plugins_contrib_wxSmithAui_Makefile.am b/devel/codeblocks/files/patch-src_plugins_contrib_wxSmithAui_Makefile.am
new file mode 100644
index 000000000000..283b1246182e
--- /dev/null
+++ b/devel/codeblocks/files/patch-src_plugins_contrib_wxSmithAui_Makefile.am
@@ -0,0 +1,11 @@
+--- src/plugins/contrib/wxSmithAui/Makefile.am.orig 2016-05-06 22:24:09 UTC
++++ src/plugins/contrib/wxSmithAui/Makefile.am
+@@ -45,7 +45,7 @@ libwxSmithAui_la_SOURCES = \
+ ./wxAuiToolBar/wxSmithAuiToolBar.cpp \
+ ./wxSmithAui.cpp
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ pkgconfig_DATA = wxsmithaui.pc
+
+ noinst_HEADERS = \
diff --git a/devel/codeblocks/files/patch-src_plugins_contrib_wxSmithAui_Makefile.in b/devel/codeblocks/files/patch-src_plugins_contrib_wxSmithAui_Makefile.in
new file mode 100644
index 000000000000..0111ca3c4275
--- /dev/null
+++ b/devel/codeblocks/files/patch-src_plugins_contrib_wxSmithAui_Makefile.in
@@ -0,0 +1,11 @@
+--- src/plugins/contrib/wxSmithAui/Makefile.in.orig 2016-05-06 22:24:06 UTC
++++ src/plugins/contrib/wxSmithAui/Makefile.in
+@@ -478,7 +478,7 @@ libwxSmithAui_la_SOURCES = \
+ ./wxAuiToolBar/wxSmithAuiToolBar.cpp \
+ ./wxSmithAui.cpp
+
+-pkgconfigdir = $(prefix)/libdata/pkgconfig
++pkgconfigdir = ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ pkgconfig_DATA = wxsmithaui.pc
+ noinst_HEADERS = \
+ ./wxAuiManager/wxsAuiManager.h \
diff --git a/devel/codeblocks/files/patch-src_plugins_contrib_wxSmith_Makefile.am b/devel/codeblocks/files/patch-src_plugins_contrib_wxSmith_Makefile.am
new file mode 100644
index 000000000000..b9cedaff718f
--- /dev/null
+++ b/devel/codeblocks/files/patch-src_plugins_contrib_wxSmith_Makefile.am
@@ -0,0 +1,11 @@
+--- src/plugins/contrib/wxSmith/Makefile.am.orig 2016-05-06 22:22:03 UTC
++++ src/plugins/contrib/wxSmith/Makefile.am
+@@ -70,7 +70,7 @@ noinst_HEADERS = \
+ ./wxsversionconverter.h \
+ ./wxssettings.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ pkgconfig_DATA = wxsmith.pc
+
+ EXTRA_DIST = \
diff --git a/devel/codeblocks/files/patch-src_plugins_contrib_wxSmith_Makefile.in b/devel/codeblocks/files/patch-src_plugins_contrib_wxSmith_Makefile.in
new file mode 100644
index 000000000000..b59ec4bbf8dd
--- /dev/null
+++ b/devel/codeblocks/files/patch-src_plugins_contrib_wxSmith_Makefile.in
@@ -0,0 +1,11 @@
+--- src/plugins/contrib/wxSmith/Makefile.in.orig 2016-05-06 22:20:29 UTC
++++ src/plugins/contrib/wxSmith/Makefile.in
+@@ -546,7 +546,7 @@ noinst_HEADERS = \
+ ./wxsversionconverter.h \
+ ./wxssettings.h
+
+-pkgconfigdir = $(prefix)/libdata/pkgconfig
++pkgconfigdir = ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ pkgconfig_DATA = wxsmith.pc
+ EXTRA_DIST = \
+ $(srcdir)/*.cbp \
diff --git a/devel/codeblocks/files/patch-src_sdk_wxscintilla_src_ScintillaWX.cpp b/devel/codeblocks/files/patch-src_sdk_wxscintilla_src_ScintillaWX.cpp
new file mode 100644
index 000000000000..f477e36226c6
--- /dev/null
+++ b/devel/codeblocks/files/patch-src_sdk_wxscintilla_src_ScintillaWX.cpp
@@ -0,0 +1,11 @@
+--- src/sdk/wxscintilla/src/ScintillaWX.cpp.orig 2016-01-23 16:43:01 UTC
++++ src/sdk/wxscintilla/src/ScintillaWX.cpp
+@@ -290,7 +290,7 @@ static int wxCountLines(const char* text
+
+ /* C::B begin */
+ // Constant ids for the timers used by every editor.
+-const int timerIDs[ScintillaWX::timersCount] = { wxNewId(), wxNewId(), wxNewId(), wxNewId() };
++const int timerIDs[ScintillaWX::timersCount] = { static_cast<int>(wxNewId()), static_cast<int>(wxNewId()), static_cast<int>(wxNewId()), static_cast<int>(wxNewId()) };
+ /* C::B end */
+
+ //----------------------------------------------------------------------
diff --git a/devel/codeblocks/pkg-plist b/devel/codeblocks/pkg-plist
index c09db528eb5f..7685d854dfa6 100644
--- a/devel/codeblocks/pkg-plist
+++ b/devel/codeblocks/pkg-plist
@@ -1,7 +1,7 @@
bin/cb_console_runner
bin/cb_share_config
bin/codeblocks
-bin/codesnippets
+include/codeblocks/Alignment.h
include/codeblocks/Assertions.h
include/codeblocks/Attributes.h
include/codeblocks/CharDistribution.h
@@ -10,7 +10,7 @@ include/codeblocks/ErrorList.h
include/codeblocks/JpCntx.h
include/codeblocks/Likely.h
include/codeblocks/NullPtr.h
-include/codeblocks/StandardInteger.h
+include/codeblocks/TypedEnum.h
include/codeblocks/Types.h
include/codeblocks/Util.h
include/codeblocks/annoyingdialog.h
@@ -34,6 +34,7 @@ include/codeblocks/cbthreadpool.h
include/codeblocks/cbtool.h
include/codeblocks/cbtreectrl.h
include/codeblocks/cbworkspace.h
+include/codeblocks/ccmanager.h
include/codeblocks/compileoptionsbase.h
include/codeblocks/compiler.h
include/codeblocks/compilercommandgenerator.h
@@ -49,7 +50,6 @@ include/codeblocks/debuggermanager.h
include/codeblocks/editarrayfiledlg.h
include/codeblocks/editarrayorderdlg.h
include/codeblocks/editarraystringdlg.h
-include/codeblocks/editkeywordsdlg.h
include/codeblocks/editor_hooks.h
include/codeblocks/editorbase.h
include/codeblocks/editorcolourset.h
@@ -119,7 +119,6 @@ include/codeblocks/prep.h
include/codeblocks/printing_types.h
include/codeblocks/prmem.h
include/codeblocks/projectbuildtarget.h
-include/codeblocks/projectdepsdlg.h
include/codeblocks/projectfile.h
include/codeblocks/projectfileoptionsdlg.h
include/codeblocks/projectlayoutloader.h
@@ -162,7 +161,6 @@ include/codeblocks/tinyxml/tinywxuni.h
include/codeblocks/tinyxml/tinyxml.h
include/codeblocks/toolsmanager.h
include/codeblocks/uservarmanager.h
-include/codeblocks/virtualbuildtargetsdlg.h
include/codeblocks/workspaceloader.h
include/codeblocks/wxContribItems/KWIC/include/wx/KWIC/AngularMeter.h
include/codeblocks/wxContribItems/KWIC/include/wx/KWIC/AngularRegulator.h
@@ -186,6 +184,7 @@ include/codeblocks/wxContribItems/wxFlatNotebook/include/wx/wxFlatNotebook/wxFNB
include/codeblocks/wxContribItems/wxFlatNotebook/include/wx/wxFlatNotebook/wxFlatNotebook.h
include/codeblocks/wxContribItems/wxFlatNotebook/include/wx/wxFlatNotebook/wxFlatNotebookSDK.h
include/codeblocks/wxContribItems/wxImagePanel/include/wx/wxImagePanel.h
+include/codeblocks/wxContribItems/wxMathPlot/mathplot.h
include/codeblocks/wxContribItems/wxSpeedButton/wxSpeedButton.h
include/codeblocks/wxContribItems/wxTreeList/include/wx/treelistctrl.h
include/codeblocks/wxContribItems/wxchart/include/wx/axis.h
@@ -339,6 +338,7 @@ lib/codeblocks/plugins/libIncrementalSearch.so
lib/codeblocks/plugins/libMouseSap.so
lib/codeblocks/plugins/libNassiShneiderman.so
lib/codeblocks/plugins/libProfiler.so
+lib/codeblocks/plugins/libProjectOptionsManipulator.so
lib/codeblocks/plugins/libRegExTestbed.so
lib/codeblocks/plugins/libReopenEditor.so
lib/codeblocks/plugins/libSmartIndentCpp.so
@@ -399,6 +399,9 @@ lib/codeblocks/wxContribItems/libwxkwic.so.0.0.1
lib/codeblocks/wxContribItems/libwxled.so
lib/codeblocks/wxContribItems/libwxled.so.0
lib/codeblocks/wxContribItems/libwxled.so.0.0.1
+lib/codeblocks/wxContribItems/libwxmathplot.so
+lib/codeblocks/wxContribItems/libwxmathplot.so.0
+lib/codeblocks/wxContribItems/libwxmathplot.so.0.0.1
lib/codeblocks/wxContribItems/libwxspeedbutton.so
lib/codeblocks/wxContribItems/libwxspeedbutton.so.0
lib/codeblocks/wxContribItems/libwxspeedbutton.so.0.0.1
@@ -411,6 +414,7 @@ lib/libcodeblocks.so.0.0.1
lib/libwxsmithlib.so
lib/libwxsmithlib.so.0
lib/libwxsmithlib.so.0.0.1
+libdata/pkgconfig/codeblocks.pc
libdata/pkgconfig/cb_wxKWIC.pc
libdata/pkgconfig/cb_wxchartctrl.pc
libdata/pkgconfig/cb_wxcontrib.pc
@@ -418,9 +422,9 @@ libdata/pkgconfig/cb_wxcustombutton.pc
libdata/pkgconfig/cb_wxflatnotebook.pc
libdata/pkgconfig/cb_wximagepanel.pc
libdata/pkgconfig/cb_wxled.pc
+libdata/pkgconfig/cb_wxmathplot.pc
libdata/pkgconfig/cb_wxspeedbutton.pc
libdata/pkgconfig/cb_wxtreelist.pc
-libdata/pkgconfig/codeblocks.pc
libdata/pkgconfig/wxsmith-contrib.pc
libdata/pkgconfig/wxsmith.pc
libdata/pkgconfig/wxsmithaui.pc
@@ -429,10 +433,6 @@ man/man1/cb_share_config.1.gz
man/man1/codeblocks.1.gz
man/man1/codesnippets.1.gz
share/applications/codeblocks.desktop
-share/icons/hicolor/48x48/mimetypes/application-x-codeblocks-workspace.png
-share/icons/hicolor/48x48/mimetypes/application-x-codeblocks.png
-share/mime/packages/codeblocks.xml
-share/pixmaps/codeblocks.png
%%DATADIR%%/AutoVersioning.zip
%%DATADIR%%/BrowseTracker.zip
%%DATADIR%%/Cccc.zip
@@ -447,6 +447,7 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/MouseSap.zip
%%DATADIR%%/NassiShneiderman.zip
%%DATADIR%%/Profiler.zip
+%%DATADIR%%/ProjectOptionsManipulator.zip
%%DATADIR%%/RegExTestbed.zip
%%DATADIR%%/ReopenEditor.zip
%%DATADIR%%/SmartIndentCpp.zip
@@ -468,6 +469,7 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/SpellChecker/en_NZ.png
%%DATADIR%%/SpellChecker/en_US.png
%%DATADIR%%/SpellChecker/fr_FR.png
+%%DATADIR%%/SpellChecker/ru_RU.png
%%DATADIR%%/SymTab.zip
%%DATADIR%%/ThreadSearch.zip
%%DATADIR%%/ToolsPlus.zip
@@ -484,10 +486,13 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/compiler.zip
%%DATADIR%%/compilers/compiler_avr-gcc.xml
%%DATADIR%%/compilers/compiler_bcc.xml
+%%DATADIR%%/compilers/compiler_bfin-elf-gcc.xml
%%DATADIR%%/compilers/compiler_clang.xml
%%DATADIR%%/compilers/compiler_dmc.xml
%%DATADIR%%/compilers/compiler_dmd.xml
%%DATADIR%%/compilers/compiler_ldc.xml
+%%DATADIR%%/compilers/compiler_lm32-gcc.xml
+%%DATADIR%%/compilers/compiler_lm8-gcc.xml
%%DATADIR%%/compilers/compiler_msp430-gcc.xml
%%DATADIR%%/compilers/compiler_null.xml
%%DATADIR%%/compilers/compiler_pgifortran.xml
@@ -495,9 +500,11 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/compilers/compiler_sdcc.xml
%%DATADIR%%/compilers/compiler_tcc.xml
%%DATADIR%%/compilers/compiler_tricore-gcc.xml
+%%DATADIR%%/compilers/compiler_zpu-gcc.xml
%%DATADIR%%/compilers/options_arm-elf-gcc.xml
%%DATADIR%%/compilers/options_avr-gcc.xml
%%DATADIR%%/compilers/options_bcc.xml
+%%DATADIR%%/compilers/options_bfin-elf-gcc.xml
%%DATADIR%%/compilers/options_clang.xml
%%DATADIR%%/compilers/options_common_architecture.xml
%%DATADIR%%/compilers/options_common_cmds.xml
@@ -526,6 +533,8 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/compilers/options_keilcx51.xml
%%DATADIR%%/compilers/options_lcc.xml
%%DATADIR%%/compilers/options_ldc.xml
+%%DATADIR%%/compilers/options_lm32-gcc.xml
+%%DATADIR%%/compilers/options_lm8-gcc.xml
%%DATADIR%%/compilers/options_msp430-gcc.xml
%%DATADIR%%/compilers/options_msvc10.xml
%%DATADIR%%/compilers/options_msvc8.xml
@@ -537,6 +546,7 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/compilers/options_sdcc.xml
%%DATADIR%%/compilers/options_tcc.xml
%%DATADIR%%/compilers/options_tricore-gcc.xml
+%%DATADIR%%/compilers/options_zpu-gcc.xml
%%DATADIR%%/copystrings.zip
%%DATADIR%%/debugger.zip
%%DATADIR%%/defaultmimehandler.zip
@@ -760,18 +770,18 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/images/codecompletion/folder_green_open.png
%%DATADIR%%/images/codecompletion/folder_open.png
%%DATADIR%%/images/codecompletion/funcs_folder.png
-%%DATADIR%%/images/codecompletion/macro.png
-%%DATADIR%%/images/codecompletion/macro_folder.png
-%%DATADIR%%/images/codecompletion/macro_private.png
-%%DATADIR%%/images/codecompletion/macro_protected.png
-%%DATADIR%%/images/codecompletion/macro_public.png
+%%DATADIR%%/images/codecompletion/macro_def.png
+%%DATADIR%%/images/codecompletion/macro_def_folder.png
+%%DATADIR%%/images/codecompletion/macro_use.png
+%%DATADIR%%/images/codecompletion/macro_use_folder.png
+%%DATADIR%%/images/codecompletion/macro_use_private.png
+%%DATADIR%%/images/codecompletion/macro_use_protected.png
+%%DATADIR%%/images/codecompletion/macro_use_public.png
%%DATADIR%%/images/codecompletion/method_private.png
%%DATADIR%%/images/codecompletion/method_protected.png
%%DATADIR%%/images/codecompletion/method_public.png
%%DATADIR%%/images/codecompletion/namespace.png
%%DATADIR%%/images/codecompletion/others_folder.png
-%%DATADIR%%/images/codecompletion/preproc.png
-%%DATADIR%%/images/codecompletion/preproc_folder.png
%%DATADIR%%/images/codecompletion/symbols_folder.png
%%DATADIR%%/images/codecompletion/typedef.png
%%DATADIR%%/images/codecompletion/typedef_private.png
@@ -841,6 +851,7 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/images/rc-file-outofdate.png
%%DATADIR%%/images/rc-file-requireslock.png
%%DATADIR%%/images/rc-file-uptodate.png
+%%DATADIR%%/images/readonly.png
%%DATADIR%%/images/rebuild.png
%%DATADIR%%/images/redo.png
%%DATADIR%%/images/run.png
@@ -1143,6 +1154,7 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/lexers/lexer_bash.xml
%%DATADIR%%/lexers/lexer_batch.sample
%%DATADIR%%/lexers/lexer_batch.xml
+%%DATADIR%%/lexers/lexer_bibtex.sample
%%DATADIR%%/lexers/lexer_bibtex.xml
%%DATADIR%%/lexers/lexer_caml.sample
%%DATADIR%%/lexers/lexer_caml.xml
@@ -1150,6 +1162,8 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/lexers/lexer_cg.xml
%%DATADIR%%/lexers/lexer_cmake.sample
%%DATADIR%%/lexers/lexer_cmake.xml
+%%DATADIR%%/lexers/lexer_coffee.sample
+%%DATADIR%%/lexers/lexer_coffee.xml
%%DATADIR%%/lexers/lexer_cpp.sample
%%DATADIR%%/lexers/lexer_cpp.xml
%%DATADIR%%/lexers/lexer_css.sample
@@ -1172,8 +1186,12 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/lexers/lexer_hitasm.xml
%%DATADIR%%/lexers/lexer_html.sample
%%DATADIR%%/lexers/lexer_html.xml
+%%DATADIR%%/lexers/lexer_ihex.sample
+%%DATADIR%%/lexers/lexer_ihex.xml
%%DATADIR%%/lexers/lexer_java.sample
%%DATADIR%%/lexers/lexer_java.xml
+%%DATADIR%%/lexers/lexer_javascript.sample
+%%DATADIR%%/lexers/lexer_javascript.xml
%%DATADIR%%/lexers/lexer_latex.sample
%%DATADIR%%/lexers/lexer_latex.xml
%%DATADIR%%/lexers/lexer_lisp.sample
@@ -1200,10 +1218,13 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/lexers/lexer_prg.xml
%%DATADIR%%/lexers/lexer_properties.sample
%%DATADIR%%/lexers/lexer_properties.xml
+%%DATADIR%%/lexers/lexer_proto.xml
%%DATADIR%%/lexers/lexer_python.sample
%%DATADIR%%/lexers/lexer_python.xml
%%DATADIR%%/lexers/lexer_rc.sample
%%DATADIR%%/lexers/lexer_rc.xml
+%%DATADIR%%/lexers/lexer_registry.sample
+%%DATADIR%%/lexers/lexer_registry.xml
%%DATADIR%%/lexers/lexer_ruby.sample
%%DATADIR%%/lexers/lexer_ruby.xml
%%DATADIR%%/lexers/lexer_smalltalk.sample
@@ -1212,6 +1233,10 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/lexers/lexer_sql.xml
%%DATADIR%%/lexers/lexer_squirrel.sample
%%DATADIR%%/lexers/lexer_squirrel.xml
+%%DATADIR%%/lexers/lexer_srec.sample
+%%DATADIR%%/lexers/lexer_srec.xml
+%%DATADIR%%/lexers/lexer_tehex.sample
+%%DATADIR%%/lexers/lexer_tehex.xml
%%DATADIR%%/lexers/lexer_vbscript.sample
%%DATADIR%%/lexers/lexer_vbscript.xml
%%DATADIR%%/lexers/lexer_verilog.sample
@@ -1237,6 +1262,11 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/scripts/sample_plugin.script
%%DATADIR%%/scripts/startup.script
%%DATADIR%%/scripts/stl-views-1.0.3.gdb
+%%DATADIR%%/scripts/tests/menu_test_plugin.script
+%%DATADIR%%/scripts/tests/script_test_plugin.script
+%%DATADIR%%/scripts/tests/test_base.script
+%%DATADIR%%/scripts/tests/user_dialog_test_plugin.script
+%%DATADIR%%/scripts/tests/wx_test.script
%%DATADIR%%/scripts/wx_help.script
%%DATADIR%%/start_here.zip
%%DATADIR%%/templates/console-main-c.cpp
@@ -1608,3 +1638,7 @@ share/pixmaps/codeblocks.png
%%DATADIR%%/wxSmithAui.zip
%%DATADIR%%/wxsmith.zip
%%DATADIR%%/wxsmithcontribitems.zip
+share/icons/hicolor/48x48/mimetypes/application-x-codeblocks-workspace.png
+share/icons/hicolor/48x48/mimetypes/application-x-codeblocks.png
+share/mime/packages/codeblocks.xml
+share/pixmaps/codeblocks.png