aboutsummaryrefslogtreecommitdiff
path: root/devel/codequery
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2017-08-02 17:53:05 +0000
committerPawel Pekala <pawel@FreeBSD.org>2017-08-02 17:53:05 +0000
commitc0595e7ea0a82ca78509b644cb550dc8f4097052 (patch)
treec662cec60cd3f067ecf79b6072b15b776679ad9f /devel/codequery
parentd35014dbf658b7792fa7ac58aa6f00e2af48786a (diff)
downloadports-c0595e7ea0a82ca78509b644cb550dc8f4097052.tar.gz
ports-c0595e7ea0a82ca78509b644cb550dc8f4097052.zip
Notes
Diffstat (limited to 'devel/codequery')
-rw-r--r--devel/codequery/Makefile33
-rw-r--r--devel/codequery/distinfo3
-rw-r--r--devel/codequery/files/patch-showgraph_Utils_asrt.h13
-rw-r--r--devel/codequery/pkg-descr12
4 files changed, 61 insertions, 0 deletions
diff --git a/devel/codequery/Makefile b/devel/codequery/Makefile
new file mode 100644
index 000000000000..40f2c6e925ed
--- /dev/null
+++ b/devel/codequery/Makefile
@@ -0,0 +1,33 @@
+# Created by: Pawel Pekala <pawel@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= codequery
+PORTVERSION= 0.21.0
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= pawel@FreeBSD.org
+COMMENT= Code understanding, browsing and search tool
+
+LICENSE= MPL20 MIT
+LICENSE_COMB= multi
+LICENSE_FILE_MPL20= ${WRKSRC}/LICENSE.md
+LICENSE_FILE_MIT= ${WRKSRC}/querylib/README.txt
+
+USES= cmake ninja sqlite
+
+USE_GITHUB= yes
+GH_ACCOUNT= ruben2020
+
+USE_QT4= linguisttools_build moc_build rcc_build uic_build \
+ corelib gui qmake xml
+
+PLIST_FILES= bin/codequery \
+ bin/cqmakedb \
+ bin/cqsearch
+DESKTOP_ENTRIES="CodeQuery" "" "" "${PORTNAME}" "Development;" ""
+
+post-patch:
+ @${REINPLACE_CMD} 's,../build/gui/,,' ${WRKSRC}/gui/codequery.qrc
+
+.include <bsd.port.mk>
diff --git a/devel/codequery/distinfo b/devel/codequery/distinfo
new file mode 100644
index 000000000000..e35d2697e5be
--- /dev/null
+++ b/devel/codequery/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1501261182
+SHA256 (ruben2020-codequery-v0.21.0_GH0.tar.gz) = 9af232e0d3bb10e5defbc222a9e422f4580dd5766cfc7f921d38baa18675f98d
+SIZE (ruben2020-codequery-v0.21.0_GH0.tar.gz) = 2423769
diff --git a/devel/codequery/files/patch-showgraph_Utils_asrt.h b/devel/codequery/files/patch-showgraph_Utils_asrt.h
new file mode 100644
index 000000000000..cebc67711b2f
--- /dev/null
+++ b/devel/codequery/files/patch-showgraph_Utils_asrt.h
@@ -0,0 +1,13 @@
+--- showgraph/Utils/asrt.h.orig 2017-07-28 19:53:18 UTC
++++ showgraph/Utils/asrt.h
+@@ -22,6 +22,10 @@
+ #ifndef ASRT_H
+ #define ASRT_H
+
++#ifdef assert
++# undef assert
++#endif
++
+ /**
+ * Assert macro that works only in debug version
+ * @ingroup Asserts
diff --git a/devel/codequery/pkg-descr b/devel/codequery/pkg-descr
new file mode 100644
index 000000000000..c31320df725e
--- /dev/null
+++ b/devel/codequery/pkg-descr
@@ -0,0 +1,12 @@
+This is a tool to index, then query or search C, C++, Java, Python, Ruby, Go
+and Javascript source code. It builds upon the databases of cscope and
+Exuberant ctags. It can also work with Universal ctags, which is a drop-in
+replacement for Exuberant ctags.
+
+The databases of cscope and ctags would be processed by the cqmakedb tool
+to generate the CodeQuery database file.
+
+The CodeQuery database file can be viewed and queried using the codequery
+GUI tool.
+
+WWW: https://ruben2020.github.io/codequery/