aboutsummaryrefslogtreecommitdiff
path: root/devel/codeville
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-12-08 01:36:10 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-12-08 01:36:10 +0000
commita4b7c2bde3fee457848c8ce685370c1dbfd48a63 (patch)
tree1afb67b0c656cffa0d1d3b93c45b92279e2b2798 /devel/codeville
parent5e0b336b8d216cd8be9525ed1ea2814177ae4b3a (diff)
downloadports-a4b7c2bde3fee457848c8ce685370c1dbfd48a63.tar.gz
ports-a4b7c2bde3fee457848c8ce685370c1dbfd48a63.zip
Notes
Diffstat (limited to 'devel/codeville')
-rw-r--r--devel/codeville/Makefile40
-rw-r--r--devel/codeville/distinfo2
-rw-r--r--devel/codeville/files/patch-setup.py10
-rw-r--r--devel/codeville/pkg-descr24
-rw-r--r--devel/codeville/pkg-plist73
5 files changed, 149 insertions, 0 deletions
diff --git a/devel/codeville/Makefile b/devel/codeville/Makefile
new file mode 100644
index 000000000000..a49a32fc4e89
--- /dev/null
+++ b/devel/codeville/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Codeville
+# Date created: Wed Dec 8 01:00:39 UTC 2004
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= codeville
+PORTVERSION= 0.1.9
+CATEGORIES= devel python
+MASTER_SITES= http://codeville.org/download/
+DISTNAME= Codeville-${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= An "anarchic" control version system without unnecessary re-merges
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PORTDOCS= \
+ LICENSE.txt
+
+EXAMPLE_FILES= \
+ cdvserver.conf.sample
+
+post-install:
+# examples
+ @${MKDIR} ${EXAMPLESDIR}
+.for file in ${EXAMPLE_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${EXAMPLESDIR}
+.endfor
+# documentation
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for file in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/codeville/distinfo b/devel/codeville/distinfo
new file mode 100644
index 000000000000..7cc0ded14c4e
--- /dev/null
+++ b/devel/codeville/distinfo
@@ -0,0 +1,2 @@
+MD5 (Codeville-0.1.9.tar.gz) = ccb9cb89e5e4e19b1d295ed8ed019e80
+SIZE (Codeville-0.1.9.tar.gz) = 68434
diff --git a/devel/codeville/files/patch-setup.py b/devel/codeville/files/patch-setup.py
new file mode 100644
index 000000000000..50df626fdd9b
--- /dev/null
+++ b/devel/codeville/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig Tue Dec 7 23:17:53 2004
++++ setup.py Tue Dec 7 23:18:37 2004
+@@ -43,6 +43,5 @@
+ packages = ["Codeville"],
+ ext_modules = plat_ext,
+
+- scripts = scripts,
+- data_files = data_files
++ scripts = scripts
+ )
diff --git a/devel/codeville/pkg-descr b/devel/codeville/pkg-descr
new file mode 100644
index 000000000000..ef5d3bcd9e26
--- /dev/null
+++ b/devel/codeville/pkg-descr
@@ -0,0 +1,24 @@
+[ excerpt from developer's web site ]
+
+Why yet another version control system? All other version control
+systems require that you keep careful track of the relationships
+between branches so as not have to repeatedly merge the same
+conflicts. Codeville is much more anarchic. It allows you to update
+from or commit to any repository at any time with no unnecessary
+re-merges.
+
+Codeville works by creating an identifier for each change which is
+done, and remembering the list of all changes which have been applied
+to each file and the last change which modified each line in each
+file. When there's a conflict, it checks to see if one of the two
+sides has already been applied to the other one, and if so makes
+the other side win automatically. When there's an actual not
+automatically mergeable version conflict, Codeville behaves in
+almost exactly the same way as CVS.
+
+For subtle but very important reasons Codeville actually versions
+spaces between lines, rather than the lines themselves. If you want
+to know the complete accurate details of how it works, you can look
+at the slides. Beyond that, I suggest reading the source.
+
+WWW: http://www.codeville.org/
diff --git a/devel/codeville/pkg-plist b/devel/codeville/pkg-plist
new file mode 100644
index 000000000000..17096fee0ddd
--- /dev/null
+++ b/devel/codeville/pkg-plist
@@ -0,0 +1,73 @@
+bin/cdv
+bin/cdv-agent
+bin/cdvpasswd
+bin/cdvserver
+bin/cdvupgrade
+%%PYTHON_SITELIBDIR%%/Codeville/RawServer.py
+%%PYTHON_SITELIBDIR%%/Codeville/RawServer.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/RawServer.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/SRP.py
+%%PYTHON_SITELIBDIR%%/Codeville/SRP.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/SRP.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/__init__.py
+%%PYTHON_SITELIBDIR%%/Codeville/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/__init__.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/agent.py
+%%PYTHON_SITELIBDIR%%/Codeville/agent.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/agent.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/auth.py
+%%PYTHON_SITELIBDIR%%/Codeville/auth.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/auth.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/bencode.py
+%%PYTHON_SITELIBDIR%%/Codeville/bencode.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/bencode.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/cdv_glob.py
+%%PYTHON_SITELIBDIR%%/Codeville/cdv_glob.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/cdv_glob.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/client.py
+%%PYTHON_SITELIBDIR%%/Codeville/client.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/client.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/client_helpers.py
+%%PYTHON_SITELIBDIR%%/Codeville/client_helpers.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/client_helpers.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/client_net.py
+%%PYTHON_SITELIBDIR%%/Codeville/client_net.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/client_net.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/crypt.py
+%%PYTHON_SITELIBDIR%%/Codeville/crypt.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/crypt.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/db.py
+%%PYTHON_SITELIBDIR%%/Codeville/db.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/db.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/diff.py
+%%PYTHON_SITELIBDIR%%/Codeville/diff.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/diff.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/entropy.py
+%%PYTHON_SITELIBDIR%%/Codeville/entropy.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/entropy.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/history.py
+%%PYTHON_SITELIBDIR%%/Codeville/history.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/history.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/merge.py
+%%PYTHON_SITELIBDIR%%/Codeville/merge.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/merge.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/network.py
+%%PYTHON_SITELIBDIR%%/Codeville/network.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/network.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/passwd.py
+%%PYTHON_SITELIBDIR%%/Codeville/passwd.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/passwd.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/selectpoll.py
+%%PYTHON_SITELIBDIR%%/Codeville/selectpoll.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/selectpoll.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/server.py
+%%PYTHON_SITELIBDIR%%/Codeville/server.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/server.pyo
+%%PYTHON_SITELIBDIR%%/Codeville/testtest.py
+%%PYTHON_SITELIBDIR%%/Codeville/testtest.pyc
+%%PYTHON_SITELIBDIR%%/Codeville/testtest.pyo
+%%EXAMPLESDIR%%/cdvserver.conf.sample
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/Codeville
+@unexec rmdir %D/%%PYTHON_SITELIBDIR%% 2>/dev/null || true
+@unexec rmdir %D/%%PYTHON_LIBDIR%% 2>/dev/null || true