aboutsummaryrefslogtreecommitdiff
path: root/devel/colormake
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2012-10-04 09:15:45 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2012-10-04 09:15:45 +0000
commit055200e680efc07fa9a934f52351f7071e90cb1c (patch)
treea50c5c7168a7761875418ef68d6cc34815add119 /devel/colormake
parente6ee2c6ce451be1f71acd6533989c9cbaf53118f (diff)
downloadports-055200e680efc07fa9a934f52351f7071e90cb1c.tar.gz
ports-055200e680efc07fa9a934f52351f7071e90cb1c.zip
Notes
Diffstat (limited to 'devel/colormake')
-rw-r--r--devel/colormake/Makefile29
-rw-r--r--devel/colormake/distinfo2
-rw-r--r--devel/colormake/pkg-descr3
3 files changed, 34 insertions, 0 deletions
diff --git a/devel/colormake/Makefile b/devel/colormake/Makefile
new file mode 100644
index 000000000000..5c7d3a2c5a69
--- /dev/null
+++ b/devel/colormake/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= colormake
+PORTVERSION= 0.9
+CATEGORIES= devel
+MASTER_SITES= http://bre.klaki.net/programs/colormake/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Wrapper to color gmake output
+
+RUN_DEPENDS= gmake:${PORTSDIR}/devel/gmake \
+ bash:${PORTSDIR}/shells/bash
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+PLIST_FILES= bin/colormake bin/colormake.pl bin/colormake-short bin/clmake \
+ bin/clmake-short
+
+post-patch:
+ cd ${WRKSRC} && \
+ ${REINPLACE_CMD} -e "s,make ,gmake ,g;s,/bin/bash,${LOCALBASE}/bin/bash,g" \
+ colormake colormake-short clmake clmake-short
+
+do-install:
+ cd ${WRKSRC} && \
+ ${INSTALL_SCRIPT} colormake.pl colormake colormake-short clmake \
+ clmake-short ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/colormake/distinfo b/devel/colormake/distinfo
new file mode 100644
index 000000000000..6c2e0907412d
--- /dev/null
+++ b/devel/colormake/distinfo
@@ -0,0 +1,2 @@
+SHA256 (colormake-0.9.tar.gz) = 000c629c84342c1224764e99e97ae9814ec6a7b9be0bc5922f2433db0d09c57e
+SIZE (colormake-0.9.tar.gz) = 11429
diff --git a/devel/colormake/pkg-descr b/devel/colormake/pkg-descr
new file mode 100644
index 000000000000..826a40260f70
--- /dev/null
+++ b/devel/colormake/pkg-descr
@@ -0,0 +1,3 @@
+This is a simple wrapper around "make" to make its output more readable.
+
+WWW: http://bre.klaki.net/programs/colormake/