aboutsummaryrefslogtreecommitdiff
path: root/devel/commit-patch/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-08-21 20:05:58 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-08-21 20:05:58 +0000
commit6b98326c8f90c9a2e849c2c86981c3517c538722 (patch)
treea8f3c21287e35c70485eb55901263f9b7410f819 /devel/commit-patch/Makefile
parent54ed4d522bd446ca638c255524b632d37f5e83f3 (diff)
downloadports-6b98326c8f90c9a2e849c2c86981c3517c538722.tar.gz
ports-6b98326c8f90c9a2e849c2c86981c3517c538722.zip
Notes
Diffstat (limited to 'devel/commit-patch/Makefile')
-rw-r--r--devel/commit-patch/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/commit-patch/Makefile b/devel/commit-patch/Makefile
new file mode 100644
index 000000000000..c2bb5008da08
--- /dev/null
+++ b/devel/commit-patch/Makefile
@@ -0,0 +1,35 @@
+# Created by: Lapo Luchin <lapo@lapo.it>
+# $FreeBSD$
+
+PORTNAME= commit-patch
+PORTVERSION= 2.5
+CATEGORIES= devel
+
+MAINTAINER= lapo@lapo.it
+COMMENT= Commit patches or partial workspace changes to a VCS repository
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= interdiff:${PORTSDIR}/misc/patchutils \
+ p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run
+
+USE_GITHUB= yes
+USES= gmake perl5
+USE_PERL5= build # pod2man
+
+GH_ACCOUNT= caldwell
+GH_PROJECT= commit-patch
+GH_TAGNAME= 2.5
+GH_COMMIT= fb3a8c5
+
+PLIST_FILES= bin/commit-partial bin/commit-patch \
+ share/emacs/site-lisp/commit-patch-buffer.el
+MAN1= commit-partial.1 commit-patch.1
+PORTDOCS= *
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/share[/]man/man/' \
+ -e 's/PREFIX=/PREFIX?=/' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>