aboutsummaryrefslogtreecommitdiff
path: root/devel/commit-patch
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-08-21 20:05:58 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-08-21 20:05:58 +0000
commit6b98326c8f90c9a2e849c2c86981c3517c538722 (patch)
treea8f3c21287e35c70485eb55901263f9b7410f819 /devel/commit-patch
parent54ed4d522bd446ca638c255524b632d37f5e83f3 (diff)
Notes
Diffstat (limited to 'devel/commit-patch')
-rw-r--r--devel/commit-patch/Makefile35
-rw-r--r--devel/commit-patch/distinfo2
-rw-r--r--devel/commit-patch/pkg-descr14
3 files changed, 51 insertions, 0 deletions
diff --git a/devel/commit-patch/Makefile b/devel/commit-patch/Makefile
new file mode 100644
index 000000000000..c2bb5008da08
--- /dev/null
+++ b/devel/commit-patch/Makefile
@@ -0,0 +1,35 @@
+# Created by: Lapo Luchin <lapo@lapo.it>
+# $FreeBSD$
+
+PORTNAME= commit-patch
+PORTVERSION= 2.5
+CATEGORIES= devel
+
+MAINTAINER= lapo@lapo.it
+COMMENT= Commit patches or partial workspace changes to a VCS repository
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= interdiff:${PORTSDIR}/misc/patchutils \
+ p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run
+
+USE_GITHUB= yes
+USES= gmake perl5
+USE_PERL5= build # pod2man
+
+GH_ACCOUNT= caldwell
+GH_PROJECT= commit-patch
+GH_TAGNAME= 2.5
+GH_COMMIT= fb3a8c5
+
+PLIST_FILES= bin/commit-partial bin/commit-patch \
+ share/emacs/site-lisp/commit-patch-buffer.el
+MAN1= commit-partial.1 commit-patch.1
+PORTDOCS= *
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/share[/]man/man/' \
+ -e 's/PREFIX=/PREFIX?=/' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/devel/commit-patch/distinfo b/devel/commit-patch/distinfo
new file mode 100644
index 000000000000..7f6d14bbf8e2
--- /dev/null
+++ b/devel/commit-patch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (commit-patch-2.5.tar.gz) = e4cdf5895f1fd45191ea5ebcc3857d560e9f994450e2725f771b3cfe8aa8ae68
+SIZE (commit-patch-2.5.tar.gz) = 17786
diff --git a/devel/commit-patch/pkg-descr b/devel/commit-patch/pkg-descr
new file mode 100644
index 000000000000..f870a5d82b49
--- /dev/null
+++ b/devel/commit-patch/pkg-descr
@@ -0,0 +1,14 @@
+Normally version control systems don't allow fine grained commits.
+commit-patch allows the user to control exactly what gets committed by
+letting the user supply a patch to be committed rather than using the
+files in the current working directory.
+
+commit-patch supports Darcs, Git, Mercurial, Bazaar, Subversion,
+Monotone or CVS repositories.
+
+Also included is an Emacs interface to commit-patch. It allows you to
+just hit C-c C-c in any patch buffer to apply and commit only the
+changes indicated by the patch, regardless of the changes in your
+working directory.
+
+WWW: http://www.porkrind.org/commit-patch/