aboutsummaryrefslogtreecommitdiff
path: root/devel/commoncpp
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-12 09:11:33 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-12 09:11:33 +0000
commitef9e8806b9df8d09ab5dd71184e54548cae28fbf (patch)
tree5fab35f7fe291f47b375101e4d319dc859a76d1a /devel/commoncpp
parentafa9784c6ec16e602d9095b6d8b6de764e5532b6 (diff)
downloadports-ef9e8806b9df8d09ab5dd71184e54548cae28fbf.tar.gz
ports-ef9e8806b9df8d09ab5dd71184e54548cae28fbf.zip
Notes
Diffstat (limited to 'devel/commoncpp')
-rw-r--r--devel/commoncpp/Makefile20
-rw-r--r--devel/commoncpp/distinfo4
-rw-r--r--devel/commoncpp/files/patch-config:ltmain.sh4
-rw-r--r--devel/commoncpp/files/patch-include-config-h.in12
-rw-r--r--devel/commoncpp/pkg-plist42
5 files changed, 29 insertions, 53 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index f5d0b557312b..9246596f8c8b 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= commoncpp2
-PORTVERSION= 1.0.13
-PORTREVISION= 1
+PORTVERSION= 1.1.0
+PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU} \
@@ -17,25 +17,13 @@ MASTER_SITE_SUBDIR= commonc++ cplusplus
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU project portable class framework for C++
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
-
USE_GETOPT_LONG=yes
-USE_GNOME= gnometarget
+USE_GNOME= gnometarget libxml2
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
- MAKEINFO="makeinfo --no-split"
-CONFIGURE_ARGS= --with-ftp
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
INSTALLS_SHLIB= yes
INFO= commoncpp2
-post-extract:
- @${RM} -f ${WRKSRC}/doc/${PORTNAME}.info*
-
-post-install:
- @(cd ${WRKSRC} && ${GMAKE} man)
- @(cd ${WRKSRC}/doc/man3 && ${LS} *.3cc | \
- ${SED} 's@^@man/man3/@'>> ${TMPPLIST})
-
.include <bsd.port.mk>
diff --git a/devel/commoncpp/distinfo b/devel/commoncpp/distinfo
index fd93cd2501fc..182d73e159ce 100644
--- a/devel/commoncpp/distinfo
+++ b/devel/commoncpp/distinfo
@@ -1,2 +1,2 @@
-MD5 (commoncpp2-1.0.13.tar.gz) = 7f1c5754ecd4a8c7524beb55b49a1fbf
-SIZE (commoncpp2-1.0.13.tar.gz) = 830489
+MD5 (commoncpp2-1.1.0.tar.gz) = 2063b53d4918df9c0a2dd157ad197573
+SIZE (commoncpp2-1.1.0.tar.gz) = 749562
diff --git a/devel/commoncpp/files/patch-config:ltmain.sh b/devel/commoncpp/files/patch-config:ltmain.sh
index f9d89d69df3a..ede65a87bcf6 100644
--- a/devel/commoncpp/files/patch-config:ltmain.sh
+++ b/devel/commoncpp/files/patch-config:ltmain.sh
@@ -1,5 +1,5 @@
---- config/ltmain.sh.orig Tue Dec 2 09:24:40 2003
-+++ config/ltmain.sh Tue Dec 2 09:24:52 2003
+--- autoconf/ltmain.sh.orig Thu Feb 12 16:50:30 2004
++++ autoconf/ltmain.sh Thu Feb 12 16:50:39 2004
@@ -5428,10 +5428,12 @@
fi
diff --git a/devel/commoncpp/files/patch-include-config-h.in b/devel/commoncpp/files/patch-include-config-h.in
deleted file mode 100644
index 92726deec0cf..000000000000
--- a/devel/commoncpp/files/patch-include-config-h.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- include/config.h.in.orig Mon Feb 17 20:21:46 2003
-+++ include/config.h.in Mon Feb 17 20:22:01 2003
-@@ -16,6 +16,8 @@
- #define CCXX_CONFIG_H_
- /* This is the top section */
-
-+#include <sys/types.h>
-+#include <math.h>
-
- /* Define if you have <unistd.h>. */
- #undef HAVE_UNISTD_H
-
diff --git a/devel/commoncpp/pkg-plist b/devel/commoncpp/pkg-plist
index f9c9a58bfbae..08d5d65d151a 100644
--- a/devel/commoncpp/pkg-plist
+++ b/devel/commoncpp/pkg-plist
@@ -1,44 +1,44 @@
bin/ccgnu2-config
+include/cc++2/cc++/buffer.h
include/cc++2/cc++/cmdoptns.h
-include/cc++2/cc++/config.h
include/cc++2/cc++/common.h
-include/cc++2/cc++/exception.h
+include/cc++2/cc++/config.h
+include/cc++2/cc++/counter.h
include/cc++2/cc++/digest.h
+include/cc++2/cc++/exception.h
+include/cc++2/cc++/export.h
include/cc++2/cc++/file.h
-include/cc++2/cc++/groups.h
-include/cc++2/cc++/numbers.h
+include/cc++2/cc++/functions.h
include/cc++2/cc++/misc.h
+include/cc++2/cc++/missing.h
include/cc++2/cc++/network.h
+include/cc++2/cc++/numbers.h
+include/cc++2/cc++/objcount.h
+include/cc++2/cc++/objlink.h
+include/cc++2/cc++/objmap.h
+include/cc++2/cc++/objsync.h
+include/cc++2/cc++/oststring.h
include/cc++2/cc++/persist.h
+include/cc++2/cc++/pointer.h
+include/cc++2/cc++/process.h
include/cc++2/cc++/serial.h
include/cc++2/cc++/slog.h
include/cc++2/cc++/socket.h
include/cc++2/cc++/strchar.h
+include/cc++2/cc++/string.h
+include/cc++2/cc++/template.h
include/cc++2/cc++/thread.h
include/cc++2/cc++/unix.h
include/cc++2/cc++/url.h
-include/cc++2/cc++/urlstring.h
include/cc++2/cc++/xml.h
-include/cc++2/cc++/ftp.h
-include/cc++2/cc++/process.h
-include/cc++2/cc++/export.h
-include/cc++2/cc++/template.h
-include/cc++2/cc++/objcount.h
-include/cc++2/cc++/objlink.h
-include/cc++2/cc++/objmap.h
-include/cc++2/cc++/objsync.h
-include/cc++2/cc++/oststring.h
-include/cc++2/cc++/functions.h
-include/cc++2/cc++/pointer.h
-include/cc++2/cc++/counter.h
@dirrm include/cc++2/cc++
@dirrm include/cc++2
share/aclocal/ost_check2.m4
lib/libccgnu2.a
lib/libccgnu2.so
-lib/libccgnu2-1.0.so
-lib/libccgnu2-1.0.so.0
+lib/libccgnu2-1.1.so
+lib/libccgnu2-1.1.so.0
lib/libccext2.a
lib/libccext2.so
-lib/libccext2-1.0.so
-lib/libccext2-1.0.so.0
+lib/libccext2-1.1.so
+lib/libccext2-1.1.so.0