aboutsummaryrefslogtreecommitdiff
path: root/devel/commoncpp
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-02 14:42:31 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-02 14:42:31 +0000
commit96187d7a683eb632df0f5de98bea7d96161c7bc7 (patch)
tree5370830ed78f7ad6e8cee899d68cf0812accb64f /devel/commoncpp
parent455eee4b11d54925c15bb02ec61fd3b6548562c4 (diff)
downloadports-96187d7a683eb632df0f5de98bea7d96161c7bc7.tar.gz
ports-96187d7a683eb632df0f5de98bea7d96161c7bc7.zip
Notes
Diffstat (limited to 'devel/commoncpp')
-rw-r--r--devel/commoncpp/Makefile28
-rw-r--r--devel/commoncpp/distinfo6
-rw-r--r--devel/commoncpp/files/patch-include-cc++_address.h40
-rw-r--r--devel/commoncpp/files/patch-src_timer.cpp11
4 files changed, 48 insertions, 37 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index 0562f6397a50..c83a6c54940f 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -6,35 +6,35 @@
#
PORTNAME= commoncpp
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.7
PORTEPOCH= 2
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= gnutelephony
+MASTER_SITES= GNU
DISTNAME= ${PORTNAME:S/$/2/}-${PORTVERSION}
MAINTAINER= acm@FreeBSD.org
COMMENT= GNU project portable class framework for C++
+USE_LDCONFIG= yes
USE_GNOME= gnomehack gnometarget
-
-.if !defined(WITHOUT_LIBXML2)
-USE_GNOME+= libxml2
-.else
-CONFIGURE_ARGS= --without-libxml2
-.endif
-
-USE_GETOPT_LONG=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GCC= 3.4+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
ac_cv_path_DOXYGEN=no
-USE_LDCONFIG= yes
+
+OPTIONS= LIBXML2 "Enable libxml2 support" on
INFO= commoncpp2
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_LIBXML2)
+USE_GNOME+= libxml2
+.else
+CONFIGURE_ARGS+=--without-libxml2
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/commoncpp/distinfo b/devel/commoncpp/distinfo
index 02bdaadb3aad..80e332fe403c 100644
--- a/devel/commoncpp/distinfo
+++ b/devel/commoncpp/distinfo
@@ -1,3 +1,3 @@
-MD5 (commoncpp2-1.5.2.tar.gz) = 9d84aa85af660b0dbb8fb601cf783409
-SHA256 (commoncpp2-1.5.2.tar.gz) = 75e2a4777f7fc6764c176b79851ca9530f6c5c745e9f610dbedf4253fde5f200
-SIZE (commoncpp2-1.5.2.tar.gz) = 862550
+MD5 (commoncpp2-1.5.7.tar.gz) = bd85e157e1f4f457e9137c59d40a13fb
+SHA256 (commoncpp2-1.5.7.tar.gz) = 95b0e86c27db1ec0b79abe4097f4449f1e15dde1870202ead0551c506269a504
+SIZE (commoncpp2-1.5.7.tar.gz) = 858598
diff --git a/devel/commoncpp/files/patch-include-cc++_address.h b/devel/commoncpp/files/patch-include-cc++_address.h
index b5ca34bd302a..dd9e9cd29a4e 100644
--- a/devel/commoncpp/files/patch-include-cc++_address.h
+++ b/devel/commoncpp/files/patch-include-cc++_address.h
@@ -1,28 +1,28 @@
---- include/cc++/address.h Sun Oct 1 07:07:12 2006
-+++ include/cc++/address.h Wed Oct 4 21:25:44 2006
-@@ -237,10 +237,10 @@
- };
+--- ./include/cc++/address.h.orig Tue Jan 23 14:15:02 2007
++++ ./include/cc++/address.h Tue Sep 11 11:58:17 2007
+@@ -236,10 +236,10 @@
+ bool isMember(const struct in_addr &inaddr) const;
- inline bool operator==(struct sockaddr *sa, IPV4Cidr &cidr)
-- {return cidr.isMember(sa);};
-+ {return cidr.isMember(sa);}
+ inline bool operator==(const struct sockaddr *a) const
+- {return isMember(a);};
++ {return isMember(a);}
- inline bool operator==(struct in_addr &a, IPV4Cidr &cidr)
-- {return cidr.isMember(a);};
-+ {return cidr.isMember(a);}
+ inline bool operator==(const struct in_addr &a) const
+- {return isMember(a);};
++ {return isMember(a);}
+ };
#ifdef CCXX_IPV6
- /**
-@@ -325,10 +325,10 @@
- };
+@@ -324,10 +324,10 @@
+ bool isMember(const struct in6_addr &inaddr) const;
- inline bool operator==(struct sockaddr *sa, IPV6Cidr &cidr)
-- {return cidr.isMember(sa);};
-+ {return cidr.isMember(sa);}
+ inline bool operator==(const struct sockaddr *sa) const
+- {return isMember(sa);};
++ {return isMember(sa);}
- inline bool operator==(struct in6_addr &a, IPV6Cidr &cidr)
-- {return cidr.isMember(a);};
-+ {return cidr.isMember(a);}
+ inline bool operator==(const struct in6_addr &a) const
+- {return isMember(a);};
++ {return isMember(a);}
+ };
#endif
-
diff --git a/devel/commoncpp/files/patch-src_timer.cpp b/devel/commoncpp/files/patch-src_timer.cpp
new file mode 100644
index 000000000000..217ef30a8c55
--- /dev/null
+++ b/devel/commoncpp/files/patch-src_timer.cpp
@@ -0,0 +1,11 @@
+--- src/timer.cpp.orig Tue Jan 23 21:09:13 2007
++++ src/timer.cpp Tue Sep 11 13:12:41 2007
+@@ -117,7 +117,7 @@
+ active = true;
+ }
+
+-#ifdef HAVE_HIRES_TIMER
++#if defined(HAVE_HIRES_TIMER) && !defined(__FreeBSD__)
+ void TimerPort::sleepTimer(void)
+ {
+ struct timespec ts;