aboutsummaryrefslogtreecommitdiff
path: root/devel/commoncpp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-03 22:30:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-03 22:30:47 +0000
commit11af410024eb23c6e9264da8767cba69eab0232c (patch)
tree00dc2cb844c521c383563a8445bc104e130011f3 /devel/commoncpp
parent976d41d5b051bd89aa32b53e538a00ffd2b84641 (diff)
downloadports-11af410024eb23c6e9264da8767cba69eab0232c.tar.gz
ports-11af410024eb23c6e9264da8767cba69eab0232c.zip
Notes
Diffstat (limited to 'devel/commoncpp')
-rw-r--r--devel/commoncpp/Makefile20
-rw-r--r--devel/commoncpp/distinfo4
-rw-r--r--devel/commoncpp/files/patch-config:ltmain.sh15
-rw-r--r--devel/commoncpp/files/patch-include-cc++-Makefile.in11
-rw-r--r--devel/commoncpp/files/patch-include_cc++_thread.h11
-rw-r--r--devel/commoncpp/pkg-descr2
-rw-r--r--devel/commoncpp/pkg-plist21
7 files changed, 37 insertions, 47 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index 9246596f8c8b..b9425950aca0 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -6,24 +6,26 @@
#
PORTNAME= commoncpp2
-PORTVERSION= 1.1.0
-PORTREVISION= 0
+PORTVERSION= 1.2.7
PORTEPOCH= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU} \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= commonc++ cplusplus
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gnutelephony
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU project portable class framework for C++
-USE_GETOPT_LONG=yes
-USE_GNOME= gnometarget libxml2
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_GNOME= gnomehack gnometarget libxml2
+USE_GETOPT_LONG= yes
USE_GMAKE= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ ac_cv_path_DOXYGEN=no
INSTALLS_SHLIB= yes
INFO= commoncpp2
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
.include <bsd.port.mk>
diff --git a/devel/commoncpp/distinfo b/devel/commoncpp/distinfo
index 182d73e159ce..32df1620c8b4 100644
--- a/devel/commoncpp/distinfo
+++ b/devel/commoncpp/distinfo
@@ -1,2 +1,2 @@
-MD5 (commoncpp2-1.1.0.tar.gz) = 2063b53d4918df9c0a2dd157ad197573
-SIZE (commoncpp2-1.1.0.tar.gz) = 749562
+MD5 (commoncpp2-1.2.7.tar.gz) = 6d0b05f02e2f2881ff6fa5ee2696c88d
+SIZE (commoncpp2-1.2.7.tar.gz) = 814003
diff --git a/devel/commoncpp/files/patch-config:ltmain.sh b/devel/commoncpp/files/patch-config:ltmain.sh
deleted file mode 100644
index ede65a87bcf6..000000000000
--- a/devel/commoncpp/files/patch-config:ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- autoconf/ltmain.sh.orig Thu Feb 12 16:50:30 2004
-+++ autoconf/ltmain.sh Thu Feb 12 16:50:39 2004
-@@ -5428,10 +5428,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/commoncpp/files/patch-include-cc++-Makefile.in b/devel/commoncpp/files/patch-include-cc++-Makefile.in
new file mode 100644
index 000000000000..0bafe1402e94
--- /dev/null
+++ b/devel/commoncpp/files/patch-include-cc++-Makefile.in
@@ -0,0 +1,11 @@
+--- include/cc++/Makefile.in.bak Sat Nov 20 13:51:00 2004
++++ include/cc++/Makefile.in Sat Jun 4 00:22:54 2005
+@@ -224,7 +224,7 @@
+ AUTOMAKE_OPTIONS = no-dependencies dist-shar dist-zip
+ EXTRA_DIST = *.h
+ MAINTAINERCLEANFILES = config.h Makefile.in config.tmp
+-ccxxincludedir = $(ccincludedir)/cc++/
++ccxxincludedir = $(ccincludedir)/cc++
+
+ # export.h are used by other library
+ ccxxinclude_HEADERS = \
diff --git a/devel/commoncpp/files/patch-include_cc++_thread.h b/devel/commoncpp/files/patch-include_cc++_thread.h
deleted file mode 100644
index 8b976b1ac738..000000000000
--- a/devel/commoncpp/files/patch-include_cc++_thread.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/cc++/thread.h.orig Sat Jan 17 17:51:01 2004
-+++ include/cc++/thread.h Thu Dec 23 16:38:55 2004
-@@ -914,7 +914,7 @@
- static Thread* _main;
-
- Thread *_parent;
-- enum Cancel _cancel;
-+ Cancel _cancel;
- Semaphore *_start;
-
- // private data
diff --git a/devel/commoncpp/pkg-descr b/devel/commoncpp/pkg-descr
index f25255c93ac8..d400a7c09221 100644
--- a/devel/commoncpp/pkg-descr
+++ b/devel/commoncpp/pkg-descr
@@ -3,7 +3,7 @@ framework. Common C++ provides classes for threads, sockets, daemon
management, system logging, object synchronization, realtime network
development, persistant object management, and file access.
-WWW: http://www.gnu.org/software/commoncpp/
+WWW: http://www.gnutelephony.org/
- David Sugar
dyfet@gnu.org
diff --git a/devel/commoncpp/pkg-plist b/devel/commoncpp/pkg-plist
index 6c472ef23bc4..d919efd00f87 100644
--- a/devel/commoncpp/pkg-plist
+++ b/devel/commoncpp/pkg-plist
@@ -1,4 +1,5 @@
bin/ccgnu2-config
+include/cc++2/cc++/address.h
include/cc++2/cc++/buffer.h
include/cc++2/cc++/cmdoptns.h
include/cc++2/cc++/common.h
@@ -31,14 +32,16 @@ include/cc++2/cc++/thread.h
include/cc++2/cc++/unix.h
include/cc++2/cc++/url.h
include/cc++2/cc++/xml.h
-@dirrm include/cc++2/cc++
-@dirrm include/cc++2
-share/aclocal/ost_check2.m4
-lib/libccgnu2.a
-lib/libccgnu2.so
-lib/libccgnu2-1.1.so
-lib/libccgnu2-1.1.so.0
+lib/libccext2-1.2.so
+lib/libccext2-1.2.so.1
lib/libccext2.a
lib/libccext2.so
-lib/libccext2-1.1.so
-lib/libccext2-1.1.so.0
+lib/libccgnu2-1.2.so
+lib/libccgnu2-1.2.so.1
+lib/libccgnu2.a
+lib/libccgnu2.so
+libdata/pkgconfig/libccext2.pc
+libdata/pkgconfig/libccgnu2.pc
+share/aclocal/ost_check2.m4
+@dirrm include/cc++2/cc++
+@dirrm include/cc++2