aboutsummaryrefslogtreecommitdiff
path: root/devel/cons-test
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-11-29 23:05:39 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-11-29 23:05:39 +0000
commit1b053d6e5214cec97d96294aef894a5706712e7f (patch)
tree840e627d132adc3509588fe1ce0c8669f55aff6a /devel/cons-test
parent906c3f9ae2d4cf2e6b0c42abc2d106d17ed2e9c1 (diff)
downloadports-1b053d6e5214cec97d96294aef894a5706712e7f.tar.gz
ports-1b053d6e5214cec97d96294aef894a5706712e7f.zip
Notes
Diffstat (limited to 'devel/cons-test')
-rw-r--r--devel/cons-test/Makefile8
-rw-r--r--devel/cons-test/pkg-plist14
2 files changed, 12 insertions, 10 deletions
diff --git a/devel/cons-test/Makefile b/devel/cons-test/Makefile
index 3d89b456a78c..c002d7f6d2b7 100644
--- a/devel/cons-test/Makefile
+++ b/devel/cons-test/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cons-test
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.dsmit.com/cons/stable/ \
http://www.gnu.org/software/cons/stable/ \
@@ -23,7 +24,8 @@ USE_PERL5= yes
NO_BUILD= yes
CONS_TEST= cons-${PORTVERSION}/test
WRKSRC= ${WRKDIR}/${CONS_TEST}
-PLIST_SUB= CONS_VER=${PORTVERSION} CONS_TEST=${CONS_TEST}
+PLIST_SUB+= CONS_VER=${PORTVERSION} CONS_TEST=${CONS_TEST}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/-test//}-${PORTVERSION}/test
MAN1= cons-test.1
MANCOMPRESSED= yes
@@ -63,10 +65,10 @@ do-install:
#
# Install the documentation
#
- ${MKDIR} ${PREFIX}/share/doc/${CONS_TEST}
+ ${MKDIR} ${DOCSDIR}
.for f in ${DOCS}
${INSTALL} -c ${WRKSRC}/$f \
- ${PREFIX}/share/doc/${CONS_TEST}
+ ${DOCSDIR}
.endfor
.endif
diff --git a/devel/cons-test/pkg-plist b/devel/cons-test/pkg-plist
index 7301713bcd60..b9acf9f175ec 100644
--- a/devel/cons-test/pkg-plist
+++ b/devel/cons-test/pkg-plist
@@ -1,11 +1,11 @@
bin/cons-test
-%%PORTDOCS%%share/doc/%%CONS_TEST%%/CHANGES
-%%PORTDOCS%%share/doc/%%CONS_TEST%%/COPYING
-%%PORTDOCS%%share/doc/%%CONS_TEST%%/COPYRIGHT
-%%PORTDOCS%%share/doc/%%CONS_TEST%%/README
-%%PORTDOCS%%share/doc/%%CONS_TEST%%/TODO
-%%PORTDOCS%%share/doc/%%CONS_TEST%%/Tests.txt
-%%PORTDOCS%%@dirrm share/doc/%%CONS_TEST%%
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/Tests.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
lib/%%CONS_TEST%%/t/t0001.t
lib/%%CONS_TEST%%/t/t0002.t
lib/%%CONS_TEST%%/t/t0003.t