aboutsummaryrefslogtreecommitdiff
path: root/devel/cpan-upload-http
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-04-01 15:08:33 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-04-01 15:08:33 +0000
commit5003efdd385d3bf4034aadecadc5cc5e891741c6 (patch)
treeeb9134c49b1f01602da5a3413ad26475f85086f9 /devel/cpan-upload-http
parentc6ce84316b15df9f77a8b67a15134d1027e53f2b (diff)
Notes
Diffstat (limited to 'devel/cpan-upload-http')
-rw-r--r--devel/cpan-upload-http/Makefile27
-rw-r--r--devel/cpan-upload-http/distinfo3
-rw-r--r--devel/cpan-upload-http/pkg-descr4
-rw-r--r--devel/cpan-upload-http/pkg-plist3
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/cpan-upload-http/Makefile b/devel/cpan-upload-http/Makefile
new file mode 100644
index 000000000000..6fca1ae80f84
--- /dev/null
+++ b/devel/cpan-upload-http/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cpan::upload::http
+# Date created: 01 Apr 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpan-upload-http
+PORTVERSION= 2.4
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/B/BR/BRADFITZ
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl script to upload one or more files to CPAN, using PAUSE
+
+RUN_DEPENDS= \
+ p5-AppConfig-Std>=1.05:${PORTSDIR}/devel/p5-AppConfig-Std \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-Term-ReadKey>0:${PORTSDIR}/devel/p5-Term-ReadKey
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= cpan-upload-http.1
+
+.include <bsd.port.mk>
diff --git a/devel/cpan-upload-http/distinfo b/devel/cpan-upload-http/distinfo
new file mode 100644
index 000000000000..7254dc1f56da
--- /dev/null
+++ b/devel/cpan-upload-http/distinfo
@@ -0,0 +1,3 @@
+MD5 (cpan-upload-http-2.4.tar.gz) = 03e08850d1fbc584eeb6db82eecc4f1f
+SHA256 (cpan-upload-http-2.4.tar.gz) = 2d8abe8827b30f8f7960ca8837ce108ae83a774d61b9df56aa786d352c875836
+SIZE (cpan-upload-http-2.4.tar.gz) = 7355
diff --git a/devel/cpan-upload-http/pkg-descr b/devel/cpan-upload-http/pkg-descr
new file mode 100644
index 000000000000..f4af80270ce6
--- /dev/null
+++ b/devel/cpan-upload-http/pkg-descr
@@ -0,0 +1,4 @@
+cpan-upload-http is a script which automates the process of uploading
+a file to CPAN using PAUSE, the Perl Authors Upload Server.
+
+WWW: http://search.cpan.org/dist/cpan-upload-http/
diff --git a/devel/cpan-upload-http/pkg-plist b/devel/cpan-upload-http/pkg-plist
new file mode 100644
index 000000000000..2bfffc57fb96
--- /dev/null
+++ b/devel/cpan-upload-http/pkg-plist
@@ -0,0 +1,3 @@
+bin/cpan-upload-http
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/cpan-upload-http/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/cpan-upload-http