aboutsummaryrefslogtreecommitdiff
path: root/devel/cpan-upload/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-12-01 20:11:55 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-12-01 20:11:55 +0000
commiteaa876894a4ee8e4e845d63ec9427cb9880a93e2 (patch)
treea343e9a283c42dc3bc84e4e70ccd251652047ec5 /devel/cpan-upload/Makefile
parentdb6967e5c9a68588ff6e92fb26f720902981c7e6 (diff)
downloadports-eaa876894a4ee8e4e845d63ec9427cb9880a93e2.tar.gz
ports-eaa876894a4ee8e4e845d63ec9427cb9880a93e2.zip
Notes
Diffstat (limited to 'devel/cpan-upload/Makefile')
-rw-r--r--devel/cpan-upload/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/devel/cpan-upload/Makefile b/devel/cpan-upload/Makefile
index 4da8f8970c4b..2e8007ba16b6 100644
--- a/devel/cpan-upload/Makefile
+++ b/devel/cpan-upload/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cpan-upload
PORTVERSION= 2.2
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../by-authors/id/N/NE/NEILB/scripts
@@ -14,15 +15,19 @@ MASTER_SITE_SUBDIR= ../by-authors/id/N/NE/NEILB/scripts
MAINTAINER= lth@FreeBSD.org
COMMENT= Script for uploading distributions to CPAN
-BUILD_DEPENDS= ${SITE_PERL}/AppConfig/Std.pm:${PORTSDIR}/devel/p5-AppConfig-Std \
- ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-Pod-Parser \
- ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
- ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-AppConfig-Std>=1.05:${PORTSDIR}/devel/p5-AppConfig-Std \
+ p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN1= cpan-upload.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Net>=2.28:${PORTSDIR}/net/p5-Net
+.endif
+
+.include <bsd.port.post.mk>