aboutsummaryrefslogtreecommitdiff
path: root/devel/cppcheck
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-02-08 01:03:19 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-02-08 01:03:19 +0000
commit25d0f36737c887b713b9f01c64d950d629db59d5 (patch)
treea313d14f99cfb6cee5f6417305de5f8bc9b0c723 /devel/cppcheck
parente576495387cab3b4de69feac0f502ee43c636dcf (diff)
downloadports-25d0f36737c887b713b9f01c64d950d629db59d5.tar.gz
ports-25d0f36737c887b713b9f01c64d950d629db59d5.zip
Notes
Diffstat (limited to 'devel/cppcheck')
-rw-r--r--devel/cppcheck/Makefile11
-rw-r--r--devel/cppcheck/distinfo4
-rw-r--r--devel/cppcheck/files/patch-Makefile24
3 files changed, 19 insertions, 20 deletions
diff --git a/devel/cppcheck/Makefile b/devel/cppcheck/Makefile
index 0a31fb1cfc14..80f5993d8d83 100644
--- a/devel/cppcheck/Makefile
+++ b/devel/cppcheck/Makefile
@@ -6,17 +6,20 @@
#
PORTNAME= cppcheck
-PORTVERSION= 1.46.1
+PORTVERSION= 1.47
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
MAINTAINER= bf@FreeBSD.org
COMMENT= Static analysis of C/C++ code
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
USE_GMAKE= yes
USE_BZIP2= yes
-LDFLAGS+= ${PTHREAD_LIBS}
-MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/cppcheck
@@ -28,7 +31,7 @@ BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
MANCOMPRESSED= no
MAN1= cppcheck.1
-ALL_TARGET+= cppcheck.1
+ALL_TARGET+= man
post-install:
@${INSTALL_MAN} ${WRKSRC}/cppcheck.1 ${PREFIX}/man/man1
diff --git a/devel/cppcheck/distinfo b/devel/cppcheck/distinfo
index 2eb80ba4b7f7..b71049f7f1fc 100644
--- a/devel/cppcheck/distinfo
+++ b/devel/cppcheck/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cppcheck-1.46.1.tar.bz2) = e91f6be0f4aeeda3a3bbfd19caa9f7e35013018d9a9f164653bad1f266f08f34
-SIZE (cppcheck-1.46.1.tar.bz2) = 676586
+SHA256 (cppcheck-1.47.tar.bz2) = 60d290088a131b49ed4b30cc6940b6a041b59002404223500dce65d71c2a46ae
+SIZE (cppcheck-1.47.tar.bz2) = 794349
diff --git a/devel/cppcheck/files/patch-Makefile b/devel/cppcheck/files/patch-Makefile
index 8a03a798430a..ae545b9bf0b5 100644
--- a/devel/cppcheck/files/patch-Makefile
+++ b/devel/cppcheck/files/patch-Makefile
@@ -1,15 +1,11 @@
---- Makefile.orig 2009-03-02 20:22:53.000000000 +0100
-+++ Makefile 2009-03-03 22:49:59.000000000 +0100
-@@ -92,6 +92,12 @@
- clean:
- rm -f src/*.o test/*.o testrunner cppcheck tools/dmake tools/errmsg
+--- Makefile.orig 2011-02-06 06:14:09.000000000 -0500
++++ Makefile 2011-02-07 15:35:58.000000000 -0500
+@@ -15,7 +15,7 @@
+ BIN=$(DESTDIR)$(PREFIX)/bin
+
+ # For 'make man': sudo apt-get install xsltproc docbook-xsl docbook-xml on Linux
+-DB2MAN=/usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl
++DB2MAN=${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl
+ XP=xsltproc -''-nonet -''-param man.charmap.use.subset "0"
+ MAN_SOURCE=man/cppcheck.1.xml
-+DB2MAN= ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl
-+XP= xsltproc -''-nonet -''-param man.charmap.use.subset "0"
-+
-+cppcheck.1: man/cppcheck.1.xml
-+ $(XP) $(DB2MAN) $<
-+
- install: cppcheck
- install -d ${BIN}
- install cppcheck ${BIN}