aboutsummaryrefslogtreecommitdiff
path: root/devel/cppi/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-08 23:12:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-08 23:12:55 +0000
commit97bacd96154e85c28c2a78e9495cfcd748e6e64f (patch)
tree63e17c30961f0a44bf0343a22a08cda00d9720f5 /devel/cppi/Makefile
parent76cd4a8426bbc090699eb73d823712e3e7ae4efc (diff)
Notes
Diffstat (limited to 'devel/cppi/Makefile')
-rw-r--r--devel/cppi/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/cppi/Makefile b/devel/cppi/Makefile
new file mode 100644
index 000000000000..75d819fcc72d
--- /dev/null
+++ b/devel/cppi/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: cppi
+# Date created: 2006-11-05
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cppi
+PORTVERSION= 1.12
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= coreutils
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= A tool to indent the C preprocessor directives
+
+USE_GPG?= yes
+SIG_FILES= ${DISTNAME}${EXTRACT_SUFX}.sig
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/cppi
+MAN1= cppi.1
+
+.include <bsd.port.mk>