aboutsummaryrefslogtreecommitdiff
path: root/devel/cppunit/Makefile
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2003-06-28 17:44:04 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2003-06-28 17:44:04 +0000
commit5759747096725a189ee316a0a6215ef030258baf (patch)
tree901549ea8b089e59f84cf6af38efcac9e44837a1 /devel/cppunit/Makefile
parent6f854c893425f9a0ed2a469a15add19061a493ff (diff)
Notes
Diffstat (limited to 'devel/cppunit/Makefile')
-rw-r--r--devel/cppunit/Makefile33
1 files changed, 26 insertions, 7 deletions
diff --git a/devel/cppunit/Makefile b/devel/cppunit/Makefile
index 64c55ad067f8..32568fdaa29e 100644
--- a/devel/cppunit/Makefile
+++ b/devel/cppunit/Makefile
@@ -5,28 +5,47 @@
# $FreeBSD$
PORTNAME= cppunit
-PORTVERSION= 1.6.2
+PORTVERSION= 1.8.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= gcross@netspace.net.au
+.if defined(WITH_DOXYGEN)
+BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+.endif
+
+MAINTAINER= gcross@fastmail.fm
COMMENT= C++ port of the JUnit framework for unit testing
HAS_CONFIGURE= yes
+.if defined(WITH_DOXYGEN) && !defined(NOPORTDOCS)
+CONFIGURE_ARGS+= --enable-doc --enable-doxygen --enable-html-docs
+PLIST_SUB+= DOXYGEN=""
+.else
+CONFIGURE_ARGS+= --disable-doc --disable-doxygen
+PLIST_SUB+= DOXYGEN="@comment "
+.endif
INSTALLS_SHLIB= yes
.if !defined(NOMAN)
MAN1= cppunit-config.1
.endif
MANCOMPRESSED= no
+pre-everything:
+.if !defined(WITH_DOXYGEN) && !defined(NOPORTDOCS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} You could define WITH_DOXYGEN if you want HTML documentation
+ @${ECHO_MSG}
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/cppunit
- ${INSTALL_MAN} ${WRKSRC}/NEWS ${PREFIX}/share/doc/cppunit
- ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/cppunit
+.if !defined(WITH_DOXYGEN)
+ ${MKDIR} -p ${PREFIX}/share/doc/cppunit
${INSTALL_MAN} ${WRKSRC}/doc/FAQ ${PREFIX}/share/doc/cppunit
- ${INSTALL_MAN} ${WRKSRC}/doc/cookbook.html ${PREFIX}/share/doc/cppunit
+.endif
+ ${INSTALL_MAN} ${WRKSRC}/NEWS ${PREFIX}/share/doc/cppunit
+ ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/cppunit
.endif
-
+
.include <bsd.port.mk>