aboutsummaryrefslogtreecommitdiff
path: root/devel/critcl
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2017-10-24 11:35:35 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2017-10-24 11:35:35 +0000
commit1c53409cf4263bd0881553859347163cb9f2a478 (patch)
tree8a991108687e65605665f127cece15f418066518 /devel/critcl
parent1b5f280ea1e3b19df5e315d63d7686d6bf7c24f1 (diff)
Notes
Diffstat (limited to 'devel/critcl')
-rw-r--r--devel/critcl/Makefile1
-rw-r--r--devel/critcl/distinfo6
-rw-r--r--devel/critcl/files/patch-build.tcl28
-rw-r--r--devel/critcl/files/patch-lib_critcl_Config (renamed from devel/critcl/files/patch-lib-critcl_Config)4
-rw-r--r--devel/critcl/files/patch-test_cache.test20
-rw-r--r--devel/critcl/files/patch-test_support_testutilities.tcl12
-rw-r--r--devel/critcl/pkg-plist1
7 files changed, 39 insertions, 33 deletions
diff --git a/devel/critcl/Makefile b/devel/critcl/Makefile
index 2f2bad07b1fd..544aaa846f11 100644
--- a/devel/critcl/Makefile
+++ b/devel/critcl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= critcl
PORTVERSION= 3.1.17
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= tcltk@FreeBSD.org
diff --git a/devel/critcl/distinfo b/devel/critcl/distinfo
index b4d28d79628c..d1e34c7109df 100644
--- a/devel/critcl/distinfo
+++ b/devel/critcl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1505921463
-SHA256 (andreas-kupries-critcl-3.1.17_GH0.tar.gz) = d1fdb23b252280f6159df7eb3cfbda9daa61f9185b7dc881d11f0253e41a367d
-SIZE (andreas-kupries-critcl-3.1.17_GH0.tar.gz) = 1744383
+TIMESTAMP = 1508842896
+SHA256 (andreas-kupries-critcl-3.1.17_GH0.tar.gz) = fff83b341fc07b8ff23bf1f645133bb4bffe4741da2e6f31155e522a74c228e4
+SIZE (andreas-kupries-critcl-3.1.17_GH0.tar.gz) = 1768244
diff --git a/devel/critcl/files/patch-build.tcl b/devel/critcl/files/patch-build.tcl
deleted file mode 100644
index 811e72edd763..000000000000
--- a/devel/critcl/files/patch-build.tcl
+++ /dev/null
@@ -1,28 +0,0 @@
---- build.tcl.orig 2017-08-25 03:29:15.000000000 +0000
-+++ build.tcl 2017-09-27 10:53:21.223065000 +0000
-@@ -323,7 +323,7 @@
- set dsta [file dirname [file dirname [file normalize [info nameofexecutable]/___]]]
- } else {
- set dstl [lindex $args 0]
-- set dsta [file dirname [findlib $dstl]]/bin
-+ set dsta $dstl/../bin
- }
-
- set selfdir [file dirname $me]
-@@ -369,7 +369,7 @@
- set theapp [critapp $dsta]
-
- set c [open $theapp w]
-- puts $c "#!/bin/sh\n# -*- tcl -*- \\\nexec [file dirname [file normalize [info nameofexecutable]/___]] \"\$0\" \$\{1+\"\$@\"\}\npackage require critcl::app\ncritcl::app::main \$argv"
-+ puts $c "#!/bin/sh\n# -*- tcl -*- \\\nexec [file dirname [file normalize [info nameofexecutable]/___]] \"\$0\" \$\{1+\"\$@\"\}\nlappend auto_path \[file join \[file dirname \[info script\]\] .. lib\]\npackage require critcl::app\ncritcl::app::main \$argv"
- close $c
- +x $theapp
-
-@@ -395,6 +395,7 @@
- lappend cmd [info nameofexecutable]
- }
- lappend cmd $theapp
-+ lappend cmd -cache [file join $selfdir cache]
- if {$target ne {}} {
- lappend cmd -target $target
- }
diff --git a/devel/critcl/files/patch-lib-critcl_Config b/devel/critcl/files/patch-lib_critcl_Config
index 7cdf191dcb14..c7c2c9bae3fa 100644
--- a/devel/critcl/files/patch-lib-critcl_Config
+++ b/devel/critcl/files/patch-lib_critcl_Config
@@ -1,5 +1,5 @@
---- lib/critcl/Config.orig 2013-11-05 09:57:26.000000000 +0100
-+++ lib/critcl/Config 2013-11-05 09:57:54.000000000 +0100
+--- lib/critcl/Config.orig 2017-10-14 02:48:11 UTC
++++ lib/critcl/Config
@@ -52,13 +52,13 @@
# the "copy" option and then specifically setting the config bits that
# you want to change. See win32-x86_64-cl for an example.
diff --git a/devel/critcl/files/patch-test_cache.test b/devel/critcl/files/patch-test_cache.test
new file mode 100644
index 000000000000..9458ef7513e2
--- /dev/null
+++ b/devel/critcl/files/patch-test_cache.test
@@ -0,0 +1,20 @@
+--- test/cache.test.orig 2017-10-14 02:48:11 UTC
++++ test/cache.test
+@@ -45,7 +45,7 @@ test critcl-cache-1.0.4 {cache, wrong\#a
+
+ test critcl-cache-2.0 {cache, default, home directory} -body {
+ critcl::cache
+-} -match glob -result $::env(HOME)/.critcl/*
++} -match glob -result [file normalize $::env(HOME)/.critcl/*]
+
+ test critcl-cache-2.1 {cache, redirecting cache} -setup {
+ set here [critcl::cache]
+@@ -54,7 +54,7 @@ test critcl-cache-2.1 {cache, redirectin
+ } -cleanup {
+ critcl::cache $here
+ unset here
+-} -match glob -result $::env(HOME)/FOO
++} -match glob -result [file normalize $::env(HOME)/FOO]
+
+ # -------------------------------------------------------------------------
+ testsuiteCleanup
diff --git a/devel/critcl/files/patch-test_support_testutilities.tcl b/devel/critcl/files/patch-test_support_testutilities.tcl
new file mode 100644
index 000000000000..de1e2ebc6f10
--- /dev/null
+++ b/devel/critcl/files/patch-test_support_testutilities.tcl
@@ -0,0 +1,12 @@
+--- test/support/testutilities.tcl.orig 2017-10-24 11:30:43 UTC
++++ test/support/testutilities.tcl
+@@ -4,6 +4,9 @@
+ # <akupries@shaw.ca>
+ # <andreas.kupries@gmail.com>
+
++set auto_path [linsert $auto_path 0 \
++ [file join [file dirname [file dirname [file dirname [info script]]]] lib]]
++
+ namespace eval ::tcllib::testutils {
+ variable version 1.2
+ variable self [file dirname [file join [pwd] [info script]]]
diff --git a/devel/critcl/pkg-plist b/devel/critcl/pkg-plist
index 39267df730af..77c12330d147 100644
--- a/devel/critcl/pkg-plist
+++ b/devel/critcl/pkg-plist
@@ -131,6 +131,7 @@ man/mann/critcl_app.n.gz
man/mann/critcl_apppkg.n.gz
man/mann/critcl_bitmap.n.gz
man/mann/critcl_class.n.gz
+man/mann/critcl_cproc.n.gz
man/mann/critcl_cutil.n.gz
man/mann/critcl_devguide.n.gz
man/mann/critcl_emap.n.gz