aboutsummaryrefslogtreecommitdiff
path: root/devel/cross-gcc
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-04-10 08:34:12 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-04-10 08:34:12 +0000
commitd20e448acd8a30ac2de3c08e2b611f900223efa5 (patch)
tree39225082dfe4417b7244baacbf86c365495611c5 /devel/cross-gcc
parent0b369b2cb8923636ce760edd06e923e5c982f217 (diff)
downloadports-d20e448acd8a30ac2de3c08e2b611f900223efa5.tar.gz
ports-d20e448acd8a30ac2de3c08e2b611f900223efa5.zip
Notes
Diffstat (limited to 'devel/cross-gcc')
-rw-r--r--devel/cross-gcc/Makefile24
-rw-r--r--devel/cross-gcc/distinfo18
-rw-r--r--devel/cross-gcc/files/patch-configure18
3 files changed, 34 insertions, 26 deletions
diff --git a/devel/cross-gcc/Makefile b/devel/cross-gcc/Makefile
index a33aebe355b3..612a562110c1 100644
--- a/devel/cross-gcc/Makefile
+++ b/devel/cross-gcc/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME?= gcc
-PORTVERSION= 4.2.3
-PORTREVISION= 1
+PORTVERSION= 4.3.2
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC:S,$,:gcc,} \
${MASTER_SITE_SOURCEWARE:S,$,:newlib,}
@@ -23,6 +23,9 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= stas@FreeBSD.org
COMMENT= GNU gcc for cross-target development
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
+ mpfr.3:${PORTSDIR}/math/mpfr
+
#
# Temporary hack to deal with dependencies during package builds for
# slave ports.
@@ -44,6 +47,11 @@ ALL_TARGET= all info
DEPENDS_ARGS= TGTARCH="${TGTARCH}" TGTABI="${TGTABI}"
+CONFIGURE_WRKSRC= ${WRKDIR}/build
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
+CONFIGURE_SCRIPT= ../${WRKSRC:C,^${WRKDIR}/?,,}/configure
+
#
# Newlib version to use
#
@@ -67,7 +75,9 @@ CONFIGURE_ARGS= --target=${OURTARGET} \
--with-newlib \
--with-dwarf2 \
--with-gxx-include-dir=${TGT_LIBDIR}/include/cxx/ \
- --disable-shared
+ --disable-shared \
+ --with-gmp="${LOCALBASE}" \
+ --with-mpfr="${LOCALBASE}" \
MAN1= ${MANPAGES:S,^,${OURTARGET}-,}
@@ -111,8 +121,8 @@ CONFIGURE_ARGS+=--with-float=${WITH_FLOAT_TYPE}
.endif
.if defined(WITH_RTEMS_PATCHES)
-PATCHFILES+= gcc-core-4.2.3-rtems4.9-20080205.diff \
- newlib-${NEWLIB_VERSION}-rtems4.9-20080302.diff
+PATCHFILES+= gcc-core-4.3.2-rtems4.9-20081214.diff \
+ newlib-${NEWLIB_VERSION}-rtems4.9-20081203.diff
.endif
#
@@ -157,9 +167,6 @@ TGTLANGS:= "${TGTLANGS},objc"
.if defined(WITH_FORTRAN)
TGTLANGS:= "${TGTLANGS},fortran"
-LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.3:${PORTSDIR}/math/mpfr
-CONFIGURE_ARGS+= --with-gmp=${LOCALBASE}
PLIST_FILES+= bin/${OURTARGET}-gfortran \
${OURTARGET}/bin/gfortran
.endif
@@ -184,6 +191,7 @@ post-extract:
@${LN} -sf ${WRKSRC}/newlib-${NEWLIB_VERSION}/newlib ${WRKSRC}/newlib
@${LN} -sf ${WRKSRC}/newlib-${NEWLIB_VERSION}/libgloss \
${WRKSRC}/libgloss
+ ${MKDIR} ${CONFIGURE_WRKSRC}/
post-patch:
#
diff --git a/devel/cross-gcc/distinfo b/devel/cross-gcc/distinfo
index 0d393747ba8a..872f893f7186 100644
--- a/devel/cross-gcc/distinfo
+++ b/devel/cross-gcc/distinfo
@@ -1,12 +1,12 @@
-MD5 (gcc-4.2.3.tar.bz2) = ef2a4d9991b3644115456ea05b2b8163
-SHA256 (gcc-4.2.3.tar.bz2) = 5df9a267091eea09179651ad2a2302fe99f780ac7e598278e7f47b2339fa2e80
-SIZE (gcc-4.2.3.tar.bz2) = 44455012
+MD5 (gcc-4.3.2.tar.bz2) = 5dfac5da961ecd5f227c3175859a486d
+SHA256 (gcc-4.3.2.tar.bz2) = bfbf487731ad5dca37efe480a837417de071bd67e685d5c1df6a290707575165
+SIZE (gcc-4.3.2.tar.bz2) = 58929447
MD5 (newlib-1.16.0.tar.gz) = bf8f1f9e3ca83d732c00a79a6ef29bc4
SHA256 (newlib-1.16.0.tar.gz) = db426394965c48c1d29023e1cc6d965ea6b9a9035d8a849be2750ca4659a3d07
SIZE (newlib-1.16.0.tar.gz) = 12024353
-MD5 (gcc-core-4.2.3-rtems4.9-20080205.diff) = d5a6a8c5973024476f0df6356b5e0424
-SHA256 (gcc-core-4.2.3-rtems4.9-20080205.diff) = 1a2bb7d8c8524f38fb89bf634240d6a9be3b0fb31e9d949569b561f376e0847c
-SIZE (gcc-core-4.2.3-rtems4.9-20080205.diff) = 4550
-MD5 (newlib-1.16.0-rtems4.9-20080302.diff) = a227456d0850e24a839634096b879c30
-SHA256 (newlib-1.16.0-rtems4.9-20080302.diff) = 599fc24c6e6bda667a0e7917d06351afcd11dba91d8110fa8b43291556517335
-SIZE (newlib-1.16.0-rtems4.9-20080302.diff) = 54490
+MD5 (gcc-core-4.3.2-rtems4.9-20081214.diff) = a3e75aecaf078c8da876c8529c41ff59
+SHA256 (gcc-core-4.3.2-rtems4.9-20081214.diff) = d3fd4574ea3f27f36ffee7345ac513cfef1843135586154d8c8080e4e4b004d3
+SIZE (gcc-core-4.3.2-rtems4.9-20081214.diff) = 5486
+MD5 (newlib-1.16.0-rtems4.9-20081203.diff) = a80e01d641492a23ffc767b3c0e497e6
+SHA256 (newlib-1.16.0-rtems4.9-20081203.diff) = 1acda758be517f6585aff8346e728e30477254e422354ede129a06001c5f8103
+SIZE (newlib-1.16.0-rtems4.9-20081203.diff) = 34548
diff --git a/devel/cross-gcc/files/patch-configure b/devel/cross-gcc/files/patch-configure
index 1177f686f18b..9d6758e527b7 100644
--- a/devel/cross-gcc/files/patch-configure
+++ b/devel/cross-gcc/files/patch-configure
@@ -1,24 +1,24 @@
---- configure.orig Mon May 14 07:19:11 2007
-+++ configure Thu Jun 21 21:53:48 2007
-@@ -3321,7 +3321,7 @@
+--- configure.orig 2009-04-07 18:00:41.000000000 +0400
++++ configure 2009-04-07 18:06:28.000000000 +0400
+@@ -5758,7 +5758,7 @@
# For the build-side libraries, we just need to pretend we're native,
# and not use the same cache file. Multilibs are neither needed nor
# desired.
--build_configargs="--cache-file=../config.cache --build=${build_alias} --host=${build_alias} --target=${target_alias} ${baseargs}"
-+build_configargs="--build=${build_alias} --host=${build_alias} --target=${target_alias} ${baseargs}"
+-build_configargs="--cache-file=../config.cache ${baseargs}"
++build_configargs="${baseargs}"
# For host modules, accept cache file option, or specification as blank.
case "${cache_file}" in
-@@ -3371,7 +3371,7 @@
+@@ -5808,7 +5808,7 @@
# Pass the appropriate --build, --host, --target and --cache-file arguments.
# We need to pass --target, as newer autoconf's requires consistency
# for target_alias and gcc doesn't manage it consistently.
--target_configargs="--cache-file=./config.cache --build=${build_alias} --host=${target_alias} --target=${target_alias} ${target_configargs}"
-+target_configargs="--build=${build_alias} --host=${target_alias} --target=${target_alias} ${target_configargs}"
+-target_configargs="--cache-file=./config.cache ${target_configargs}"
++target_configargs="${target_configargs}"
FLAGS_FOR_TARGET=
case " $target_configdirs " in
-@@ -3439,7 +3439,7 @@
+@@ -5893,7 +5893,7 @@
# being built; programs in there won't even run.
if test "${build}" = "${host}" && test -d ${srcdir}/gcc; then
# Search for pre-installed headers if nothing else fits.