aboutsummaryrefslogtreecommitdiff
path: root/devel/crossgo32
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-22 16:21:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-22 16:21:46 +0000
commitc393562b29c366fd679e0c998edf510bec978008 (patch)
tree0f52d0d218a995536d8ff03b808ad9d5e11107fe /devel/crossgo32
parentfec231f3978fc6d259b263d7b8af2739ad6fd091 (diff)
downloadports-c393562b29c366fd679e0c998edf510bec978008.tar.gz
ports-c393562b29c366fd679e0c998edf510bec978008.zip
Notes
Diffstat (limited to 'devel/crossgo32')
-rw-r--r--devel/crossgo32/Makefile8
-rw-r--r--devel/crossgo32/files/patch-cccp.c56
-rw-r--r--devel/crossgo32/files/patch-functions.def18
-rw-r--r--devel/crossgo32/files/patch-g++.c10
-rw-r--r--devel/crossgo32/files/patch-gcc.c10
-rw-r--r--devel/crossgo32/files/patch-protoize.c30
-rw-r--r--devel/crossgo32/files/patch-strerror.c10
-rw-r--r--devel/crossgo32/files/patch-strsignal.c10
8 files changed, 145 insertions, 7 deletions
diff --git a/devel/crossgo32/Makefile b/devel/crossgo32/Makefile
index eb426b88bf1b..e8e4921bd253 100644
--- a/devel/crossgo32/Makefile
+++ b/devel/crossgo32/Makefile
@@ -35,12 +35,6 @@ MAN1= i386-go32-ar.1 i386-go32-nm.1 i386-go32-objdump.1\
DOCDIR= ${PREFIX}/share/doc/crossgo32
GO32DIR= ${PREFIX}/share/crossgo32
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
post-extract:
${MV} ${WRKDIR}/dosrel-1.0/ ${WRKSRC}
@@ -65,4 +59,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/dosrel-1.0/go32.exe ${GO32DIR}
${INSTALL_DATA} ${WRKSRC}/dosrel-1.0/emu387 ${GO32DIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/crossgo32/files/patch-cccp.c b/devel/crossgo32/files/patch-cccp.c
new file mode 100644
index 000000000000..8ac5809af0d4
--- /dev/null
+++ b/devel/crossgo32/files/patch-cccp.c
@@ -0,0 +1,56 @@
+--- gcc/cccp.c.old Wed May 19 15:10:39 2004
++++ gcc/cccp.c Wed May 19 15:19:53 2004
+@@ -24,6 +24,8 @@
+
+ typedef unsigned char U_CHAR;
+
++#define HAS_STDARG_H
++
+ #ifdef EMACS
+ #define NO_SHORTNAMES
+ #include "../src/config.h"
+@@ -199,7 +201,7 @@
+ # endif
+ #endif
+
+-#if defined (__STDC__) && defined (HAVE_VPRINTF)
++#if defined (__STDC__) && defined (HAVE_VPRINTF) || defined (HAS_STDARG_H)
+ # include <stdarg.h>
+ # define VA_START(va_list, var) va_start (va_list, var)
+ # define PRINTF_ALIST(msg) char *msg, ...
+@@ -8967,7 +8969,7 @@
+ }
+
+ static void
+-#if defined (__STDC__) && defined (HAVE_VPRINTF)
++#if defined (__STDC__) && defined (HAVE_VPRINTF) || defined (HAS_STDARG_H)
+ error_with_line (int line, PRINTF_ALIST (msg))
+ #else
+ error_with_line (line, PRINTF_ALIST (msg))
+@@ -9007,7 +9009,7 @@
+ }
+
+ static void
+-#if defined (__STDC__) && defined (HAVE_VPRINTF)
++#if defined (__STDC__) && defined (HAVE_VPRINTF) || defined (HAS_STDARG_H)
+ warning_with_line (int line, PRINTF_ALIST (msg))
+ #else
+ warning_with_line (line, PRINTF_ALIST (msg))
+@@ -9069,7 +9071,7 @@
+ }
+
+ void
+-#if defined (__STDC__) && defined (HAVE_VPRINTF)
++#if defined (__STDC__) && defined (HAVE_VPRINTF) || defined (HAS_STDARG_H)
+ pedwarn_with_line (int line, PRINTF_ALIST (msg))
+ #else
+ pedwarn_with_line (line, PRINTF_ALIST (msg))
+@@ -9091,7 +9093,7 @@
+ giving specified file name and line number, not current. */
+
+ static void
+-#if defined (__STDC__) && defined (HAVE_VPRINTF)
++#if defined (__STDC__) && defined (HAVE_VPRINTF) || defined (HAS_STDARG_H)
+ pedwarn_with_file_and_line (char *file, int line, PRINTF_ALIST (msg))
+ #else
+ pedwarn_with_file_and_line (file, line, PRINTF_ALIST (msg))
diff --git a/devel/crossgo32/files/patch-functions.def b/devel/crossgo32/files/patch-functions.def
new file mode 100644
index 000000000000..6de88a704a14
--- /dev/null
+++ b/devel/crossgo32/files/patch-functions.def
@@ -0,0 +1,18 @@
+--- libiberty/functions.def.old Thu Jul 4 19:16:36 1996
++++ libiberty/functions.def Wed May 19 18:21:14 2004
+@@ -34,15 +34,12 @@
+ DEF(strchr, char*, (s, c), CONST char *s AND int c)
+ DEF(strdup, char*, (s1), char * s1)
+ DEF(strrchr, char*, (s, c), CONST char *s AND int c)
+-DEF(strstr, char*, (), NOTHING)
+ DEF(strtod, double, (), NOTHING)
+ DEF(strtol, long, (), NOTHING)
+ DEF(strtoul, unsigned long, (), NOTHING)
+ DEF(tmpnam, char *, (s), char * s)
+ DEF(vfork, int, (), NOTHING)
+ DEF(vfprintf, int, (), NOTHING)
+-DEF(vprintf, int, (), NOTHING)
+-DEF(vsprintf, int, (), NOTHING)
+ DEF(sigsetmask, int, (), NOTHING)
+ DEF(alloca, PTR, (size), size_t size)
+ DEF(waitpid, int, (pid, statp, opts), int pid AND int* statp AND int opts )
diff --git a/devel/crossgo32/files/patch-g++.c b/devel/crossgo32/files/patch-g++.c
new file mode 100644
index 000000000000..fbe0466affe8
--- /dev/null
+++ b/devel/crossgo32/files/patch-g++.c
@@ -0,0 +1,10 @@
+--- gcc/cp/g++.c.old Wed May 19 15:33:04 2004
++++ gcc/cp/g++.c Wed May 19 15:33:19 2004
+@@ -92,7 +92,6 @@
+ extern int errno;
+ #endif
+
+-extern int sys_nerr;
+ #ifndef HAVE_STRERROR
+ #if defined(bsd4_4)
+ extern const char *const sys_errlist[];
diff --git a/devel/crossgo32/files/patch-gcc.c b/devel/crossgo32/files/patch-gcc.c
new file mode 100644
index 000000000000..72146566bfc1
--- /dev/null
+++ b/devel/crossgo32/files/patch-gcc.c
@@ -0,0 +1,10 @@
+--- gcc/gcc.c.old Wed May 19 15:29:39 2004
++++ gcc/gcc.c Wed May 19 15:29:46 2004
+@@ -175,7 +175,6 @@
+ extern int errno;
+ #endif
+
+-extern int sys_nerr;
+ #ifndef HAVE_STRERROR
+ #if defined(bsd4_4)
+ extern const char *const sys_errlist[];
diff --git a/devel/crossgo32/files/patch-protoize.c b/devel/crossgo32/files/patch-protoize.c
new file mode 100644
index 000000000000..45bbfe51f532
--- /dev/null
+++ b/devel/crossgo32/files/patch-protoize.c
@@ -0,0 +1,30 @@
+--- gcc/protoize.c.orig Mon Oct 9 18:37:32 1995
++++ gcc/protoize.c Wed May 19 16:16:12 2004
+@@ -22,6 +22,8 @@
+ as __STDC__ plus more, so make sure that __STDC__ is defined if
+ __cplusplus is defined. */
+
++#define HAS_STDARG_H
++
+ #if defined(__cplusplus) && !defined(__STDC__)
+ #define __STDC__ 1
+ #endif /* defined(__cplusplus) && !defined(__STDC__) */
+@@ -57,7 +59,9 @@
+ #define _POSIX_SOURCE
+ #endif
+
++#ifndef HAS_STDARG_H
+ #include <varargs.h>
++#endif
+ /* On some systems stdio.h includes stdarg.h;
+ we must bring in varargs.h first. */
+ #include <stdio.h>
+@@ -66,7 +70,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #ifndef _WIN32
+-#if defined(POSIX) || defined(CONCURRENT)
++#if defined(POSIX) || defined(CONCURRENT) || defined (HAS_STDARG_H)
+ #include <dirent.h>
+ #else
+ #include <sys/dir.h>
diff --git a/devel/crossgo32/files/patch-strerror.c b/devel/crossgo32/files/patch-strerror.c
new file mode 100644
index 000000000000..bb51459bba4e
--- /dev/null
+++ b/devel/crossgo32/files/patch-strerror.c
@@ -0,0 +1,10 @@
+--- libiberty/strerror.c.old Wed May 19 15:01:49 2004
++++ libiberty/strerror.c Wed May 19 15:01:55 2004
+@@ -460,7 +460,6 @@
+
+ #else
+
+-extern int sys_nerr;
+ extern char *sys_errlist[];
+
+ #endif
diff --git a/devel/crossgo32/files/patch-strsignal.c b/devel/crossgo32/files/patch-strsignal.c
new file mode 100644
index 000000000000..067a6244d052
--- /dev/null
+++ b/devel/crossgo32/files/patch-strsignal.c
@@ -0,0 +1,10 @@
+--- libiberty/strsignal.c.old Wed May 19 15:05:20 2004
++++ libiberty/strsignal.c Wed May 19 15:05:32 2004
+@@ -235,7 +235,6 @@
+
+ #else
+
+-static int sys_nsig = NSIG;
+ extern const char * const sys_siglist[];
+
+ #endif