aboutsummaryrefslogtreecommitdiff
path: root/devel/crossgo32
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-01-29 02:46:13 +0000
committerSteve Price <steve@FreeBSD.org>2000-01-29 02:46:13 +0000
commite71900fd0b7f1c09c97f204e25f649bf20d8384c (patch)
tree26f1c89ea33e41ffc54db504c39661ed3484883a /devel/crossgo32
parent2b2af36e2d76b279542cd992f6a5e1c4b2a6d519 (diff)
downloadports-e71900fd0b7f1c09c97f204e25f649bf20d8384c.tar.gz
ports-e71900fd0b7f1c09c97f204e25f649bf20d8384c.zip
Notes
Diffstat (limited to 'devel/crossgo32')
-rw-r--r--devel/crossgo32/Makefile26
-rw-r--r--devel/crossgo32/files/README.FreeBSD57
-rw-r--r--devel/crossgo32/pkg-descr43
-rw-r--r--devel/crossgo32/pkg-plist164
4 files changed, 155 insertions, 135 deletions
diff --git a/devel/crossgo32/Makefile b/devel/crossgo32/Makefile
index 11fcf8114408..634c3cf608e8 100644
--- a/devel/crossgo32/Makefile
+++ b/devel/crossgo32/Makefile
@@ -1,7 +1,7 @@
-# New ports collection makefile for: crossgo32
-# Version required: 1.3
-# Date created: 6 Mar 97
-# Whom: Pedro Giffuni <giffunip@asme.org>
+# New ports collection makefile for: crossgo32
+# Version required: 1.3
+# Date created: 6 Mar 97
+# Whom: Pedro Giffuni <giffunip@asme.org>
# Date updated: Sun Jun 22 16:11:40 EST 1997
# Whom: Joel Sutton <sutton@aardvark.apana.org.au>
#
@@ -12,9 +12,11 @@ DISTNAME= crosstree-1.3
PKGNAME= crossgo32-1.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_LOCAL} \
- ftp://ftp.cygnus.com/pub/embedded/crossgcc/
+ ftp://sourceware.cygnus.com/pub/crossgcc/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} dosrel-1.0${EXTRACT_SUFX}
+MAINTAINER= ports@FreeBSD.org
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=${TARGET}
USE_GMAKE= yes
@@ -26,8 +28,8 @@ MAN1= i386-go32-ar.1 i386-go32-nm.1 i386-go32-objdump.1\
i386-go32-g++.1 i386-go32-gcc.1 cccp.1\
i386-go32-c++filt.1 configure.1 i386-go32-as.1 i386-go32-ld.1
-DOCDIR= ${PREFIX}/share/doc/crossgo32
-GO32DIR=${PREFIX}/share/crossgo32
+DOCDIR= ${PREFIX}/share/doc/crossgo32
+GO32DIR= ${PREFIX}/share/crossgo32
post-extract:
${MV} ${WRKDIR}/dosrel-1.0/ ${WRKSRC}
@@ -37,7 +39,7 @@ post-patch:
post-build:
@cd ${WRKSRC}/dosrel-1.0 ;\
- make coff2exe
+ ${MAKE} coff2exe
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/dosrel-1.0/coff2exe \
@@ -45,12 +47,12 @@ post-install:
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing documentation into ${DOCDIR}"
${MKDIR} ${DOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/FAQ-0.8 ${DOCDIR}/
- ${INSTALL_DATA} ${PKGDIR}/DESCR ${DOCDIR}/Readme.FreeBSD
+ ${INSTALL_DATA} ${WRKSRC}/FAQ-0.8 ${DOCDIR}
+ ${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${DOCDIR}
.endif
@${ECHO_MSG} "===> Installing DJGPP exe files into ${GO32DIR}"
${MKDIR} ${GO32DIR}
- ${INSTALL_DATA} ${WRKSRC}/dosrel-1.0/go32.exe ${GO32DIR}/
- ${INSTALL_DATA} ${WRKSRC}/dosrel-1.0/emu387 ${GO32DIR}/
+ ${INSTALL_DATA} ${WRKSRC}/dosrel-1.0/go32.exe ${GO32DIR}
+ ${INSTALL_DATA} ${WRKSRC}/dosrel-1.0/emu387 ${GO32DIR}
.include <bsd.port.mk>
diff --git a/devel/crossgo32/files/README.FreeBSD b/devel/crossgo32/files/README.FreeBSD
new file mode 100644
index 000000000000..cd13e636f643
--- /dev/null
+++ b/devel/crossgo32/files/README.FreeBSD
@@ -0,0 +1,57 @@
+Crossgo32 is a cross-compiler built from "gcc 2.7.2.2" which uses the
+Cygnus embedded libraries to create smaller binaries. Unfortunately
+there is no networking support at the moment. Binaries are created in
+the COFF format and a utility is provided to convert these binaries
+into DJGPPv1 exe files.
+
+The package is composed of the following utilities:
+GNU`s misc. utilities binutils-2.7
+The GNU's C Compiler gcc-2.7.2.2 + crosspatch
+Cygnus's embedded libraries newlib-1.7.1
+Cygnus's dos release utilities dosrel-1.0
+
+Compiling your code
+===================
+
+Compiling your code is just as easy (or should that be difficult?) as
+gcc. All of the go32 compiler binaries have been installed with the
+i386-go32 prefix. So, if you wanted to compile a file called "hello.c"
+then you might use something like:
+
+ i386-go32-gcc -o hello hello.c
+
+This will produce a COFF binary called "hello". You will now need to
+convert that binary into a EXE file so that it can be run on a DOS
+machine. It's as easy as typing:
+
+ i386-go32-coff2exe hello
+
+This will produce "hello.exe".
+
+To run your programs you need to have a DPMI server running and the
+go32.exe & emu387 files in your DOS path. Crossgo32 binaries will work
+with a range of DPMI servers - I have personally had success with
+Windows 95 - and there is a server available from the DJGPP web
+site. The DOS files mentioned above should be in
+/usr/local/share/crossgo32 (or similar on your system). Please check
+the DJGPP FAQ for more information on this topic.
+
+ http://www.delorie.com/djgpp/ (DPMI server, source, FAQs, etc)
+
+Related ports
+=============
+
+This cross-compiler port was originally created by Pedro Giffuni using
+the Cygnus cross-compiler FAQ and mailing list postings. You will find
+other ports in the collection which use the same distribution. The
+intention was to create a cross-compiler kit for all platforms
+emulated on FreeBSD.
+
+If you are interested in network support and DJGPP v2 exe files,
+amongst other DJGPP bits and pieces, check out the crossgo32-dgjpp2
+selection of ports.
+
+Share and enjoy,
+
+- Joel
+sutton@aardvark.apana.org.au
diff --git a/devel/crossgo32/pkg-descr b/devel/crossgo32/pkg-descr
index 299ab21110ce..80a58282ce1c 100644
--- a/devel/crossgo32/pkg-descr
+++ b/devel/crossgo32/pkg-descr
@@ -10,48 +10,9 @@ The GNU's C Compiler gcc-2.7.2.2 + crosspatch
Cygnus's embedded libraries newlib-1.7.1
Cygnus's dos release utilities dosrel-1.0
-Compiling your code
-===================
-
-Compiling your code is just as easy (or should that be difficult?) as
-gcc. All of the go32 compiler binaries have been installed with the
-i386-go32 prefix. So, if you wanted to compile a file called "hello.c"
-then you might use something like:
-
- i386-go32-gcc -o hello hello.c
-
-This will produce a COFF binary called "hello". You will now need to
-convert that binary into a EXE file so that it can be run on a DOS
-machine. It's as easy as typing:
-
- i386-go32-coff2exe hello
-
-This will produce "hello.exe".
-
-To run your programs you need to have a DPMI server running and the
-go32.exe & emu387 files in your DOS path. Crossgo32 binaries will work
-with a range of DPMI servers - I have personally had success with
-Windows 95 - and there is a server available from the DJGPP web
-site. The DOS files mentioned above should be in
-/usr/local/share/crossgo32 (or similar on your system). Please check
-the DJGPP FAQ for more information on this topic.
-
-WWW: http://www.delorie.com/djgpp/ (DPMI server, source, FAQs, etc)
-
-Related ports
-=============
-
-This cross-compiler port was originally created by Pedro Giffuni using
-the Cygnus cross-compiler FAQ and mailing list postings. You will find
-other ports in the collection which use the same distribution. The
-intention was to create a cross-compiler kit for all platforms
-emulated on FreeBSD.
-
-If you are interested in network support and DJGPP v2 exe files,
-amongst other DJGPP bits and pieces, check out the crossgo32-dgjpp2
-selection of ports.
-
Share and enjoy,
- Joel
sutton@aardvark.apana.org.au
+
+WWW: http://www.delorie.com/djgpp/
diff --git a/devel/crossgo32/pkg-plist b/devel/crossgo32/pkg-plist
index 564e65e412d8..c36c550b5d48 100644
--- a/devel/crossgo32/pkg-plist
+++ b/devel/crossgo32/pkg-plist
@@ -1,43 +1,28 @@
-bin/i386-go32-size
-bin/i386-go32-objdump
-bin/i386-go32-nm
bin/i386-go32-ar
-bin/i386-go32-strings
-bin/i386-go32-strip
-bin/i386-go32-ranlib
-bin/i386-go32-c++filt
-bin/i386-go32-objcopy
bin/i386-go32-as
+bin/i386-go32-c++
+bin/i386-go32-c++filt
+bin/i386-go32-coff2exe
+bin/i386-go32-g++
bin/i386-go32-gasp
+bin/i386-go32-gcc
bin/i386-go32-ld
-bin/i386-go32-g++
-bin/i386-go32-c++
+bin/i386-go32-nm
+bin/i386-go32-objcopy
+bin/i386-go32-objdump
+bin/i386-go32-ranlib
+bin/i386-go32-size
+bin/i386-go32-strings
+bin/i386-go32-strip
bin/protoize
bin/unprotoize
-bin/i386-go32-gcc
-bin/i386-go32-coff2exe
-i386-go32/bin/nm
-i386-go32/bin/strip
i386-go32/bin/ar
-i386-go32/bin/ranlib
i386-go32/bin/as
-i386-go32/bin/ld
i386-go32/bin/gcc
-i386-go32/lib/ldscripts/i386go32.x
-i386-go32/lib/ldscripts/i386go32.xbn
-i386-go32/lib/ldscripts/i386go32.xn
-i386-go32/lib/ldscripts/i386go32.xr
-i386-go32/lib/ldscripts/i386go32.xu
-i386-go32/lib/libg.a
-i386-go32/lib/libc.a
-i386-go32/lib/libiberty.a
-i386-go32/lib/libm.a
-i386-go32/lib/crt0.o
-i386-go32/include/machine/fastmath.h
-i386-go32/include/machine/ieeefp.h
-i386-go32/include/machine/setjmp-dj.h
-i386-go32/include/machine/setjmp.h
-i386-go32/include/machine/types.h
+i386-go32/bin/ld
+i386-go32/bin/nm
+i386-go32/bin/ranlib
+i386-go32/bin/strip
i386-go32/include/_ansi.h
i386-go32/include/_syslist.h
i386-go32/include/ar.h
@@ -50,6 +35,11 @@ i386-go32/include/fcntl.h
i386-go32/include/grp.h
i386-go32/include/ieeefp.h
i386-go32/include/locale.h
+i386-go32/include/machine/fastmath.h
+i386-go32/include/machine/ieeefp.h
+i386-go32/include/machine/setjmp-dj.h
+i386-go32/include/machine/setjmp.h
+i386-go32/include/machine/types.h
i386-go32/include/math.h
i386-go32/include/paths.h
i386-go32/include/process.h
@@ -61,40 +51,50 @@ i386-go32/include/signal.h
i386-go32/include/stdio.h
i386-go32/include/stdlib.h
i386-go32/include/string.h
-i386-go32/include/termios.h
-i386-go32/include/time.h
-i386-go32/include/utime.h
-i386-go32/include/unctrl.h
-i386-go32/include/unistd.h
-i386-go32/include/utmp.h
i386-go32/include/sys/_types.h
i386-go32/include/sys/config.h
+i386-go32/include/sys/dir.h
i386-go32/include/sys/dirent.h
+i386-go32/include/sys/dos.h
+i386-go32/include/sys/dpmi.h
i386-go32/include/sys/errno.h
i386-go32/include/sys/fcntl.h
+i386-go32/include/sys/file.h
+i386-go32/include/sys/go32.h
i386-go32/include/sys/param.h
+i386-go32/include/sys/pc.h
i386-go32/include/sys/reent.h
+i386-go32/include/sys/register.h
i386-go32/include/sys/resource.h
+i386-go32/include/sys/setjmp.h
i386-go32/include/sys/signal.h
i386-go32/include/sys/stat-dj.h
i386-go32/include/sys/stat.h
+i386-go32/include/sys/stdc.h
i386-go32/include/sys/time.h
i386-go32/include/sys/times.h
i386-go32/include/sys/types.h
+i386-go32/include/sys/uio.h
i386-go32/include/sys/unistd.h
i386-go32/include/sys/wait.h
-i386-go32/include/sys/dir.h
-i386-go32/include/sys/dos.h
-i386-go32/include/sys/dpmi.h
-i386-go32/include/sys/file.h
-i386-go32/include/sys/go32.h
-i386-go32/include/sys/pc.h
-i386-go32/include/sys/register.h
-i386-go32/include/sys/setjmp.h
-i386-go32/include/sys/stdc.h
-i386-go32/include/sys/uio.h
-include/bfd.h
+i386-go32/include/termios.h
+i386-go32/include/time.h
+i386-go32/include/unctrl.h
+i386-go32/include/unistd.h
+i386-go32/include/utime.h
+i386-go32/include/utmp.h
+i386-go32/lib/crt0.o
+i386-go32/lib/ldscripts/i386go32.x
+i386-go32/lib/ldscripts/i386go32.xbn
+i386-go32/lib/ldscripts/i386go32.xn
+i386-go32/lib/ldscripts/i386go32.xr
+i386-go32/lib/ldscripts/i386go32.xu
+i386-go32/lib/libc.a
+i386-go32/lib/libg.a
+i386-go32/lib/libiberty.a
+i386-go32/lib/libm.a
include/ansidecl.h
+include/bfd.h
include/bfdlink.h
include/obstack.h
@unexec install-info --delete %D/info/cpp.info %D/info/dir
@@ -131,62 +131,62 @@ info/gcc.info-8
info/gcc.info-9
@exec install-info %D/info/cpp.info %D/info/dir
@exec install-info %D/info/gcc.info %D/info/dir
-lib/libiberty.a
-lib/libi386-go32-bfd.a
-lib/gcc-lib/i386-go32/2.7.2.2/include/syslimits.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/objc/hash.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/objc/list.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/objc/sarray.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/objc/objc.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/objc/objc-api.h
+lib/gcc-lib/i386-go32/2.7.2.2/SYSCALLS.c.X
+lib/gcc-lib/i386-go32/2.7.2.2/cc1
+lib/gcc-lib/i386-go32/2.7.2.2/cc1obj
+lib/gcc-lib/i386-go32/2.7.2.2/cc1plus
+lib/gcc-lib/i386-go32/2.7.2.2/cpp
+lib/gcc-lib/i386-go32/2.7.2.2/include/README
+lib/gcc-lib/i386-go32/2.7.2.2/include/float.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/iso646.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/limits.h
lib/gcc-lib/i386-go32/2.7.2.2/include/objc/NXConstStr.h
lib/gcc-lib/i386-go32/2.7.2.2/include/objc/Object.h
lib/gcc-lib/i386-go32/2.7.2.2/include/objc/Protocol.h
lib/gcc-lib/i386-go32/2.7.2.2/include/objc/encoding.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/objc/hash.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/objc/list.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/objc/objc-api.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/objc/objc.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/objc/sarray.h
lib/gcc-lib/i386-go32/2.7.2.2/include/objc/typedstream.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/proto.h
lib/gcc-lib/i386-go32/2.7.2.2/include/stdarg.h
lib/gcc-lib/i386-go32/2.7.2.2/include/stddef.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/varargs.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/syslimits.h
lib/gcc-lib/i386-go32/2.7.2.2/include/va-alpha.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/va-clipper.h
lib/gcc-lib/i386-go32/2.7.2.2/include/va-h8300.h
lib/gcc-lib/i386-go32/2.7.2.2/include/va-i860.h
lib/gcc-lib/i386-go32/2.7.2.2/include/va-i960.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/va-mips.h
lib/gcc-lib/i386-go32/2.7.2.2/include/va-m88k.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/va-mips.h
lib/gcc-lib/i386-go32/2.7.2.2/include/va-pa.h
+lib/gcc-lib/i386-go32/2.7.2.2/include/va-ppc.h
lib/gcc-lib/i386-go32/2.7.2.2/include/va-pyr.h
lib/gcc-lib/i386-go32/2.7.2.2/include/va-sparc.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/va-clipper.h
lib/gcc-lib/i386-go32/2.7.2.2/include/va-spur.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/iso646.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/va-ppc.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/proto.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/limits.h
-lib/gcc-lib/i386-go32/2.7.2.2/include/README
-lib/gcc-lib/i386-go32/2.7.2.2/include/float.h
-lib/gcc-lib/i386-go32/2.7.2.2/cc1
-lib/gcc-lib/i386-go32/2.7.2.2/cc1obj
-lib/gcc-lib/i386-go32/2.7.2.2/cc1plus
-lib/gcc-lib/i386-go32/2.7.2.2/specs
-lib/gcc-lib/i386-go32/2.7.2.2/SYSCALLS.c.X
-lib/gcc-lib/i386-go32/2.7.2.2/cpp
+lib/gcc-lib/i386-go32/2.7.2.2/include/varargs.h
lib/gcc-lib/i386-go32/2.7.2.2/libgcc.a
+lib/gcc-lib/i386-go32/2.7.2.2/specs
+lib/libi386-go32-bfd.a
lib/libi386-go32-opcodes.a
-share/doc/crossgo32/FAQ-0.8
-share/doc/crossgo32/Readme.FreeBSD
-share/crossgo32/go32.exe
+lib/libiberty.a
share/crossgo32/emu387
+share/crossgo32/go32.exe
+share/doc/crossgo32/FAQ-0.8
+share/doc/crossgo32/README.FreeBSD
+@dirrm share/doc/crossgo32
+@dirrm share/crossgo32
+@dirrm lib/gcc-lib/i386-go32/2.7.2.2/include/objc
+@dirrm lib/gcc-lib/i386-go32/2.7.2.2/include
+@dirrm lib/gcc-lib/i386-go32/2.7.2.2
+@dirrm lib/gcc-lib/i386-go32
+@dirrm lib/gcc-lib
@dirrm i386-go32/lib/ldscripts
@dirrm i386-go32/lib
@dirrm i386-go32/include/sys
@dirrm i386-go32/include/machine
@dirrm i386-go32/include
@dirrm i386-go32/bin
-@dirrm i386-go32/
-@dirrm lib/gcc-lib/i386-go32/2.7.2.2/include/objc
-@dirrm lib/gcc-lib/i386-go32/2.7.2.2/include
-@dirrm lib/gcc-lib/i386-go32/2.7.2.2
-@dirrm lib/gcc-lib/i386-go32
-@dirrm lib/gcc-lib/
-@dirrm share/doc/crossgo32
-@dirrm share/crossgo32
+@dirrm i386-go32