aboutsummaryrefslogtreecommitdiff
path: root/devel/cscope
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2008-03-13 09:31:15 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2008-03-13 09:31:15 +0000
commitd13d6b6d3e38ba707568b5d2b192b253cb23825f (patch)
treef5042a206875ea7eb63cc2c32f70cc9205dba3f7 /devel/cscope
parentf90d2a6bf9d21ef6348ce6042c72d11580ff14ba (diff)
Notes
Diffstat (limited to 'devel/cscope')
-rw-r--r--devel/cscope/Makefile4
-rw-r--r--devel/cscope/files/patch-main.c16
-rw-r--r--devel/cscope/pkg-plist2
3 files changed, 15 insertions, 7 deletions
diff --git a/devel/cscope/Makefile b/devel/cscope/Makefile
index d7d9e37aa0ee..112b79a6182b 100644
--- a/devel/cscope/Makefile
+++ b/devel/cscope/Makefile
@@ -8,7 +8,7 @@
PORTNAME= cscope
PORTVERSION= 15.6
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,6 +19,8 @@ COMMENT= An interactive C program browser
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-yacc
+PLIST_FILES= bin/cscope \
+ bin/ocs
MAN1= cscope.1
.include <bsd.port.mk>
diff --git a/devel/cscope/files/patch-main.c b/devel/cscope/files/patch-main.c
index 96863c2328cd..eecf7051be68 100644
--- a/devel/cscope/files/patch-main.c
+++ b/devel/cscope/files/patch-main.c
@@ -1,6 +1,6 @@
---- src/main.c.orig Sat Sep 30 01:13:00 2006
-+++ src/main.c Thu Oct 5 15:21:30 2006
-@@ -359,7 +359,7 @@ cscope: TMPDIR to a valid directory\n");
+--- src/main.c.orig 2006-09-30 03:13:00.000000000 -0500
++++ src/main.c 2008-01-18 15:01:59.000000000 -0600
+@@ -359,7 +359,7 @@
/* create the temporary file names */
orig_umask = umask(S_IRWXG|S_IRWXO);
pid = getpid();
@@ -9,7 +9,7 @@
if(mkdir(tempdirpv,S_IRWXU)) {
fprintf(stderr, "\
cscope: Could not create private temp dir %s\n",
-@@ -368,8 +368,13 @@ cscope: Could not create private temp di
+@@ -368,8 +368,13 @@
}
umask(orig_umask);
@@ -25,3 +25,11 @@
/* if running in the foreground */
if (signal(SIGINT, SIG_IGN) != SIG_IGN) {
+@@ -379,6 +384,7 @@
+ }
+ /* cleanup on the hangup signal */
+ signal(SIGHUP, myexit);
++ signal(SIGTERM, myexit);
+
+ /* if the database path is relative and it can't be created */
+ if (reffile[0] != '/' && access(".", WRITE) != 0) {
diff --git a/devel/cscope/pkg-plist b/devel/cscope/pkg-plist
deleted file mode 100644
index 227d970b8c77..000000000000
--- a/devel/cscope/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/cscope
-bin/ocs