aboutsummaryrefslogtreecommitdiff
path: root/devel/cut/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-20 16:16:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-20 16:16:03 +0000
commit6008ca470e0fbc39084c46faa356fb3d62f2453b (patch)
tree5770b5aa64638942a710b03fb6806bd3b857fd09 /devel/cut/Makefile
parentc79c8e11161fda653748fa73badd31cf4e8e34dc (diff)
Notes
Diffstat (limited to 'devel/cut/Makefile')
-rw-r--r--devel/cut/Makefile39
1 files changed, 14 insertions, 25 deletions
diff --git a/devel/cut/Makefile b/devel/cut/Makefile
index 98bff9ea0fce..87d5f7fd8a15 100644
--- a/devel/cut/Makefile
+++ b/devel/cut/Makefile
@@ -6,38 +6,27 @@
#
PORTNAME= cut
-PORTVERSION= 2.4
+PORTVERSION= 2.6
CATEGORIES= devel
-MASTER_SITES= http://www.falvotech.com/content/cut/2.4/downloads/
+MASTER_SITES= http://www.falvotech.com/content/cut/${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Unit Testing Framework for C, C++ and Objective-C
-EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${PORTVERSION}
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+USE_PYTHON_RUN= yes
+ALL_TARGET= build
-WRKSRC= ${WRKDIR}/repo
-
-# related to build target
-ALL_TARGET= bin/cutgen
-
-# cut interface is compatible at major version number
-major= 2
+post-patch:
+.for FILE in common.py cutgen.py options.py parser.py
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|${PREFIX}/bin/python|' \
+ ${WRKSRC}/${FILE}
+.endfor
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/cutgen ${PREFIX}/bin/cutgen-${major}
- ${CP} -R ${WRKSRC}/include/* ${PREFIX}/include/
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/tutorial
- ${CP} ${WRKSRC}/LICENSE ${WRKSRC}/docs/README ${WRKSRC}/CHANGELOG ${DOCSDIR}/
- ${CP} -R ${WRKSRC}/docs/tutorials/sergei_gnezdov/*.c\
- ${WRKSRC}/docs/tutorials/sergei_gnezdov/*.h\
- ${WRKSRC}/docs/tutorials/sergei_gnezdov/*.dvi\
- ${WRKSRC}/docs/tutorials/sergei_gnezdov/*.pdf\
- ${WRKSRC}/docs/tutorials/sergei_gnezdov/*.ps\
- ${DOCSDIR}/tutorial/
- ${MKDIR} ${EXAMPLESDIR}/
- ${CP} -R ${WRKSRC}/test/* ${EXAMPLESDIR}/
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/build/bin/cutgen ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/build/bin/cutgen.py ${PREFIX}/bin
+.for FILE in common.py lexer.py options.py parser.py
+ ${INSTALL_SCRIPT} ${WRKSRC}/build/bin/${FILE} ${PREFIX}/bin/cutgen_${FILE}
+.endfor
.include <bsd.port.mk>