aboutsummaryrefslogtreecommitdiff
path: root/devel/cvs2cl/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-08-19 11:00:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-08-19 11:00:25 +0000
commite7101cc37845863cee9750e002525e0f376cf696 (patch)
tree9b06eeda12927a3781e8ae2a7eee7f9f21863726 /devel/cvs2cl/Makefile
parentcb8c95ff59d272b6ae29c4b0ecb240b26fee9514 (diff)
downloadports-e7101cc37845863cee9750e002525e0f376cf696.tar.gz
ports-e7101cc37845863cee9750e002525e0f376cf696.zip
Notes
Diffstat (limited to 'devel/cvs2cl/Makefile')
-rw-r--r--devel/cvs2cl/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/cvs2cl/Makefile b/devel/cvs2cl/Makefile
index 964faf8a4f8e..95ccdfbd8d92 100644
--- a/devel/cvs2cl/Makefile
+++ b/devel/cvs2cl/Makefile
@@ -8,9 +8,11 @@
PORTNAME= cvs2cl
PORTVERSION= 2.67
CATEGORIES= devel
-MASTER_SITES= http://www.red-bean.com/cvs2cl/
+MASTER_SITES= http://www.red-bean.com/cvs2cl/ \
+ http://www.sysfault.org/freebsd/${DIST_SUBDIR}/
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .pl
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
EXTRACT_ONLY= # none
MAINTAINER= mva@sysfault.org
@@ -29,8 +31,11 @@ do-extract:
@${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} ${WRKSRC}/${PORTNAME}
post-patch:
- @${REINPLACE_CMD} -e "s|exec ${PERL} -w -x|exec ${PERL} -w -x|" \
- -e "s|#!${PERL} -w|#!${PERL} -w|" ${WRKSRC}/${PORTNAME}
+ @${REINPLACE_CMD} -e "s|exec perl -w -x|exec ${PERL} -w -x|" \
+ -e "s|#!perl -w|#!${PERL} -w|" ${WRKSRC}/${PORTNAME}
+ @${REINPLACE_CMD} -e \
+ "s|=item, B<--group-within-date>|=item B<--group-within-date>|" \
+ ${WRKSRC}/${PORTNAME}
do-install:
@pod2man ${WRKSRC}/${PORTNAME} > ${WRKSRC}/${PORTNAME}.1