aboutsummaryrefslogtreecommitdiff
path: root/devel/cvs2darcs
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2007-03-01 20:07:05 +0000
committerOliver Braun <obraun@FreeBSD.org>2007-03-01 20:07:05 +0000
commit7a77d626fe16e165ef3e68b097ca1722d64292fd (patch)
tree8b00519861cd79bbf90e2ec1b20fb2fcb88a4fb0 /devel/cvs2darcs
parentd8737589d750594507020678495ee4c6bde98399 (diff)
downloadports-7a77d626fe16e165ef3e68b097ca1722d64292fd.tar.gz
ports-7a77d626fe16e165ef3e68b097ca1722d64292fd.zip
Notes
Diffstat (limited to 'devel/cvs2darcs')
-rw-r--r--devel/cvs2darcs/Makefile29
-rw-r--r--devel/cvs2darcs/distinfo3
-rw-r--r--devel/cvs2darcs/pkg-descr4
3 files changed, 36 insertions, 0 deletions
diff --git a/devel/cvs2darcs/Makefile b/devel/cvs2darcs/Makefile
new file mode 100644
index 000000000000..bbc78ac20bd1
--- /dev/null
+++ b/devel/cvs2darcs/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: cvs2darcs
+# Date created: 1 March 2007
+# Whom: Oliver Braun <obraun@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvs2darcs
+PORTVERSION= 0.7.1
+CATEGORIES= devel
+MASTER_SITES= http://ab-initio.mit.edu/${PORTNAME}/
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Convert cvs module to darcs repository
+
+BUILD_DEPENDS= darcs:${PORTSDIR}/devel/darcs \
+ cvsps:${PORTSDIR}/devel/cvsps \
+ ${SITE_PERL}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_PERL5= yes
+NO_BUILD= yes
+MAN1= cvs2darcs.1
+PLIST_FILES= bin/cvs2darcs share/cvs2darcs/cvs_convert.pl \
+ share/cvs2darcs/branch_detect.pl
+PLIST_DIRS= share/cvs2darcs
+
+.include <bsd.port.mk>
diff --git a/devel/cvs2darcs/distinfo b/devel/cvs2darcs/distinfo
new file mode 100644
index 000000000000..61bd12412631
--- /dev/null
+++ b/devel/cvs2darcs/distinfo
@@ -0,0 +1,3 @@
+MD5 (cvs2darcs-0.7.1.tar.gz) = 71a03498c5f9a8478d1e57d87a018132
+SHA256 (cvs2darcs-0.7.1.tar.gz) = 5c89f3e4e7d415d2e79642a11477866aa70403d7d9aea202f08a704616264d43
+SIZE (cvs2darcs-0.7.1.tar.gz) = 61420
diff --git a/devel/cvs2darcs/pkg-descr b/devel/cvs2darcs/pkg-descr
new file mode 100644
index 000000000000..4a3eddc50532
--- /dev/null
+++ b/devel/cvs2darcs/pkg-descr
@@ -0,0 +1,4 @@
+cvs2darcs is a script to check out a CVS repository module and convert it to
+use the Darcs version control system.
+
+WWW: http://ab-initio.mit.edu/cvs2darcs/