aboutsummaryrefslogtreecommitdiff
path: root/devel/cvs2html
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-12-29 14:50:31 +0000
committerChris Rees <crees@FreeBSD.org>2013-12-29 14:50:31 +0000
commit50ef26bc899f6e2609a163028c5983ffe356bfd6 (patch)
treecec4a5c2ac8fb6e3e87cbc537549aefc29e453b1 /devel/cvs2html
parent7675051328c20eff50ad7669ad27d7cbb524dff0 (diff)
Notes
Diffstat (limited to 'devel/cvs2html')
-rw-r--r--devel/cvs2html/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/devel/cvs2html/Makefile b/devel/cvs2html/Makefile
index 18d314d2b51b..f99863e13b15 100644
--- a/devel/cvs2html/Makefile
+++ b/devel/cvs2html/Makefile
@@ -16,19 +16,19 @@ COMMENT= Perl script to turn ``cvs log'' output into HTML
LICENSE= GPLv2
+RUN_DEPENDS= cvs:${PORTSDIR}/devel/cvs
+
PLIST_FILES= bin/cvs2html
-USES= perl5
+NO_WRKSUBDIR= yes
NO_BUILD= yes
+USES= perl5 shebangfix
+SHEBANG_FILES= ${PORTNAME}
-NO_STAGE= yes
do-extract:
- @${MKDIR} ${WRKDIR}
- @${CP} ${DISTDIR}/${PORTNAME} ${WRKDIR}
-
-post-patch:
- ${REINPLACE_CMD} -e '1s|\(#!\).*$$|\1${PERL}|' ${WRKDIR}/${PORTNAME}
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${PORTNAME} ${WRKSRC}
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>