aboutsummaryrefslogtreecommitdiff
path: root/devel/cvs2svn
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-07-31 16:17:51 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-07-31 16:17:51 +0000
commit8aa14b34f7e761e89126d8e25614c24dd6d7cf83 (patch)
treec3c216886b602660624f645c49ee6b4ae9297ea7 /devel/cvs2svn
parent18f529ff22e63e5d643feb95b68f5facff2fbd8e (diff)
downloadports-8aa14b34f7e761e89126d8e25614c24dd6d7cf83.tar.gz
ports-8aa14b34f7e761e89126d8e25614c24dd6d7cf83.zip
Notes
Diffstat (limited to 'devel/cvs2svn')
-rw-r--r--devel/cvs2svn/Makefile25
1 files changed, 20 insertions, 5 deletions
diff --git a/devel/cvs2svn/Makefile b/devel/cvs2svn/Makefile
index ac0b16fc4045..f164dc9f410a 100644
--- a/devel/cvs2svn/Makefile
+++ b/devel/cvs2svn/Makefile
@@ -6,7 +6,7 @@
PORTNAME= cvs2svn
PORTVERSION= 2.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://cvs2svn.tigris.org/files/documents/1462/42521/
@@ -14,13 +14,28 @@ MAINTAINER= pgollucci@FreeBSD.org
COMMENT= CVS to Subversion Repository Converter
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/gdbm.so:${PORTSDIR}/databases/py-gdbm
-RUN_DEPENDS= ${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion \
- ${LOCALBASE}/bin/git:${PORTSDIR}/devel/git \
- ${PYTHON_SITELIBDIR}/gdbm.so:${PORTSDIR}/databases/py-gdbm
+RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
+OPTIONS= SUBVERSION "Build with subversion support" on \
+ GIT "Build with git support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_SUBVERSION) && defined(WITHOUT_GIT)
+IGNORE= choose at least subversion, git or both
+.endif
+
+.if defined(WITH_SUBVERSION)
+RUN_DEPENDS+= ${LOCALBASE}/bin/svn:${PORTSDIR}/devel/py-subversion
+.endif
+
+.if defined(WITH_GIT)
+RUN_DEPENDS+= ${LOCALBASE}/bin/git:${PORTSDIR}/devel/git
+.endif
+
MAN1= cvs2svn.1
# The only thing different in this target vs. the one found in bsd.port.mk
@@ -39,4 +54,4 @@ do-extract:
post-install:
${INSTALL_MAN} ${WRKSRC}/cvs2svn.1 ${PREFIX}/man/man1/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>