aboutsummaryrefslogtreecommitdiff
path: root/devel/cvschangelogbuilder
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-21 10:17:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-21 10:17:09 +0000
commitff5d0c3106152f95c61c89e4f7c3d0c904cf5682 (patch)
tree21b3d659ba21937f650be25bf98e1c99b2fb72b9 /devel/cvschangelogbuilder
parent987b42ecd9d82bd468f310fcd0806b681803072f (diff)
downloadports-ff5d0c3106152f95c61c89e4f7c3d0c904cf5682.tar.gz
ports-ff5d0c3106152f95c61c89e4f7c3d0c904cf5682.zip
Notes
Diffstat (limited to 'devel/cvschangelogbuilder')
-rw-r--r--devel/cvschangelogbuilder/Makefile38
-rw-r--r--devel/cvschangelogbuilder/distinfo3
-rw-r--r--devel/cvschangelogbuilder/pkg-descr10
3 files changed, 51 insertions, 0 deletions
diff --git a/devel/cvschangelogbuilder/Makefile b/devel/cvschangelogbuilder/Makefile
new file mode 100644
index 000000000000..45077542c956
--- /dev/null
+++ b/devel/cvschangelogbuilder/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: cvschangelogbuilder
+# Date created: Sun Mar 5 16:43:25 EST 2006
+# Whom: Matthew Will <mwill@spingen.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvschangelogbuilder
+PORTVERSION= 2.2
+CATEGORIES= devel
+MASTER_SITES= http://cvschangelogb.sourceforge.net/files/ \
+ http://mirror.spingen.com/cvschangelogbuilder/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= mwill@spingen.com
+COMMENT= Utility to generate changelogs and reports from a CVS repository
+
+RUN_DEPENDS= ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+PLIST_FILES= bin/cvschangelogbuilder
+PORTDOCS= *
+
+post-patch:
+ ${REINPLACE_CMD} -e '1s|/usr/bin/perl|${PERL}|' ${WRKSRC}/${PORTNAME}.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/images
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.* ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/images/* ${DOCSDIR}/images
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cvschangelogbuilder/distinfo b/devel/cvschangelogbuilder/distinfo
new file mode 100644
index 000000000000..0c8c2f75c300
--- /dev/null
+++ b/devel/cvschangelogbuilder/distinfo
@@ -0,0 +1,3 @@
+MD5 (cvschangelogbuilder-2.2.tar.gz) = edceda7beee3a22039e8792d58053783
+SHA256 (cvschangelogbuilder-2.2.tar.gz) = 3852be57e0a8934c18a5886e48860ead8da627241706f344b816aea08e6cb637
+SIZE (cvschangelogbuilder-2.2.tar.gz) = 31825
diff --git a/devel/cvschangelogbuilder/pkg-descr b/devel/cvschangelogbuilder/pkg-descr
new file mode 100644
index 000000000000..632bbfdfd56c
--- /dev/null
+++ b/devel/cvschangelogbuilder/pkg-descr
@@ -0,0 +1,10 @@
+cvschangelogbuilder is an Perl utility to generate ChangeLogs or CVS reports
+for a project hosted on a CVS server.
+
+Features include the ability to work with a remote cvs repository, detailed
+reporting, graphical HTML reports and building changelogs.
+
+WWW: http://cvschangelogb.sourceforge.net/
+Author: Laurent Destailleur
+
+- Matthew Will <mwill@spingen.com>