aboutsummaryrefslogtreecommitdiff
path: root/devel/cvschk/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-04-23 12:00:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-04-23 12:00:14 +0000
commit6c92aef956a2232ae6c7c0a0cf06b9cc64f74265 (patch)
tree7ee2f5aa4237c50bae9f11e5692b844140eed7ad /devel/cvschk/Makefile
parent6af650b4c26b02e29942b26d4372e51184932f89 (diff)
downloadports-6c92aef956a2232ae6c7c0a0cf06b9cc64f74265.tar.gz
ports-6c92aef956a2232ae6c7c0a0cf06b9cc64f74265.zip
Notes
Diffstat (limited to 'devel/cvschk/Makefile')
-rw-r--r--devel/cvschk/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/cvschk/Makefile b/devel/cvschk/Makefile
new file mode 100644
index 000000000000..4f7a1848d1c6
--- /dev/null
+++ b/devel/cvschk/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: cvschk
+# Date created: 2005-04-23
+# Whom: Matthias Andree <matthias.andree@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvschk
+PORTVERSION= 1.12
+CATEGORIES= devel
+MASTER_SITES= http://cvs.sslug.dk/cvs2html/utils/
+DISTNAME= cvschk
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= matthias.andree@gmx.de
+COMMENT= Quick offline checker for CVS modifications
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+MAN1= cvschk.1
+
+do-configure:
+ ${SED} -e "s,^#!/usr/bin/perl -w,#! ${PERL} -w," \
+ <${DISTDIR}/${DISTNAME} >${WRKSRC}/${DISTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/cvschk.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>