aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsnt
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2005-04-19 19:03:52 +0000
committerMax Khon <fjoe@FreeBSD.org>2005-04-19 19:03:52 +0000
commitb44f841ace6226d6f0ebeef30fb2f7c6a9353d6e (patch)
treedcc7b905517706bf614afcf1c235795437e4d195 /devel/cvsnt
parent90df81c3555b1dffabddd0980bb9149d8a15d800 (diff)
downloadports-b44f841ace6226d6f0ebeef30fb2f7c6a9353d6e.tar.gz
ports-b44f841ace6226d6f0ebeef30fb2f7c6a9353d6e.zip
Notes
Diffstat (limited to 'devel/cvsnt')
-rw-r--r--devel/cvsnt/Makefile20
-rw-r--r--devel/cvsnt/distinfo4
-rw-r--r--devel/cvsnt/files/cvslockd.sh.in (renamed from devel/cvsnt/files/cvslockd.sh)2
-rw-r--r--devel/cvsnt/files/patch-lockservice-LockParse.cpp12
-rw-r--r--devel/cvsnt/files/patch-protocols-gserver.c6
-rw-r--r--devel/cvsnt/files/patch-src-cvs.h27
-rw-r--r--devel/cvsnt/files/patch-xmlapi-xmlapi.cpp32
-rw-r--r--devel/cvsnt/pkg-plist12
8 files changed, 18 insertions, 97 deletions
diff --git a/devel/cvsnt/Makefile b/devel/cvsnt/Makefile
index f2b4429be9fc..3fc71ddfb094 100644
--- a/devel/cvsnt/Makefile
+++ b/devel/cvsnt/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cvsnt
-PORTVERSION= 2.0.58d
-PORTREVISION= 4
+PORTVERSION= 2.5.01.1927
CATEGORIES= devel
MASTER_SITES= http://www.cvsnt.org/archive/
@@ -18,13 +17,13 @@ CONFLICTS= cvs-1*
USE_LIBLTDL= yes
USE_INC_LIBTOOL_VER= 13
-USE_RC_SUBR= yes
+USE_RC_SUBR= cvslockd.sh
CONFIGURE_ARGS= --enable-fork
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GETOPT_LONG=yes
USE_ICONV= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
@@ -37,16 +36,5 @@ PLIST_SUB= GSERVER=""
PLIST_SUB= GSERVER="@comment "
CONFIGURE_ARGS+=--disable-gserver
.endif
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
-
-STARTUPDIR= etc/rc.d
-STARTUPFILES= cvslockd.sh
-
-post-install:
-.for file in ${STARTUPFILES}
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/${file} > ${WRKDIR}/${file}
- ${INSTALL_SCRIPT} ${WRKDIR}/${file} ${PREFIX}/${STARTUPDIR}/${file}
-.endfor
.include <bsd.port.mk>
diff --git a/devel/cvsnt/distinfo b/devel/cvsnt/distinfo
index ae05111f2802..b3f0363acd97 100644
--- a/devel/cvsnt/distinfo
+++ b/devel/cvsnt/distinfo
@@ -1,2 +1,2 @@
-MD5 (cvsnt-2.0.58d.tar.gz) = c17a07a127a808187fcd8c8369128367
-SIZE (cvsnt-2.0.58d.tar.gz) = 4951176
+MD5 (cvsnt-2.5.01.1927.tar.gz) = daa028983a4d5aa71b95ff2d506b017c
+SIZE (cvsnt-2.5.01.1927.tar.gz) = 5247997
diff --git a/devel/cvsnt/files/cvslockd.sh b/devel/cvsnt/files/cvslockd.sh.in
index 9364402ca382..66784c35dc7d 100644
--- a/devel/cvsnt/files/cvslockd.sh
+++ b/devel/cvsnt/files/cvslockd.sh.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/devel/cvsnt/files/Attic/cvslockd.sh.in,v 1.1 2005-04-19 19:03:52 fjoe Exp $
#
# PROVIDE: cvslockd
# REQUIRE: LOGIN
diff --git a/devel/cvsnt/files/patch-lockservice-LockParse.cpp b/devel/cvsnt/files/patch-lockservice-LockParse.cpp
deleted file mode 100644
index f24f80f0a862..000000000000
--- a/devel/cvsnt/files/patch-lockservice-LockParse.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- lockservice/LockParse.cpp.orig Sun Feb 20 17:42:22 2005
-+++ lockservice/LockParse.cpp Sun Feb 20 17:42:40 2005
-@@ -155,7 +155,8 @@
- #ifdef _WIN32
- this_clock = GetTickCount();
- #else
-- this_clock = times(NULL);
-+ struct tms tms_buf;
-+ this_clock = times(&tms_buf);
- #endif
-
- if(this_clock<last_clock.clock)
diff --git a/devel/cvsnt/files/patch-protocols-gserver.c b/devel/cvsnt/files/patch-protocols-gserver.c
index 65aed3d7d2ca..791637ccd094 100644
--- a/devel/cvsnt/files/patch-protocols-gserver.c
+++ b/devel/cvsnt/files/patch-protocols-gserver.c
@@ -1,5 +1,5 @@
---- protocols/gserver.c.orig Sun Feb 20 16:35:47 2005
-+++ protocols/gserver.c Sun Feb 20 16:35:55 2005
+--- protocols/gserver.c.orig Fri Mar 18 20:56:35 2005
++++ protocols/gserver.c Wed Apr 20 01:49:15 2005
@@ -43,12 +43,13 @@
#ifdef HAVE_GSSAPI_H
@@ -8,7 +8,7 @@
+#else
#ifdef HAVE_GSSAPI_GSSAPI_H
#include <gssapi/gssapi.h>
- #endif
+ #endif /* freebsd needs 'else' but this breaks on other platforms so is incorrect for the main distribution. Fix manually if building on that platform */
#ifdef HAVE_GSSAPI_GSSAPI_GENERIC_H
#include <gssapi/gssapi_generic.h>
+#endif
diff --git a/devel/cvsnt/files/patch-src-cvs.h b/devel/cvsnt/files/patch-src-cvs.h
deleted file mode 100644
index 824fb8428435..000000000000
--- a/devel/cvsnt/files/patch-src-cvs.h
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/cvs.h.orig Tue Feb 8 21:53:19 2005
-+++ src/cvs.h Tue Feb 8 21:59:05 2005
-@@ -1159,8 +1159,14 @@
-
- namespace cvs
- {
-+#if defined(__GNUC__) && (__GNUC__ < 3)
-+typedef string_char_traits<char> char_traits_base;
-+#else
-+typedef std::char_traits<char> char_traits_base;
-+#endif
-+
- /* Define traits for the filenames and usernames in c++ */
-- struct filename_char_traits : public std::char_traits<char>
-+ struct filename_char_traits : public char_traits_base
- {
- static bool eq( char c1, char c2 ) { return FOLD_FN_CHAR(c1) == FOLD_FN_CHAR(c2); }
- static bool ne( char c1, char c2 ) { return FOLD_FN_CHAR(c1) != FOLD_FN_CHAR(c2); }
-@@ -1169,7 +1175,7 @@
- static const char*find( const char* s, int n, char a ) { while( n-- > 0 && FOLD_FN_CHAR(*s) != FOLD_FN_CHAR(a) ) { ++s; } return s; }
- };
-
-- struct username_char_traits : public std::char_traits<char>
-+ struct username_char_traits : public char_traits_base
- {
- static bool eq( char c1, char c2 ) { return FOLD_UN_CHAR(c1) == FOLD_UN_CHAR(c2); }
- static bool ne( char c1, char c2 ) { return FOLD_UN_CHAR(c1) != FOLD_UN_CHAR(c2); }
diff --git a/devel/cvsnt/files/patch-xmlapi-xmlapi.cpp b/devel/cvsnt/files/patch-xmlapi-xmlapi.cpp
deleted file mode 100644
index 4b5280eb37a2..000000000000
--- a/devel/cvsnt/files/patch-xmlapi-xmlapi.cpp
+++ /dev/null
@@ -1,32 +0,0 @@
---- xmlapi/xmlapi.cpp.orig Tue Feb 8 21:27:08 2005
-+++ xmlapi/xmlapi.cpp Tue Feb 8 21:26:30 2005
-@@ -41,7 +41,7 @@
- else n->value="";
- n->Parent=this;
- if(n->XmlType==XmlTypeNode)
-- n->Parent->value.clear(); /* We don't support mixing trees and labels... this also papers over a small quirk in the loading routine */
-+ n->Parent->value.erase(); /* We don't support mixing trees and labels... this also papers over a small quirk in the loading routine */
- return n;
- }
-
-@@ -365,7 +365,7 @@
-
- bool XmlNode::BatchDelete()
- {
-- name.clear(); /* Having no name marks the tag for deletion */
-+ name.erase(); /* Having no name marks the tag for deletion */
- return true;
- }
-
-@@ -374,6 +374,11 @@
- static bool operator==(std::pair<const std::string,XmlNode>& a,XmlNode *b)
- {
- return &a.second == b;
-+}
-+
-+static bool operator!=(std::pair<const std::string,XmlNode>& a,XmlNode *b)
-+{
-+ return &a.second != b;
- }
-
- XmlNode::ChildArray_t::iterator XmlNode::FindIterator(XmlNode *node)
diff --git a/devel/cvsnt/pkg-plist b/devel/cvsnt/pkg-plist
index bc03bdaa488a..ba92a952e532 100644
--- a/devel/cvsnt/pkg-plist
+++ b/devel/cvsnt/pkg-plist
@@ -1,14 +1,15 @@
-bin/co
bin/cvs
bin/cvslockd
+bin/cvsnt
bin/rcs2log
-bin/rcsdiff
-bin/rlog
etc/cvsnt/PServer.example
etc/cvsnt/ca.pem
-etc/rc.d/cvslockd.sh
+lib/cvsnt/default_trigger.la
+lib/cvsnt/default_trigger.so
lib/cvsnt/ext_protocol.la
lib/cvsnt/ext_protocol.so
+lib/cvsnt/ext_xdiff.la
+lib/cvsnt/ext_xdiff.so
lib/cvsnt/fork_protocol.la
lib/cvsnt/fork_protocol.so
%%GSERVER%%lib/cvsnt/gserver_protocol.la
@@ -21,6 +22,9 @@ lib/cvsnt/sserver_protocol.la
lib/cvsnt/sserver_protocol.so
lib/cvsnt/sspi_protocol.la
lib/cvsnt/sspi_protocol.so
+lib/libcvsapi-2.5.01.1927.so
+lib/libcvsapi.la
+lib/libcvsapi.so
share/cvsnt/contrib/README
share/cvsnt/contrib/clmerge
share/cvsnt/contrib/cln_hist