aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsplot
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-31 16:15:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-31 16:15:02 +0000
commit21b1afdb2b378839987a35436f50928bf57690c1 (patch)
treeb835635531c152b5e5acd62b30bcfa1d233b0718 /devel/cvsplot
parent8654f8ae5f31d9e07f8fdec6d0a40562ee9b1b2c (diff)
downloadports-21b1afdb2b378839987a35436f50928bf57690c1.tar.gz
ports-21b1afdb2b378839987a35436f50928bf57690c1.zip
Notes
Diffstat (limited to 'devel/cvsplot')
-rw-r--r--devel/cvsplot/Makefile28
-rw-r--r--devel/cvsplot/distinfo1
-rw-r--r--devel/cvsplot/pkg-comment1
-rw-r--r--devel/cvsplot/pkg-descr5
-rw-r--r--devel/cvsplot/pkg-plist1
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/cvsplot/Makefile b/devel/cvsplot/Makefile
new file mode 100644
index 000000000000..a448120bf54c
--- /dev/null
+++ b/devel/cvsplot/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: cvsplot
+# Date created: May 31, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvsplot
+PORTVERSION= 1.6.1
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ gnuplot:${PORTSDIR}/math/gnuplot
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s,^#!/usr/bin/perl -w,#!/usr/bin/env perl -w,g" ${WRKSRC}/cvsplot.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cvsplot.pl ${PREFIX}/bin/cvsplot
+
+.include <bsd.port.mk>
diff --git a/devel/cvsplot/distinfo b/devel/cvsplot/distinfo
new file mode 100644
index 000000000000..6c62881f300f
--- /dev/null
+++ b/devel/cvsplot/distinfo
@@ -0,0 +1 @@
+MD5 (cvsplot-1.6.1.tar.gz) = a95653f607f8a58900e727732b30dbd0
diff --git a/devel/cvsplot/pkg-comment b/devel/cvsplot/pkg-comment
new file mode 100644
index 000000000000..22725bcceb94
--- /dev/null
+++ b/devel/cvsplot/pkg-comment
@@ -0,0 +1 @@
+A perl script which analyses the history of a CVS-managed project
diff --git a/devel/cvsplot/pkg-descr b/devel/cvsplot/pkg-descr
new file mode 100644
index 000000000000..d3f5fa3a11cc
--- /dev/null
+++ b/devel/cvsplot/pkg-descr
@@ -0,0 +1,5 @@
+Cvsplot is used for collecting statistics from CVS controlled files. Simple
+statistics such as how the total number of files and lines of code change
+against time.
+
+WWW: http://cvsplot.sourceforge.net/
diff --git a/devel/cvsplot/pkg-plist b/devel/cvsplot/pkg-plist
new file mode 100644
index 000000000000..8db3b0685787
--- /dev/null
+++ b/devel/cvsplot/pkg-plist
@@ -0,0 +1 @@
+bin/cvsplot