aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsps
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-12 03:57:38 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-12 03:57:38 +0000
commitc6d89716288a5e0e29a9ff09b9a9d114c2b3d9db (patch)
tree4eba6dc7641564720a0c0d5a0cd31791551184df /devel/cvsps
parent62801042a01756ce3a75788856a68aea12fc04ea (diff)
downloadports-c6d89716288a5e0e29a9ff09b9a9d114c2b3d9db.tar.gz
ports-c6d89716288a5e0e29a9ff09b9a9d114c2b3d9db.zip
Notes
Diffstat (limited to 'devel/cvsps')
-rw-r--r--devel/cvsps/Makefile17
-rw-r--r--devel/cvsps/distinfo6
-rw-r--r--devel/cvsps/files/patch-cvsps.c12
3 files changed, 28 insertions, 7 deletions
diff --git a/devel/cvsps/Makefile b/devel/cvsps/Makefile
index 4dd9965ed626..6de680f29fd2 100644
--- a/devel/cvsps/Makefile
+++ b/devel/cvsps/Makefile
@@ -7,13 +7,13 @@
#
PORTNAME= cvsps
-PORTVERSION= 1.3.3
-PORTREVISION= 1
+PORTVERSION= 2.1
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= http://www.cobite.com/cvsps/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= CVS patchsets
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Create patchset information from CVS
USE_GMAKE= yes
ALL_TARGET= cvsps
@@ -21,8 +21,17 @@ ALL_TARGET= cvsps
MAN1= cvsps.1
PLIST_FILES= bin/cvsps
+.if !defined(NOPORTDOCS)
+PORTDOCS= README
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cvsps ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/cvsps.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/cvsps/distinfo b/devel/cvsps/distinfo
index 0202a12bcbe9..55e227fd5fff 100644
--- a/devel/cvsps/distinfo
+++ b/devel/cvsps/distinfo
@@ -1,3 +1,3 @@
-MD5 (cvsps-1.3.3.tar.gz) = 06996d83366794d295745092225946b7
-SHA256 (cvsps-1.3.3.tar.gz) = dea4bca02858b8aac56de2c8936fadc24b0e02ae9175ed0266f3867d9c10fb0f
-SIZE (cvsps-1.3.3.tar.gz) = 28560
+MD5 (cvsps-2.1.tar.gz) = bde2110ed9f5d14de8f8cb04e9d596fe
+SHA256 (cvsps-2.1.tar.gz) = 91d3198b33463861a581686d5fcf99a5c484e7c4d819384c04fda9cafec1075a
+SIZE (cvsps-2.1.tar.gz) = 61634
diff --git a/devel/cvsps/files/patch-cvsps.c b/devel/cvsps/files/patch-cvsps.c
new file mode 100644
index 000000000000..9f21b1379f1b
--- /dev/null
+++ b/devel/cvsps/files/patch-cvsps.c
@@ -0,0 +1,12 @@
+--- cvsps.c.orig Wed Aug 9 21:59:54 2006
++++ cvsps.c Wed Aug 9 22:00:17 2006
+@@ -2551,8 +2551,8 @@
+ for (next = ps->members.next; next != &ps->members; next = next->next)
+ {
+ PatchSetMember * psm = list_entry(next, PatchSetMember, link);
+- rev = psm->pre_rev;
+ int d1, d2;
++ rev = psm->pre_rev;
+
+ /* the reason this is at all complicated has to do with a
+ * branch off of a branch. it is possible (and indeed