aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsspam/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-19 10:47:50 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-19 10:47:50 +0000
commit2d8df958b8acb6693919b86bb2c22be4f2727e8e (patch)
tree97665034d3602a5f3c93ca1dba19470c675b69c6 /devel/cvsspam/Makefile
parent3d4cc4d1a8a1364944f41f575066e26a7d7686ef (diff)
downloadports-2d8df958b8acb6693919b86bb2c22be4f2727e8e.tar.gz
ports-2d8df958b8acb6693919b86bb2c22be4f2727e8e.zip
Notes
Diffstat (limited to 'devel/cvsspam/Makefile')
-rw-r--r--devel/cvsspam/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/devel/cvsspam/Makefile b/devel/cvsspam/Makefile
new file mode 100644
index 000000000000..8f86c30a7ac2
--- /dev/null
+++ b/devel/cvsspam/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: cvsspam
+# Date created: 16 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvsspam
+PORTVERSION= 0.2.12
+CATEGORIES= devel
+MASTER_SITES= http://www.badgers-in-foil.co.uk/projects/cvsspam/releases/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Sends diffs when a change is committed to your CVS repository
+
+USE_RUBY= yes
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+PORTDOCS= COPYING CREDITS TODO cvsspam-doc.html cvsspam-doc.pdf
+
+post-patch:
+.for f in collect_diffs.rb cvsspam.rb record_lastdir.rb
+ @${REINPLACE_CMD} -e 's|/usr/bin/ruby|${RUBY}|' \
+ ${WRKSRC}/${f}
+.endfor
+ @${REINPLACE_CMD} -E 's|/etc/cvsspam/(cvsspam\.conf)|${PREFIX}/etc/\1|' \
+ ${WRKSRC}/collect_diffs.rb
+
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
+.for f in collect_diffs.rb cvsspam.rb record_lastdir.rb
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/libexec/${PORTNAME}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/cvsspam.conf ${PREFIX}/etc/cvsspam.conf.default
+.if !exists(${PREFIX}/etc/cvsspam.conf)
+ ${INSTALL_DATA} ${WRKSRC}/cvsspam.conf ${PREFIX}/etc/cvsspam.conf
+.endif
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>