aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsstat/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-08-29 02:27:31 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-08-29 02:27:31 +0000
commit41626904a1768ac7cbf33048a24c5aab3abc4bf2 (patch)
tree13ac95b4c9ca82dcad3b0ae5686ba2f53f1bc764 /devel/cvsstat/Makefile
parentd3762340a385270c261f55db634b633e07c86f14 (diff)
downloadports-41626904a1768ac7cbf33048a24c5aab3abc4bf2.tar.gz
ports-41626904a1768ac7cbf33048a24c5aab3abc4bf2.zip
Notes
Diffstat (limited to 'devel/cvsstat/Makefile')
-rw-r--r--devel/cvsstat/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/cvsstat/Makefile b/devel/cvsstat/Makefile
new file mode 100644
index 000000000000..3521b6655a92
--- /dev/null
+++ b/devel/cvsstat/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: cvsstat
+# Date created: 27 August 2001
+# Whom: petef
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvsstat
+PORTVERSION= 2.17
+CATEGORIES= devel
+MASTER_SITES= http://cvs.sslug.dk/cvs2html/utils/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= petef@FreeBSD.org
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} -p ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+post-patch:
+ @${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/cvsstat
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cvsstat ${PREFIX}/bin
+
+.include <bsd.port.mk>