aboutsummaryrefslogtreecommitdiff
path: root/devel/cvstrac/files
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2003-06-03 05:01:12 +0000
committerWill Andrews <will@FreeBSD.org>2003-06-03 05:01:12 +0000
commiteb5d10f4aa2fc802ccc19b5c2b36a589b70ba16e (patch)
tree5aed1d02b2120e4c14e4aa0a9e056be2cf52a6bc /devel/cvstrac/files
parent8ffb4a9411f75e7646f2ab2db14ddf4a06fca1af (diff)
downloadports-eb5d10f4aa2fc802ccc19b5c2b36a589b70ba16e.tar.gz
ports-eb5d10f4aa2fc802ccc19b5c2b36a589b70ba16e.zip
Notes
Diffstat (limited to 'devel/cvstrac/files')
-rw-r--r--devel/cvstrac/files/patch-Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/cvstrac/files/patch-Makefile b/devel/cvstrac/files/patch-Makefile
new file mode 100644
index 000000000000..1defb9884fc9
--- /dev/null
+++ b/devel/cvstrac/files/patch-Makefile
@@ -0,0 +1,37 @@
+--- Makefile.orig Thu May 8 10:58:17 2003
++++ Makefile Thu May 8 10:58:32 2003
+@@ -0,0 +1,34 @@
++#!/usr/bin/make
++#
++#### The toplevel directory of the source tree.
++#
++#SRCDIR = /home/drh/cvstrac/cvstrac
++
++#### C Compiler and options for use in building executables that
++# will run on the platform that is doing the build.
++#
++BCC = gcc -g -O2 -I$(LOCALBASE)/include
++
++#### The suffix to add to executable files. ".exe" for windows.
++# Nothing for unix.
++#
++E =
++
++#### C Compile and options for use in building executables that
++# will run on the target platform. This is usually the same
++# as BCC, unless you are cross-compiling.
++#
++TCC = gcc -g -O0 -Wall -I$(LOCALBASE)/include
++
++#### Extra arguments for linking against SQLite
++#
++LIBSQLITE = -L$(LOCALBASE)/lib -lsqlite -lcrypt
++
++#### Installation directory
++#
++INSTALLDIR = $(PREFIX)/bin
++
++
++# You should not need to change anything below this line
++###############################################################################
++include $(SRCDIR)/main.mk