aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsweb3/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-03-23 12:02:34 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-03-23 12:02:34 +0000
commitcf6e506a1287f61c53d13b15991ccb236b4585cd (patch)
treeae3e870569c3fb1b15aa3ce7b6ccd0cbc2162cef /devel/cvsweb3/Makefile
parentce048dc96fa9713ff26dcc4eb1b5031d5e443bbf (diff)
downloadports-cf6e506a1287f61c53d13b15991ccb236b4585cd.tar.gz
ports-cf6e506a1287f61c53d13b15991ccb236b4585cd.zip
Notes
Diffstat (limited to 'devel/cvsweb3/Makefile')
-rw-r--r--devel/cvsweb3/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/devel/cvsweb3/Makefile b/devel/cvsweb3/Makefile
index fc729a06fd4d..b61866d0237b 100644
--- a/devel/cvsweb3/Makefile
+++ b/devel/cvsweb3/Makefile
@@ -1,14 +1,14 @@
# New ports collection makefile for: cvsweb
-# Version required: 1.0
+# Version required: 1.80
# Date created: 27 Jun 1999
# Whom: SADA Kenji <sada@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= cvsweb-1.0
+DISTNAME= cvsweb-1.80
CATEGORIES= devel www
-MASTER_SITES= http://people.FreeBSD.org/~fenner/cvsweb/
+MASTER_SITES= http://stud.fh-heilbronn.de/~zeller/download/
MAINTAINER= knu@idaemons.org
@@ -23,22 +23,30 @@ CVSROOT= /home/ncvs
# Specify the title of your cvsweb site.
TITLE?= My CVS Repository
-# Specify the cgi-bin directory in relative paths to ${PREFIX}.
+# Specify these directories in relative paths to ${PREFIX}.
CGIDIR?= share/apache/cgi-bin
+ICONSDIR?= share/apache/icons
-PLIST_SUB= CGIDIR="${CGIDIR}"
+PLIST_SUB= CGIDIR="${CGIDIR}" ICONSDIR="${ICONSDIR}"
+
+WRKSRC= ${WRKDIR}/cvsweb
do-configure:
- ${SED} -e "s;!!CVSROOT!!;${CVSROOT};g" \
- -e "s;!!TITLE!!;${TITLE};g" \
- ${WRKSRC}/cvsweb > ${WRKSRC}/cvsweb.cgi
+ cd ${WRKSRC} && ${PERL} -i -pe "\
+ s;!!PREFIX!!;${PREFIX};g; \
+ s;!!CVSROOT!!;${CVSROOT};g; \
+ s;!!TITLE!!;${TITLE};g; \
+ " cvsweb.cgi cvsweb.conf
do-install:
${MKDIR} ${PREFIX}/${CGIDIR}
${INSTALL_SCRIPT} ${WRKSRC}/cvsweb.cgi ${PREFIX}/${CGIDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/cvsweb.conf ${PREFIX}/etc/cvsweb.conf.sample
+ ${MKDIR} ${PREFIX}/${ICONSDIR}/cvsweb
+ cd ${WRKSRC}/icons && ${INSTALL_DATA} * ${PREFIX}/${ICONSDIR}/cvsweb/
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/cvsweb
- cd ${WRKSRC} && ${INSTALL_DATA} README ${PREFIX}/share/doc/cvsweb/
+ cd ${WRKSRC} && ${INSTALL_DATA} INSTALL README TODO ${PREFIX}/share/doc/cvsweb/
.endif
post-install: