aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsweb3
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2004-05-12 07:02:16 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2004-05-12 07:02:16 +0000
commit156fa355eba55197d3740aedd39297bbd243e000 (patch)
treeac9f1d4822d43b4f758ad1d6c2928cc8a674737b /devel/cvsweb3
parent87e207c52874cc0bc9a449e3e102a409ca20f667 (diff)
downloadports-156fa355eba55197d3740aedd39297bbd243e000.tar.gz
ports-156fa355eba55197d3740aedd39297bbd243e000.zip
Notes
Diffstat (limited to 'devel/cvsweb3')
-rw-r--r--devel/cvsweb3/Makefile58
-rw-r--r--devel/cvsweb3/distinfo4
-rw-r--r--devel/cvsweb3/files/patch-cvsweb.cgi20
-rw-r--r--devel/cvsweb3/files/patch-cvsweb.conf87
-rw-r--r--devel/cvsweb3/pkg-descr4
-rw-r--r--devel/cvsweb3/pkg-plist21
6 files changed, 114 insertions, 80 deletions
diff --git a/devel/cvsweb3/Makefile b/devel/cvsweb3/Makefile
index a5376b1eead9..26158fcaa86c 100644
--- a/devel/cvsweb3/Makefile
+++ b/devel/cvsweb3/Makefile
@@ -6,20 +6,39 @@
#
PORTNAME= cvsweb
-PORTVERSION= 2.0.6
-PORTREVISION= 1
+PORTVERSION= 3.0.1
CATEGORIES= devel www
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://people.FreeBSD.org/~scop/cvsweb/
MASTER_SITE_SUBDIR= scop
MAINTAINER= freebsd-cvsweb@FreeBSD.org
-COMMENT= WWW CGI script to browse CVS repository trees
+COMMENT= WWW CGI script to browse CVS repository trees version 3
+
+RUN_DEPENDS= ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+
+# The following extra dependencies are optional, but CVSweb works the
+# best with them.
+RUN_DEPENDS+= ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types \
+ ${SITE_PERL}/${PERL_ARCH}/String/Ediff.pm:${PORTSDIR}/devel/p5-String-Ediff \
+ enscript:${PORTSDIR}/print/enscript-a4 \
+ cvsgraph:${PORTSDIR}/devel/cvsgraph
NO_BUILD= yes
USE_PERL5= yes
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= Port requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
# Specify where your repository belongs.
# (You can reconfigure it after installation anyway)
.if defined(PACKAGE_BUILDING) || !defined(CVSROOT) || empty(CVSROOT)
@@ -30,12 +49,18 @@ CVSROOT= /home/cvs
TITLE?= My CVS Repository
# Specify these directories in relative paths to ${PREFIX}.
-.if !exists(${PREFIX}/www) && exists(${PREFIX}/share/apache)
-CGIDIR?= share/apache/cgi-bin
-ICONSDIR?= share/apache/icons
-.else
+.if exists(${PREFIX}/www/cgi-bin)
CGIDIR?= www/cgi-bin
ICONSDIR?= www/icons
+CSSDIR?= www/data/css
+.elif exists(${PREFIX}/apache/cgi-bin)
+CGIDIR?= apache/cgi-bin
+ICONSDIR?= apache/icons
+CSSDIR?= apache/data/css
+.else
+CGIDIR?= share/apache/cgi-bin
+ICONSDIR?= share/apache/icons
+CSSDIR?= share/apache/data/css
.endif
CONFFILES= cvsweb.conf \
@@ -44,7 +69,7 @@ CONFFILES= cvsweb.conf \
cvsweb.conf-netbsd \
cvsweb.conf-ruby
-PLIST_SUB= CGIDIR="${CGIDIR}" ICONSDIR="${ICONSDIR}"
+PLIST_SUB= CGIDIR="${CGIDIR}" ICONSDIR="${ICONSDIR}" CSSDIR="${CSSDIR}"
post-patch:
${PERL} -i -pe "\
@@ -65,16 +90,23 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/etc/cvsweb/${f}.dist
.endfor
${MKDIR} ${PREFIX}/${ICONSDIR}/cvsweb
- cd ${WRKSRC}/icons && ${INSTALL_DATA} * ${PREFIX}/${ICONSDIR}/cvsweb/
+ ${INSTALL_DATA} ${WRKSRC}/icons/* ${PREFIX}/${ICONSDIR}/cvsweb/
+ ${MKDIR} ${PREFIX}/${CSSDIR}/cvsweb
+ ${INSTALL_DATA} ${WRKSRC}/css/*.css ${PREFIX}/${CSSDIR}/cvsweb/
+ ${INSTALL_DATA} ${WRKSRC}/enscript/*.st ${PREFIX}/share/enscript/hl/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/cvsweb
- cd ${WRKSRC} && ${INSTALL_DATA} ChangeLog INSTALL README README.FreeBSD TODO TODO.FreeBSD ${PREFIX}/share/doc/cvsweb/
+ ${MKDIR} ${DOCSDIR}
+.for f in ChangeLog INSTALL NEWS README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/* ${EXAMPLESDIR}/
.endif
post-install:
.if defined(PACKAGE_BUILDING)
- ${ECHO_CMD} "@unexec rmdir -p %D/${CGIDIR} %D/${ICONSDIR} 2>/dev/null || true" >> ${TMPPLIST}
+ ${ECHO_CMD} "@unexec rmdir -p %D/${CGIDIR} %D/${ICONSDIR} %D/${CSSDIR} 2>/dev/null || true" >> ${TMPPLIST}
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/cvsweb3/distinfo b/devel/cvsweb3/distinfo
index 44d4ceb28d81..2ae4a545c857 100644
--- a/devel/cvsweb3/distinfo
+++ b/devel/cvsweb3/distinfo
@@ -1,2 +1,2 @@
-MD5 (cvsweb-2.0.6.tar.gz) = fd15c8521b26be858616a7ba52fc2c22
-SIZE (cvsweb-2.0.6.tar.gz) = 52659
+MD5 (cvsweb-3.0.1.tar.gz) = 08cc35e620773517b392bea4fc1e9f6b
+SIZE (cvsweb-3.0.1.tar.gz) = 69916
diff --git a/devel/cvsweb3/files/patch-cvsweb.cgi b/devel/cvsweb3/files/patch-cvsweb.cgi
index d1f55a60f264..df18e64f5c30 100644
--- a/devel/cvsweb3/files/patch-cvsweb.cgi
+++ b/devel/cvsweb3/files/patch-cvsweb.cgi
@@ -1,17 +1,17 @@
---- cvsweb.cgi.orig Fri Sep 27 05:56:05 2002
-+++ cvsweb.cgi Tue Feb 24 23:12:51 2004
+--- cvsweb.cgi.orig Sat May 8 23:13:40 2004
++++ cvsweb.cgi Wed May 12 15:27:34 2004
@@ -1,4 +1,4 @@
--#!/usr/bin/perl -wT
-+#!!!PERL!! -w
+-#!/usr/bin/perl -T
++#!!!PERL!! -wT
#
# cvsweb - a CGI interface to CVS trees.
#
-@@ -157,7 +157,7 @@
+@@ -214,7 +214,7 @@
# == EDIT this ==
# Locations to search for user configuration, in order:
--for ("$mydir/cvsweb.conf", '/usr/local/etc/cvsweb/cvsweb.conf') {
-+for ("$mydir/cvsweb.conf", '!!PREFIX!!/etc/cvsweb/cvsweb.conf') {
- if (defined($_) && -r $_) {
- $config = $_;
- last;
+-for (catfile($mydir, 'cvsweb.conf'), '/usr/local/etc/cvsweb/cvsweb.conf') {
++for (catfile($mydir, 'cvsweb.conf'), '!!PREFIX!!/etc/cvsweb/cvsweb.conf') {
+ if (-r $_) {
+ $config = $_;
+ last;
diff --git a/devel/cvsweb3/files/patch-cvsweb.conf b/devel/cvsweb3/files/patch-cvsweb.conf
index c5716494a73e..0a8d28d735d9 100644
--- a/devel/cvsweb3/files/patch-cvsweb.conf
+++ b/devel/cvsweb3/files/patch-cvsweb.conf
@@ -1,52 +1,47 @@
-Index: cvsweb.conf
-===================================================================
-RCS file: /home/ncvs/projects/cvsweb/cvsweb.conf,v
-retrieving revision 1.36
-diff -a -u -r1.36 cvsweb.conf
---- cvsweb.conf 10 Jul 2002 15:30:56 -0000 1.36
-+++ cvsweb.conf 23 Jul 2002 14:15:23 -0000
-@@ -18,7 +18,7 @@
- # uname, cvs, rlog, rcsdiff
- # gzip (if you enable $allow_compress)
- # tar, rm, zip (if you enable $allow_tar)
--$command_path = '/bin:/usr/bin:/usr/local/bin';
-+$command_path = '/bin:/usr/bin:!!PREFIX!!/bin';
-
- # Search the above directories for each command
- for (qw(uname cvs rlog rcsdiff gzip tar rm zip)) {
-@@ -43,7 +43,7 @@
- # 'symbolic_name' => ['name_to_display', 'path_to_the_actual_repository']
- # Listed in the order specified:
+--- cvsweb.conf.orig Wed May 5 08:40:50 2004
++++ cvsweb.conf Wed May 12 15:50:36 2004
+@@ -47,7 +47,7 @@
+ # 'symbolic_name' => ['Name to display', '/path/to/cvsroot']
+ #
@CVSrepositories = (
-- 'local' => ['Local Repository', '/home/cvs'],
-+ 'local' => ['!!TITLE!!', '!!CVSROOT!!'],
- # 'freebsd' => ['FreeBSD', '/home/ncvs'],
- # 'openbsd' => ['OpenBSD', '/home/ncvs'],
- # 'netbsd' => ['NetBSD', '/home/ncvs'],
-@@ -200,7 +200,7 @@
- # These default icons are coming with apache.
- # If these icons are too large, check out the miniicons in the
- # icons/ directory; they have a width/height of 16/16
--my $iconsdir = "/icons";
-+my $iconsdir = "/icons/cvsweb";
+- 'local' => ['Local Repository', '/var/cvs'],
++ 'local' => ['My CVS Repository', '/home/cvs'],
+ # 'freebsd' => ['FreeBSD', '/var/ncvs'],
+ # 'openbsd' => ['OpenBSD', '/var/ncvs'],
+ # 'netbsd' => ['NetBSD', '/var/ncvs'],
+@@ -202,7 +202,7 @@
+ # check out the "mini" versions in the icons/ directory; they have a
+ # width/height of 16/16.
+ #
+-my $iconsdir = '/icons';
++my $iconsdir = '/icons/cvsweb';
- # format: TEXT ICON-URL width height
+ # format: TEXT ICON-URL width height
%ICONS = (
-@@ -335,7 +335,7 @@
- # cvsweb to guess the correct mime-type on
- # checkout; you can use the mime.types from
- # apache here:
--$mime_types = '/usr/local/etc/apache/mime.types';
-+$mime_types = '!!PREFIX!!/etc/apache/mime.types';
+@@ -216,7 +216,7 @@
+
+ # An URL where to find the CSS.
+ #
+-$cssurl = '/css/cvsweb.css';
++$cssurl = '/css/cvsweb/cvsweb.css';
- # quick mime-type lookup; maps file-suffices to
- # mime-types for displaying checkouts in the browser.
-@@ -472,7 +472,7 @@
- $allow_tar = '';
+ # The length to which the last log entry should be truncated when shown
+ # in the directory view.
+@@ -470,7 +470,7 @@
+ # settings in the configuration file with command line options, see
+ # doGraph() and doGraphView() in cvsweb.cgi for details.
+ #
+-#$cvsgraph_config = "/etc/cvsgraph.conf";
++$cvsgraph_config = "!!PREFIX!!/etc/cvsgraph.conf";
- # Options to pass to tar(1).
--@tar_options = qw();
-+@tar_options = qw(--ignore-failed-read);
+ # URL to the CVSHistory script. This should be absolute (but does not need
+ # to include the host and port if the script is on the same server as
+@@ -539,7 +539,7 @@
+ # Enables syntax highlighting using GNU Enscript if set.
+ # You will need GNU Enscript version 1.6.3 or newer for this to work.
+ #
+-#$allow_enscript = $CMD{enscript} ? 1 : 0;
++$allow_enscript = $CMD{enscript} ? 1 : 0;
- # e.g. @tar_options = qw(--ignore-failed-read);
- # GNU tar has some useful options against unexpected errors.
+ # Options to pass to enscript(1).
+ # Do not set the -q, --language, -o or --highlight options here.
diff --git a/devel/cvsweb3/pkg-descr b/devel/cvsweb3/pkg-descr
index a803ebf17e71..2ed5a05e0337 100644
--- a/devel/cvsweb3/pkg-descr
+++ b/devel/cvsweb3/pkg-descr
@@ -8,7 +8,7 @@ for the FreeBSD project, improved visually and functionally by Henner
Zeller <zeller@think.de>, Henrik Nordstrom <hno@hem.passagen.se>, and
Ken Coar <Ken.Coar@Golux.Com>, then Akinori MUSHA <knu@FreeBSD.org>
brought it back to the FreeBSD community and made further
-improvements.
+improvements. FreeBSD-CVSweb is currently maintained by Ville Skytta.
WWW: http://www.FreeBSD.org/projects/cvsweb.html
-Author: the FreeBSD Project
+Author: The FreeBSD Project <freebsd-cvsweb at FreeBSD dot org>
diff --git a/devel/cvsweb3/pkg-plist b/devel/cvsweb3/pkg-plist
index 616f8a0ac59f..07dcd4857b00 100644
--- a/devel/cvsweb3/pkg-plist
+++ b/devel/cvsweb3/pkg-plist
@@ -4,18 +4,25 @@ etc/cvsweb/cvsweb.conf-openbsd.dist
etc/cvsweb/cvsweb.conf-netbsd.dist
etc/cvsweb/cvsweb.conf-ruby.dist
@dirrm etc/cvsweb
-%%PORTDOCS%%share/doc/cvsweb/ChangeLog
-%%PORTDOCS%%share/doc/cvsweb/INSTALL
-%%PORTDOCS%%share/doc/cvsweb/README
-%%PORTDOCS%%share/doc/cvsweb/README.FreeBSD
-%%PORTDOCS%%share/doc/cvsweb/TODO
-%%PORTDOCS%%share/doc/cvsweb/TODO.FreeBSD
-%%PORTDOCS%%@dirrm share/doc/cvsweb
%%CGIDIR%%/cvsweb.cgi
%%ICONSDIR%%/cvsweb/back.gif
+%%ICONSDIR%%/cvsweb/binary.gif
%%ICONSDIR%%/cvsweb/dir.gif
%%ICONSDIR%%/cvsweb/miniback.gif
%%ICONSDIR%%/cvsweb/minidir.gif
+%%ICONSDIR%%/cvsweb/minigraph.png
%%ICONSDIR%%/cvsweb/minitext.gif
%%ICONSDIR%%/cvsweb/text.gif
@dirrm %%ICONSDIR%%/cvsweb
+%%CSSDIR%%/cvsweb/cvsweb.css
+@dirrm %%CSSDIR%%/cvsweb
+share/enscript/hl/lang_cvsweb.st
+share/enscript/hl/lang_cvsweb_diff.st
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%EXAMPLESDIR%%/cvsweb-httpd.conf
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%