aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsweb3
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-10 13:01:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-10 13:01:56 +0000
commitc26e4613b845326c15e7677017019612cecaaf49 (patch)
tree87c297be98bf07652377eb17cfdc0c4a9dc59cbb /devel/cvsweb3
parent34c5e4869367013160a0988749ec338312a7dab0 (diff)
downloadports-c26e4613b845326c15e7677017019612cecaaf49.tar.gz
ports-c26e4613b845326c15e7677017019612cecaaf49.zip
Notes
Diffstat (limited to 'devel/cvsweb3')
-rw-r--r--devel/cvsweb3/Makefile12
-rw-r--r--devel/cvsweb3/files/pkg-message.in (renamed from devel/cvsweb3/pkg-message)4
-rw-r--r--devel/cvsweb3/pkg-plist17
3 files changed, 22 insertions, 11 deletions
diff --git a/devel/cvsweb3/Makefile b/devel/cvsweb3/Makefile
index 2ad125079d03..60e082acd25f 100644
--- a/devel/cvsweb3/Makefile
+++ b/devel/cvsweb3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cvsweb
PORTVERSION= 3.0.5
+PORTREVISION= 1
CATEGORIES= devel www
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://people.FreeBSD.org/~scop/cvsweb/
@@ -24,10 +25,15 @@ RUN_DEPENDS= ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
# best with them.
RUN_DEPENDS+= ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types \
${SITE_PERL}/${PERL_ARCH}/String/Ediff.pm:${PORTSDIR}/devel/p5-String-Ediff \
- enscript:${PORTSDIR}/print/enscript-a4 \
cvsgraph:${PORTSDIR}/devel/cvsgraph
+# Use PAPERSIZE to avoid a stale dependency on Enscript.
+PAPERSIZE?= letter
+RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-${PAPERSIZE}
+
LATEST_LINK= cvsweb3
+CONFLICTS= cvsweb-2.*
+
NO_BUILD= yes
USE_PERL5= yes
@@ -73,6 +79,9 @@ CONFFILES= cvsweb.conf \
PLIST_SUB= CGIDIR="${CGIDIR}" ICONSDIR="${ICONSDIR}" CSSDIR="${CSSDIR}"
+SUB_FILES= pkg-message
+SUB_LIST= PREFIX="${PREFIX}" DOCSDIR="${DOCSDIR}"
+
post-patch:
${PERL} -i -pe "\
s'!!PERL!!'${PERL}'g; \
@@ -95,6 +104,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/icons/* ${PREFIX}/${ICONSDIR}/cvsweb/
${MKDIR} ${PREFIX}/${CSSDIR}/cvsweb
${INSTALL_DATA} ${WRKSRC}/css/*.css ${PREFIX}/${CSSDIR}/cvsweb/
+ ${MKDIR} ${PREFIX}/share/enscript/hl
${INSTALL_DATA} ${WRKSRC}/enscript/*.st ${PREFIX}/share/enscript/hl/
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/devel/cvsweb3/pkg-message b/devel/cvsweb3/files/pkg-message.in
index ee9705c7ed50..942d80831845 100644
--- a/devel/cvsweb3/pkg-message
+++ b/devel/cvsweb3/files/pkg-message.in
@@ -1,6 +1,6 @@
************************************************************
Quickstart:
- cd ${PREFIX}/etc/cvsweb
+ cd %%PREFIX%%/etc/cvsweb
cp cvsweb.conf.dist cvsweb.conf
and you can browse your CVS repository via web if you set up
@@ -11,5 +11,5 @@ will be like `http://localhost/cgi-bin/cvsweb.cgi/'.
browse, edit cvsweb.conf* as you like.
For further information, please look into the directory
-`${PREFIX}/share/doc/cvsweb/'.
+`%%DOCSDIR%%'.
************************************************************
diff --git a/devel/cvsweb3/pkg-plist b/devel/cvsweb3/pkg-plist
index 07dcd4857b00..09882b3b9bfd 100644
--- a/devel/cvsweb3/pkg-plist
+++ b/devel/cvsweb3/pkg-plist
@@ -4,6 +4,14 @@ etc/cvsweb/cvsweb.conf-openbsd.dist
etc/cvsweb/cvsweb.conf-netbsd.dist
etc/cvsweb/cvsweb.conf-ruby.dist
@dirrm etc/cvsweb
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%EXAMPLESDIR%%/cvsweb-httpd.conf
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
%%CGIDIR%%/cvsweb.cgi
%%ICONSDIR%%/cvsweb/back.gif
%%ICONSDIR%%/cvsweb/binary.gif
@@ -18,11 +26,4 @@ etc/cvsweb/cvsweb.conf-ruby.dist
@dirrm %%CSSDIR%%/cvsweb
share/enscript/hl/lang_cvsweb.st
share/enscript/hl/lang_cvsweb_diff.st
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%%%EXAMPLESDIR%%/cvsweb-httpd.conf
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@unexec rmdir %D/share/enscript/hl 2>/dev/null || true