aboutsummaryrefslogtreecommitdiff
path: root/devel/cweb/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-02-11 07:42:14 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-02-11 07:42:14 +0000
commitebdaa8da51df05d62dd97803c8f42cb280846847 (patch)
tree49f28e87992d72984a54ead6783096ecb601fe05 /devel/cweb/Makefile
parentae12c9c8425311c54039e3bbd1628f010a269cda (diff)
Notes
Diffstat (limited to 'devel/cweb/Makefile')
-rw-r--r--devel/cweb/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/cweb/Makefile b/devel/cweb/Makefile
new file mode 100644
index 000000000000..226560fcf90f
--- /dev/null
+++ b/devel/cweb/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: cweb
+# Version required: 3.41
+# Date created: 10 Feb 1998
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= cweb
+PKGNAME= cweb-3.41
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= web/c_cpp/cweb
+
+MAINTAINER= tg@FreeBSD.ORG
+
+NO_WRKSUBDIR= yes
+MAN1= cweb.1
+
+pre-install:
+ @${MKDIR} ${PREFIX}/share/texmf/tex/generic/misc
+ @${MKDIR} ${PREFIX}/share/emacs/site-lisp
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/cweb
+ @${INSTALL_DATA} ${WRKDIR}/cwebman.tex ${PREFIX}/share/doc/cweb
+.endif
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>