aboutsummaryrefslogtreecommitdiff
path: root/devel/cweb
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-20 18:54:50 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-20 18:54:50 +0000
commiteba28cfd74bcd6ee1a8cf54d9cfcbc5f35d36cc2 (patch)
tree92ab7bd4894be54fcd7ff0ab980e693795e62fad /devel/cweb
parenta1006aec4a0dc721eadca32f8e10fd6438714797 (diff)
downloadports-eba28cfd74bcd6ee1a8cf54d9cfcbc5f35d36cc2.tar.gz
ports-eba28cfd74bcd6ee1a8cf54d9cfcbc5f35d36cc2.zip
Notes
Diffstat (limited to 'devel/cweb')
-rw-r--r--devel/cweb/Makefile8
-rw-r--r--devel/cweb/distinfo6
-rw-r--r--devel/cweb/files/patch-aa50
3 files changed, 10 insertions, 54 deletions
diff --git a/devel/cweb/Makefile b/devel/cweb/Makefile
index 35741b82effe..395241c0da13 100644
--- a/devel/cweb/Makefile
+++ b/devel/cweb/Makefile
@@ -6,16 +6,22 @@
#
PORTNAME= cweb
-PORTVERSION= 3.64
+PORTVERSION= 3.64a.a
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= web/c_cpp/cweb
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/.([a-z])$/\1/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Literate programming tools for the C language
NO_WRKSUBDIR= yes
+MAKE_ARGS= CWEBINPUTS="${DATADIR}" \
+ CFLAGS="${CFLAGS}" \
+ LINKFLAGS="" \
+ CC="${CC}"
+
MAN1= cweb.1
post-patch:
diff --git a/devel/cweb/distinfo b/devel/cweb/distinfo
index 379c30acf55b..e65ec8baa8ab 100644
--- a/devel/cweb/distinfo
+++ b/devel/cweb/distinfo
@@ -1,3 +1,3 @@
-MD5 (cweb-3.64.tar.gz) = 49e2abe401ebf1ab008193063b88af2b
-SHA256 (cweb-3.64.tar.gz) = b68fa4cc8a3ada0b4be130c62306a66ff8e74a132afb354a2a0d1581796bcfce
-SIZE (cweb-3.64.tar.gz) = 212010
+MD5 (cweb-3.64aa.tar.gz) = 6391ce4aa8b4083fe24ba1d66a9a673f
+SHA256 (cweb-3.64aa.tar.gz) = 0cde41fd86643aefa80cd1704acfafcb2b485e71fa8dc6277bfd87971004900c
+SIZE (cweb-3.64aa.tar.gz) = 223945
diff --git a/devel/cweb/files/patch-aa b/devel/cweb/files/patch-aa
deleted file mode 100644
index 1ee17f332c9a..000000000000
--- a/devel/cweb/files/patch-aa
+++ /dev/null
@@ -1,50 +0,0 @@
---- Makefile.orig Sat Jul 13 07:33:16 2002
-+++ Makefile Tue Dec 14 23:47:23 2004
-@@ -18,23 +18,23 @@
- #
-
- # directory for TeX inputs (cwebmac.tex goes here)
--MACROSDIR= /usr/local/texmf/tex/generic
-+MACROSDIR= ${PREFIX}/share/texmf/tex/generic/misc
-
- # directory for CWEB inputs in @i files
--CWEBINPUTS= /usr/local/lib/cweb
-+CWEBINPUTS= ${PREFIX}/share/cweb
-
- # extension for manual pages ("l" distinguishes local from system stuff)
--MANEXT= l
--#MANEXT= 1
-+#MANEXT= l
-+MANEXT= 1
-
- # directory for manual pages (cweb.1 goes here)
--MANDIR= /usr/man/man$(MANEXT)
-+MANDIR= ${PREFIX}/man/man$(MANEXT)
-
- # destination directory for executables; must end in /
--DESTDIR= /usr/local/bin/
-+DESTDIR= ${PREFIX}/bin/
-
- # directory for GNU EMACS Lisp code (cweb.el goes here)
--EMACSDIR= /usr/local/emacs/lisp
-+EMACSDIR= ${PREFIX}/share/emacs/site-lisp
-
- # Set DESTPREF to null if you want to call the executables "tangle" and "weave"
- # (probably NOT a good idea; we recommend leaving DESTPREF=c)
-@@ -50,13 +50,13 @@
- WCHANGES=
-
- # We keep debugging info around, for fun, but most users don't need it
--CFLAGS = -g
-+#CFLAGS = -g
- #CFLAGS = -O
--LINKFLAGS = -g
-+#LINKFLAGS = -g
- #LINKFLAGS = -s # for smaller (stripped) executables on many UNIX systems
-
- # What C compiler are you using?
--CC = cc
-+#CC = cc
-
- # RM and CP are used below in case rm and cp are aliased
- RM= /bin/rm